aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-03 11:54:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-03 18:26:41 +0000
commitc7f13313cda239c91fba6fa7bb775817379f0fcd (patch)
treec6ed5b8629419a5f8004d7c849bd386134c11eb0
parent43cc9e6350f0df54ffda5f462bb6553369f6e496 (diff)
downloadports-c7f13313cda239c91fba6fa7bb775817379f0fcd.tar.gz
ports-c7f13313cda239c91fba6fa7bb775817379f0fcd.zip
biology/py-python-libsbml: limit supported python versions, fix build
- Cap supported python verions with 3.9. Fails with 3.10: Traceback (most recent call last): File "/wrkdirs/usr/ports/biology/py-python-libsbml/work-py310/python-libsbml-5.19.0/libsbml_source/src/bindings/python/doc-converter/rewrite_pydoc.py", line 121, in <module> from formatter import NullWriter, AbstractFormatter ModuleNotFoundError: No module named 'formatter' - Fix library stripping to unbreak port with python != 3.8 Approved by: portmgr blanket
-rw-r--r--biology/py-python-libsbml/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/biology/py-python-libsbml/Makefile b/biology/py-python-libsbml/Makefile
index 2acf5ef53d00..33bea5f02f8f 100644
--- a/biology/py-python-libsbml/Makefile
+++ b/biology/py-python-libsbml/Makefile
@@ -12,10 +12,10 @@ LICENSE= LGPL21
BUILD_DEPENDS= cmake:devel/cmake \
swig:devel/swig
-USES= python:3.6+
+USES= python:3.6-3.9
USE_PYTHON= autoplist distutils # autoplist produces incomplete plist, missing files are in pkg-plist. Reported to the upstream author fbergman@caltech.edu on 2021-08-17
post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/libsbml/_libsbml.cpython-38.so
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/libsbml/_libsbml*.so
.include <bsd.port.mk>