aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-07 15:23:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-07 15:24:46 +0000
commitc8234c33e77bef7c00fe5770f6bf7ae680c6dd83 (patch)
tree1beec490abaf7016c1940812d76eba7b7d331109
parent172c0c5438a6f66524a6cfc99e5890aefe83ebcc (diff)
downloadports-c8234c33e77bef7c00fe5770f6bf7ae680c6dd83.tar.gz
ports-c8234c33e77bef7c00fe5770f6bf7ae680c6dd83.zip
{chinese,japanese,korean}/FreeWnn-server: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--japanese/FreeWnn-server/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/japanese/FreeWnn-server/Makefile b/japanese/FreeWnn-server/Makefile
index 040f6ce3ecf2..06a68d53486b 100644
--- a/japanese/FreeWnn-server/Makefile
+++ b/japanese/FreeWnn-server/Makefile
@@ -34,4 +34,14 @@ KWNN_CONFIGURE_ON+= --with-libkwnn=-lkwnn \
--with-kwnn-libraries="${PREFIX}/lib"
KWNN_USE= RC_SUBR=kwnn
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
.include <bsd.port.mk>