aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2023-07-16 18:17:47 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2023-07-16 18:30:29 +0000
commitc83149b2a7e77513adb4ed016604405cf7cb2840 (patch)
tree12fe728dd1b8a30ead8251b1e9625564c9faeaa0
parent6d38380655cd0caadc3cbcb95ee6d4571fa2471b (diff)
downloadports-c83149b2a7e77513adb4ed016604405cf7cb2840.tar.gz
ports-c83149b2a7e77513adb4ed016604405cf7cb2840.zip
math/saga: Update to 9.1.0
Minor release with many improvements, new features and bugfixes. - Moved tools from VIGRA to OpenCV - Clipper2 upgrade to v1.2.2 - Pointcloud improvements and new features - Parallization of topographic correction - Supervised classification: training samples option added - Cloud and cloud shadow detection tools added - Several improvements for the 3D view panel and map - Add a Python package PySAGA for saga-python-api - Moved several tools to better places - ... Changelog: https://sourceforge.net/p/saga-gis/wiki/Changelog%209.1.0/attachment/changelog_saga_9.1.0.txt Reported by: portscout, Repology
-rw-r--r--math/saga/Makefile7
-rw-r--r--math/saga/distinfo6
-rw-r--r--math/saga/files/pkg-message.in40
-rw-r--r--math/saga/pkg-plist20
4 files changed, 31 insertions, 42 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index c50634be8ee1..84d0f663bf94 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -1,5 +1,5 @@
PORTNAME= saga
-PORTVERSION= 9.0.3
+PORTVERSION= 9.1.0
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -29,13 +29,13 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libtiff.so:graphics/tiff
RUN_DEPENDS:= swig:devel/swig
-USES= cmake compiler:c++17-lang dos2unix gnome \
+USES= cmake compiler:c++17-lang desktop-file-utils dos2unix gnome \
iconv:wchar_t libtool localbase pkgconfig python
DOS2UNIX_GLOB= *.cpp *.h
USE_LDCONFIG= yes
USE_WX= 3.2+
-GIT_TAGNAME= d742d4172
+GIT_TAGNAME= 8a8add6b5
CMAKE_ARGS= -DSVM_INCLUDE:PATH=${LOCALBASE}/include/svm.h
CMAKE_ON= CMAKE_VERBOSE_MAKEFILE
@@ -45,6 +45,7 @@ CMAKE_ON+= WITH_MRMR
CMAKE_ON+= WITH_SYSTEM_SVM
CMAKE_ON+= WITH_TOOLS_HPDF
CMAKE_ON+= WITH_TOOLS_OPENCV
+CMAKE_ON+= WITH_PYTHON_PKG
CMAKE_ON+= WITH_TOOLS_PDAL
CMAKE_ON+= WITH_TOOLS_POSTGRES
CMAKE_ON+= WITH_TOOLS_PROJ
diff --git a/math/saga/distinfo b/math/saga/distinfo
index 2b4a24cde542..0e088779e008 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1688571969
-SHA256 (saga-9.0.3.tar.gz) = a6bcaa76b01c4750597508eb46ac416ea86a064124980698373eff6f776c0de4
-SIZE (saga-9.0.3.tar.gz) = 8349202
+TIMESTAMP = 1689518144
+SHA256 (saga-9.1.0.tar.gz) = d3cda84365826b3ca7753b7cd62aa71dd177d192767e001b6a5a91748c7d0a7a
+SIZE (saga-9.1.0.tar.gz) = 8392363
diff --git a/math/saga/files/pkg-message.in b/math/saga/files/pkg-message.in
index 602113b4cd50..2ea3197f1c8a 100644
--- a/math/saga/files/pkg-message.in
+++ b/math/saga/files/pkg-message.in
@@ -1,34 +1,28 @@
[
-{ type: install
+{ type: upgrade
message: <<EOM
-Unlike to windows systems, saga_cmd should be instantly available in
-the shell as it is usually installed in %%PREFIX%%/bin.
-
-Next you have to set the environmental variable SAGA_MLB to make SAGA
-know where the SAGA module libraries exist on your system. You can do
-this permanently by adding the following command to your .bashrc file
-or by defining it temporarily on the command line before executing
-SAGA CMD:
+Your SAGA GIS installation now resides under
+ %%PREFIX%%/lib/saga
- export SAGA_MLB=/yourPathToSAGA_tools
+Besides the graphical user interface saga_gui, saga_cmd is of
+particular importance for the processing of geodata. The
+latter can be used in scripts or directly in the shell.
-e.g.:
- export SAGA_MLB=%%PREFIX%%/lib/saga
-
-Now your system is prepared for using SAGA CMD to execute SAGA
-modules.
-EOM
-}
-{ type: upgrade
- maximum_version: 2.2.0
- message: <<EOM
-From SAGA GIS 2.2.0 on, there is some example and test data installed.
+All extra material like helpers and templates are at
+ %%DATADIR%%/
-Predefined ToolChains are located at
+Predefined ToolChains in xml format are located at
%%DATADIR%%/toolchains/
+
+You will find a ToolChains manual and a cheatsheet at
+ %%DATADIR%%/docs
+
+There is a SAGA Python package, PySAGA, which resides at
+ %%PREFIX%%/lib/python%%PYTHON_VER%%/site-packages/PySAGA
Python scripts with examples, helpers and test data reside at
- %%DATADIR%%/python/
+%%DATADIR%%/python/. A good starting point is the script
+ saga_python_example.py.
EOM
}
]
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index 23fa6ed8088f..6d8c751ab12f 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -35,9 +35,9 @@ lib/libsaga_api.so.%%PORTVERSION%%
lib/libsaga_gdi.so
lib/libsaga_gdi.so.9
lib/libsaga_gdi.so.%%PORTVERSION%%
-%%PYTHON_SITELIBDIR%%/_saga_api.so
-%%PYTHON_SITELIBDIR%%/saga.py
-%%PYTHON_SITELIBDIR%%/saga_api.py
+%%PYTHON_SITELIBDIR%%/PySAGA/__init__.py
+%%PYTHON_SITELIBDIR%%/PySAGA/_saga_api.so
+%%PYTHON_SITELIBDIR%%/PySAGA/saga_api.py
lib/saga/libclimate_tools.so
lib/saga/libcontrib_perego.so
lib/saga/libdb_odbc.so
@@ -137,9 +137,6 @@ share/pixmaps/saga.png
%%DATADIR%%/docs/saga_on_mac_build.sh
%%DATADIR%%/docs/saga_toolchains_cheat_sheet.xml
%%DATADIR%%/docs/saga_toolchains_manual.odt
-@mode 0777
-@dir %%DATADIR%%
-@mode 0666
%%DATADIR%%/helper/convert2utf-8.bat
%%DATADIR%%/helper/convert2utf-8.py
%%DATADIR%%/helper/doxygen_saga_api_chm
@@ -154,18 +151,16 @@ share/pixmaps/saga.png
%%DATADIR%%/helper/make_saga_snapshot.bat
%%DATADIR%%/helper/make_tools_interface.bat
%%DATADIR%%/helper/make_translation_files.bat
-@mode 0755
%%DATADIR%%/helper/saga_python_version_tester.bat
%%DATADIR%%/helper/saga_python_version_tester.py
+%%DATADIR%%/python/__init__.py
%%DATADIR%%/python/helpers/print_version.py
%%DATADIR%%/python/helpers/saga_cmd_param_interface/environment.py
%%DATADIR%%/python/helpers/saga_cmd_param_interface/param_interface.py
%%DATADIR%%/python/helpers/saga_cmd_param_interface/tools.py
-@mode 0666
-%%DATADIR%%/python/saga.py
-%%DATADIR%%/python/saga_python_api.txt
+%%DATADIR%%/python/saga_python_example.bat
%%DATADIR%%/python/saga_python_example.py
-%%DATADIR%%/python/saga_python_runner.bat
+%%DATADIR%%/python/saga_python_readme.txt
%%DATADIR%%/python/test_data/test.mgrd
%%DATADIR%%/python/test_data/test.sdat
%%DATADIR%%/python/test_data/test.sgrd
@@ -206,7 +201,7 @@ share/pixmaps/saga.png
%%DATADIR%%/toolchains/gridding.xml
%%DATADIR%%/toolchains/group_files.xml
%%DATADIR%%/toolchains/imagery.xml
-%%DATADIR%%/toolchains/imagery_fmask_clouds.xml
+%%DATADIR%%/toolchains/imagery_classify_majority.xml
%%DATADIR%%/toolchains/imagery_lczc.xml
%%DATADIR%%/toolchains/import_text_tables.xml
%%DATADIR%%/toolchains/obia.xml
@@ -226,4 +221,3 @@ share/pixmaps/saga.png
%%DATADIR%%/toolchains/tta_tools.xml
%%DATADIR%%/toolchains/twi.xml
%%DATADIR%%/toolchains/upslope_height.xml
-@mode