aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-04-01 22:16:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-04-01 22:19:23 +0000
commitc86015628527041853df223a2950622cecdfd2c4 (patch)
tree69b548abc350d5e325681cec3105d4f2078d3bab
parent2de2a79dd462cbdbaf244462d42d5ec0fbb1302f (diff)
downloadports-c86015628527041853df223a2950622cecdfd2c4.tar.gz
ports-c86015628527041853df223a2950622cecdfd2c4.zip
devel/ga: Add BLAS_SIZE_N options to reflect how science/nwchem expects to be built
-rw-r--r--devel/ga/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/devel/ga/Makefile b/devel/ga/Makefile
index f0cb85027c2d..11c76313375e 100644
--- a/devel/ga/Makefile
+++ b/devel/ga/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ga
DISTVERSION= 5.8.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= https://github.com/GlobalArrays/ga/releases/download/v${DISTVERSION}/
@@ -18,7 +18,7 @@ USES= autoreconf fortran gmake libtool localbase
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-peigs --enable-shared --disable-static --with-blas4 --with-scalapack
+CONFIGURE_ARGS= --enable-peigs --enable-shared --disable-static --with-scalapack
LDFLAGS+= -lscalapack
@@ -27,9 +27,16 @@ TEST_TARGET= check # test asserts, see https://github.com/GlobalArrays/ga/issues
MPIEXEC_ARGS= -np 2
-OPTIONS_RADIO= MPI
-OPTIONS_RADIO_MPI= MPICH OPENMPI
-OPTIONS_DEFAULT= MPICH # the default should be the same as for the MPI option in math/scalapack
+OPTIONS_RADIO= BLAS_SIZE MPI
+OPTIONS_RADIO_BLAS_SIZE= BLAS_SIZE_4 BLAS_SIZE_8 # the default BLAS_SIZE below should be same as the same choice in science/nwchem and in math/blas or math/openblas
+OPTIONS_RADIO_MPI= MPICH OPENMPI # the default MPI choice below should be the same as for the MPI option in math/scalapack
+OPTIONS_DEFAULT= BLAS_SIZE_4 MPICH
+
+BLAS_SIZE_DESC= BLAS_SIZE value to use during build (should be same as in devel/ga)
+BLAS_SIZE_4_DESC= BLAS_SIZE=4
+BLAS_SIZE_4_CONFIGURE_ON= --with-blas4
+BLAS_SIZE_8_DESC= BLAS_SIZE=8
+BLAS_SIZE_8_CONFIGURE_ON= --with-blas8
MPICH_LIB_DEPENDS= libmpich.so:net/mpich
MPICH_VARS= TEST_ARGS+=MPIEXEC="${LOCALBASE}/bin/mpiexec ${MPIEXEC_ARGS}"