aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2024-06-25 13:44:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2024-06-25 19:13:58 +0000
commitc8a36ed58fae02809fb60be49c6b55dec733967e (patch)
tree4359281d632f0667ed831596795511d20a563b06
parentf32032cfbb5811e042a38576c1ddf11da339e448 (diff)
downloadports-c8a36ed58fae02809fb60be49c6b55dec733967e.tar.gz
ports-c8a36ed58fae02809fb60be49c6b55dec733967e.zip
games/openlierox: fix build with libxml 2.13, add license
PR: 279765 Reported by: diizzy
-rw-r--r--games/openlierox/Makefile3
-rw-r--r--games/openlierox/files/patch-include_XMLutils.h10
-rw-r--r--games/openlierox/files/patch-src_common_StringUtils.cpp14
3 files changed, 27 insertions, 0 deletions
diff --git a/games/openlierox/Makefile b/games/openlierox/Makefile
index d04a2184e698..5d37f3dfce64 100644
--- a/games/openlierox/Makefile
+++ b/games/openlierox/Makefile
@@ -10,6 +10,9 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Extremely addictive realtime worms shoot-em-up
WWW= https://openlierox.sourceforge.net/
+LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING.LIB
+
LIB_DEPENDS= libcurl.so:ftp/curl
USES= cmake:insource compiler:c++11-lang gnome localbase pkgconfig \
diff --git a/games/openlierox/files/patch-include_XMLutils.h b/games/openlierox/files/patch-include_XMLutils.h
new file mode 100644
index 000000000000..3dfb0e10777d
--- /dev/null
+++ b/games/openlierox/files/patch-include_XMLutils.h
@@ -0,0 +1,10 @@
+--- include/XMLutils.h.orig 2018-01-30 13:49:55 UTC
++++ include/XMLutils.h
+@@ -17,6 +17,7 @@
+
+ #include <string>
+ #include <libxml/xmlmemory.h>
++#include <libxml/tree.h>
+ #include "Color.h"
+
+ int xmlGetInt(xmlNodePtr node, const std::string& name, int def = 0);
diff --git a/games/openlierox/files/patch-src_common_StringUtils.cpp b/games/openlierox/files/patch-src_common_StringUtils.cpp
new file mode 100644
index 000000000000..ba5a96b679a5
--- /dev/null
+++ b/games/openlierox/files/patch-src_common_StringUtils.cpp
@@ -0,0 +1,14 @@
+--- src/common/StringUtils.cpp.orig 2018-02-01 15:56:41 UTC
++++ src/common/StringUtils.cpp
+@@ -751,7 +751,11 @@ static void charactersParsed(void* context, const xmlC
+ }
+
+ /* GCS: custom error function to ignore errors */
++#if LIBXML_VERSION >= 21300
++static void xmlErrorHandlerDummy(void *, const xmlError *)
++#else
+ static void xmlErrorHandlerDummy(void *, xmlErrorPtr)
++#endif
+ {
+ /* ignore all errors */
+ }