aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 07:15:26 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 07:15:26 +0000
commitc9062744d896f2e8e5b341201cdde1666058c467 (patch)
tree978da5e3b0fa97fbf3e90caa3b1da5ac7ed4d720
parent751c02071a60a5b081f0c6310ab5e9a48c79084d (diff)
downloadports-c9062744d896f2e8e5b341201cdde1666058c467.tar.gz
ports-c9062744d896f2e8e5b341201cdde1666058c467.zip
security/py-base58: Add new port
Base58 and Base58Check implementation compatible with what is used by the bitcoin network.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-base58/Makefile18
-rw-r--r--security/py-base58/distinfo3
-rw-r--r--security/py-base58/pkg-descr4
4 files changed, 26 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d510cd30bb51..c2a99520b98d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -827,6 +827,7 @@
SUBDIR += py-azure-keyvault-certificates
SUBDIR += py-azure-keyvault-keys
SUBDIR += py-azure-keyvault-secrets
+ SUBDIR += py-base58
SUBDIR += py-bcrypt
SUBDIR += py-btchip-python
SUBDIR += py-cerealizer
diff --git a/security/py-base58/Makefile b/security/py-base58/Makefile
new file mode 100644
index 000000000000..56067b275a50
--- /dev/null
+++ b/security/py-base58/Makefile
@@ -0,0 +1,18 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= base58
+PORTVERSION= 2.1.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Bitcoin-compatible Base58 and Base58Check implementation
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python:3.6+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-base58/distinfo b/security/py-base58/distinfo
new file mode 100644
index 000000000000..27eb6ed40e4b
--- /dev/null
+++ b/security/py-base58/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1649176492
+SHA256 (base58-2.1.1.tar.gz) = c5d0cb3f5b6e81e8e35da5754388ddcc6d0d14b6c6a132cb93d69ed580a7278c
+SIZE (base58-2.1.1.tar.gz) = 6528
diff --git a/security/py-base58/pkg-descr b/security/py-base58/pkg-descr
new file mode 100644
index 000000000000..40f22d712da5
--- /dev/null
+++ b/security/py-base58/pkg-descr
@@ -0,0 +1,4 @@
+Base58 and Base58Check implementation compatible with what is used by
+the bitcoin network.
+
+WWW: https://pypi.org/project/base58/