aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2009-09-02 11:55:55 +0000
committerAnton Berezin <tobez@FreeBSD.org>2009-09-02 11:55:55 +0000
commitc927b729fb882cf6e7c157f17795b123b4b7c69d (patch)
tree8dfe087b74d1f2eb9d69b6e0e8e67f62a8fc8023
parent48ee90c8bafeb609c3acef1232b21423a5994a30 (diff)
downloadports-c927b729fb882cf6e7c157f17795b123b4b7c69d.tar.gz
ports-c927b729fb882cf6e7c157f17795b123b4b7c69d.zip
Update to 2.42.
Notes
Notes: svn path=/head/; revision=240708
-rw-r--r--graphics/p5-Chart-Clicker/Makefile24
-rw-r--r--graphics/p5-Chart-Clicker/distinfo6
-rw-r--r--graphics/p5-Chart-Clicker/pkg-plist28
3 files changed, 32 insertions, 26 deletions
diff --git a/graphics/p5-Chart-Clicker/Makefile b/graphics/p5-Chart-Clicker/Makefile
index f4e48649d31d..59bd1c3adede 100644
--- a/graphics/p5-Chart-Clicker/Makefile
+++ b/graphics/p5-Chart-Clicker/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Chart-Clicker
-PORTVERSION= 2.36
+PORTVERSION= 2.42
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +14,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Powerful, extensible charting
-BUILD_DEPENDS= p5-Moose>=0.57:${PORTSDIR}/devel/p5-Moose \
- p5-MooseX-AttributeHelpers>=0.13:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
- p5-Module-Install>=0.64:${PORTSDIR}/devel/p5-Module-Install \
- p5-DateTime-Set>=0.25:${PORTSDIR}/devel/p5-DateTime-Set \
+BUILD_DEPENDS= p5-Color-Palette>=0.091400:${PORTSDIR}/graphics/p5-Color-Palette \
+ p5-Color-Scheme>=1.02:${PORTSDIR}/graphics/p5-Color-Scheme \
+ p5-Moose>=0.76:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-AttributeHelpers>=0.17:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-DateTime>=0.47:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Set>=0.27:${PORTSDIR}/devel/p5-DateTime-Set \
p5-Geometry-Primitive>=0.13:${PORTSDIR}/graphics/p5-Geometry-Primitive \
- p5-Graphics-Primitive>=0.38:${PORTSDIR}/graphics/p5-Graphics-Primitive \
- p5-Graphics-Primitive-Driver-Cairo>=0.33:${PORTSDIR}/graphics/p5-Graphics-Primitive-Driver-Cairo \
- p5-Layout-Manager>=0.20:${PORTSDIR}/graphics/p5-Layout-Manager
+ p5-Graphics-Color>=0.20:${PORTSDIR}/graphics/p5-Graphics-Color \
+ p5-Graphics-Primitive>=0.42:${PORTSDIR}/graphics/p5-Graphics-Primitive \
+ p5-Graphics-Primitive-Driver-Cairo>=0.39:${PORTSDIR}/graphics/p5-Graphics-Primitive-Driver-Cairo \
+ p5-Layout-Manager>=0.29:${PORTSDIR}/graphics/p5-Layout-Manager
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= YES
@@ -42,7 +45,7 @@ MAN3= Chart::Clicker.3 \
Chart::Clicker::Decoration::Glass.3 \
Chart::Clicker::Decoration::Grid.3 \
Chart::Clicker::Decoration::Legend.3 \
- Chart::Clicker::Decoration::LegendItem.3 \
+ Chart::Clicker::Decoration::Legend::Tabular.3 \
Chart::Clicker::Decoration::MarkerOverlay.3 \
Chart::Clicker::Decoration::OverAxis.3 \
Chart::Clicker::Decoration::Plot.3 \
@@ -57,6 +60,7 @@ MAN3= Chart::Clicker.3 \
Chart::Clicker::Renderer::Pie.3 \
Chart::Clicker::Renderer::Point.3 \
Chart::Clicker::Renderer::StackedArea.3 \
- Chart::Clicker::Renderer::StackedBar.3
+ Chart::Clicker::Renderer::StackedBar.3 \
+ Chart::Clicker::Tutorial.3
.include <bsd.port.mk>
diff --git a/graphics/p5-Chart-Clicker/distinfo b/graphics/p5-Chart-Clicker/distinfo
index 31242082affe..c0a9936d8b26 100644
--- a/graphics/p5-Chart-Clicker/distinfo
+++ b/graphics/p5-Chart-Clicker/distinfo
@@ -1,3 +1,3 @@
-MD5 (Chart-Clicker-2.36.tar.gz) = 81f1bda2a38ca0ecc5466f09fffccc60
-SHA256 (Chart-Clicker-2.36.tar.gz) = beb7561fa1fb9b54c3a5295c96051d901c02425612f41375aa89aee817f8bdb7
-SIZE (Chart-Clicker-2.36.tar.gz) = 60671
+MD5 (Chart-Clicker-2.42.tar.gz) = 977e76d655b15f22506241e40d101777
+SHA256 (Chart-Clicker-2.42.tar.gz) = 78c3851cbfb371afe88b7dc07d1f62f98b70f9cf414ff0355532dec41bc1209b
+SIZE (Chart-Clicker-2.42.tar.gz) = 63930
diff --git a/graphics/p5-Chart-Clicker/pkg-plist b/graphics/p5-Chart-Clicker/pkg-plist
index 13ac93215419..6bce653f80b0 100644
--- a/graphics/p5-Chart-Clicker/pkg-plist
+++ b/graphics/p5-Chart-Clicker/pkg-plist
@@ -1,19 +1,27 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Clicker/.packlist
%%SITE_PERL%%/Chart/Clicker.pm
%%SITE_PERL%%/Chart/Clicker/Axis.pm
+%%SITE_PERL%%/Chart/Clicker/Axis/DateTime.pm
%%SITE_PERL%%/Chart/Clicker/Component.pm
%%SITE_PERL%%/Chart/Clicker/Container.pm
%%SITE_PERL%%/Chart/Clicker/Context.pm
+%%SITE_PERL%%/Chart/Clicker/Data/DataSet.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Marker.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Range.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Series.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Series/HighLow.pm
+%%SITE_PERL%%/Chart/Clicker/Data/Series/Size.pm
%%SITE_PERL%%/Chart/Clicker/Decoration.pm
-%%SITE_PERL%%/Chart/Clicker/Positioned.pm
-%%SITE_PERL%%/Chart/Clicker/Renderer.pm
%%SITE_PERL%%/Chart/Clicker/Decoration/Glass.pm
%%SITE_PERL%%/Chart/Clicker/Decoration/Grid.pm
%%SITE_PERL%%/Chart/Clicker/Decoration/Legend.pm
-%%SITE_PERL%%/Chart/Clicker/Decoration/LegendItem.pm
+%%SITE_PERL%%/Chart/Clicker/Decoration/Legend/Tabular.pm
%%SITE_PERL%%/Chart/Clicker/Decoration/MarkerOverlay.pm
%%SITE_PERL%%/Chart/Clicker/Decoration/OverAxis.pm
%%SITE_PERL%%/Chart/Clicker/Decoration/Plot.pm
+%%SITE_PERL%%/Chart/Clicker/Drawing/ColorAllocator.pm
+%%SITE_PERL%%/Chart/Clicker/Positioned.pm
+%%SITE_PERL%%/Chart/Clicker/Renderer.pm
%%SITE_PERL%%/Chart/Clicker/Renderer/Area.pm
%%SITE_PERL%%/Chart/Clicker/Renderer/Bar.pm
%%SITE_PERL%%/Chart/Clicker/Renderer/Bubble.pm
@@ -23,22 +31,16 @@
%%SITE_PERL%%/Chart/Clicker/Renderer/Point.pm
%%SITE_PERL%%/Chart/Clicker/Renderer/StackedArea.pm
%%SITE_PERL%%/Chart/Clicker/Renderer/StackedBar.pm
-%%SITE_PERL%%/Chart/Clicker/Drawing/ColorAllocator.pm
-%%SITE_PERL%%/Chart/Clicker/Axis/DateTime.pm
-%%SITE_PERL%%/Chart/Clicker/Data/DataSet.pm
-%%SITE_PERL%%/Chart/Clicker/Data/Range.pm
-%%SITE_PERL%%/Chart/Clicker/Data/Marker.pm
-%%SITE_PERL%%/Chart/Clicker/Data/Series.pm
-%%SITE_PERL%%/Chart/Clicker/Data/Series/HighLow.pm
-%%SITE_PERL%%/Chart/Clicker/Data/Series/Size.pm
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Clicker
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart
+%%SITE_PERL%%/Chart/Clicker/Tutorial.pod
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Shape
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Renderer
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Drawing
+@dirrmtry %%SITE_PERL%%/Chart/Clicker/Decoration/Legend
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Decoration
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Data/Series
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Data
@dirrmtry %%SITE_PERL%%/Chart/Clicker/Axis
@dirrmtry %%SITE_PERL%%/Chart/Clicker
@dirrmtry %%SITE_PERL%%/Chart
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart/Clicker
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chart