aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Neubauer <m.ne@gmx.net>2023-05-29 06:40:00 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-05-30 06:08:05 +0000
commitca82785515c8ecfa4bab73b7539a688c343f327e (patch)
tree7652e9b14f591b869a00cab9a3d3df8d97f2b404
parent8cb2876b3fff97e43ce7358db000a111f1aee9a6 (diff)
downloadports-ca82785515c8ecfa4bab73b7539a688c343f327e.tar.gz
ports-ca82785515c8ecfa4bab73b7539a688c343f327e.zip
audio/alsa-plugins: fix build with FFMPEG option enabled
After the update to ffmpeg 6 the configure script failed to recognise the components needed, causing packaging errors later on. Changing the dependency to the new ffmpeg4 port fixes this. PR: 271641 Reported by: m.ne@gmx.net
-rw-r--r--audio/alsa-plugins/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/audio/alsa-plugins/Makefile b/audio/alsa-plugins/Makefile
index 5d7ab3fcdc3d..92788a29cc1b 100644
--- a/audio/alsa-plugins/Makefile
+++ b/audio/alsa-plugins/Makefile
@@ -1,6 +1,6 @@
PORTNAME= alsa-plugins
PORTVERSION= 1.2.2
-PORTREVISION= 9
+PORTREVISION= 10
DISTVERSIONPREFIX= v
CATEGORIES= audio
MASTER_SITES= GH
@@ -39,8 +39,10 @@ BLKCNT_P2_CFLAGS= -DFREEBSD_OSS_BLKCNT_P2
BUFSZ_P2_CFLAGS= -DFREEBSD_OSS_BUFSZ_P2
VERBOSE_CFLAGS= -DALSA_OSS_DEBUG_VERBOSE
-FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
+FFMPEG_LIB_DEPENDS= libavcodec.so.58:multimedia/ffmpeg4
FFMPEG_CONFIGURE_ENABLE= libav
+FFMPEG_CONFIGURE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
+FFMPEG_MAKE_ENV+= PKG_CONFIG_PATH="${LOCALBASE}/ffmpeg4/libdata/pkgconfig"
JACK_LIB_DEPENDS= libjack.so:audio/jack
JACK_CONFIGURE_ENABLE= jack