aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <felix@palmen-it.de>2021-10-19 15:59:13 +0000
committerMichael Zhilin <mizhka@FreeBSD.org>2021-11-01 06:14:41 +0000
commitca9de5d4536e09be93db2e3dd610412bd781d689 (patch)
tree2508c9083e338d17cf6c6fb7d434c1a822593592
parent51c8c9bdc20f2c5166fa98f9c14b1000a0f199d7 (diff)
downloadports-ca9de5d4536e09be93db2e3dd610412bd781d689.tar.gz
ports-ca9de5d4536e09be93db2e3dd610412bd781d689.zip
databases/postgresql-plv8js: disable C++ RTTI
Fixes /usr/local/lib/postgresql/plv8-3.0.0.so: Undefined symbol "_ZTIN2v811ArrayBuffer9AllocatorE" Also enable V8 pointer compression, fixes Embedder-vs-V8 build configuration mismatch. On embedder side pointer compression is DISABLED while on V8 side it's ENABLED. PR: 259262 Reported by: ryan@cybership.net Submitted by: felix@palmen-it.de Sponsored by: Postgres Professional
-rw-r--r--databases/postgresql-plv8js/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/databases/postgresql-plv8js/Makefile b/databases/postgresql-plv8js/Makefile
index 5bae9ecee678..94574cccfa88 100644
--- a/databases/postgresql-plv8js/Makefile
+++ b/databases/postgresql-plv8js/Makefile
@@ -2,7 +2,7 @@
PORTNAME= plv8
PORTVERSION= 3.0.0
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= v
CATEGORIES= databases
PKGNAMEPREFIX= postgresql${PGSQL_VER:S/.//}-
@@ -16,12 +16,13 @@ LICENSE= PostgreSQL
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libv8.so:lang/v8
-USES= compiler:c++14-lang gmake perl5 pgsql:9.6-10
+USES= compiler:c++14-lang gmake perl5 pgsql
USE_PERL5= build
USE_GITHUB= yes
PLIST_SUB= PORTVERSION="${PORTVERSION}"
-CXXFLAGS+= -std=c++14
+CXXFLAGS+= -std=c++14 -fno-rtti \
+ -DV8_COMPRESS_POINTERS=1 -DV8_31BIT_SMIS_ON_64BIT_ARCH=1
MAKEFILE= Makefile.shared
MAKE_ARGS= CUSTOM_CC=${CXX} CCFLAGS="${CXXFLAGS}"