aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2024-03-22 18:35:37 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2024-03-22 18:43:25 +0000
commitcab93d2304d3214c4578ea5726dd519a3acd83d0 (patch)
treeeeebf5c6959f326ee863144c22b34fb583f218a9
parent1c9739605bf55589f5baed10bb4282e3fd63196c (diff)
downloadports-cab93d2304d3214c4578ea5726dd519a3acd83d0.tar.gz
ports-cab93d2304d3214c4578ea5726dd519a3acd83d0.zip
Mk/bsd.options.mk: add possibility set default options for other (not defined in port) arches
New port option OPTIONS_DEFAULT_OTHER_ARCHS. Examples are at review. Approved by: arrowd (portmgr, mentor) Differential Revision: https://reviews.freebsd.org/D44228
-rw-r--r--Mk/bsd.options.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 83a03c885ff0..964b817ff706 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -219,7 +219,11 @@ OPTIONS_DEFINE+= ${opt}
. endfor
# Add per arch defaults
+. if defined(OPTIONS_DEFAULT_${ARCH})
OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_${ARCH}}
+. else
+OPTIONS_DEFAULT+= ${OPTIONS_DEFAULT_OTHER_ARCHS}
+. endif
_ALL_EXCLUDE= ${OPTIONS_EXCLUDE_${ARCH}} ${OPTIONS_EXCLUDE} \
${OPTIONS_SLAVE} ${OPTIONS_EXCLUDE_${OPSYS}} \