aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@FreeBSD.org>2023-02-11 07:39:53 +0000
committerYasuhiro Kimura <yasu@FreeBSD.org>2023-02-11 08:42:26 +0000
commitcb188cbfd474c422243e87675e6e0861de4e1fc2 (patch)
treedb83646816151d2a3a28fd7df500772e45ccf4d8
parent1566fe1dab272560ca8e8225edf12514a6147368 (diff)
downloadports-cb188cbfd474c422243e87675e6e0861de4e1fc2.tar.gz
ports-cb188cbfd474c422243e87675e6e0861de4e1fc2.zip
databases/db18: Fix build with LLVM15
MFH: 2023Q1
-rw-r--r--databases/db18/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/db18/Makefile b/databases/db18/Makefile
index 20c649aa45d4..0c9eab17bc61 100644
--- a/databases/db18/Makefile
+++ b/databases/db18/Makefile
@@ -38,7 +38,8 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/bin/${PORTNAME} \
MAKE_ARGS+= docdir=${DOCSDIR}
INSTALL_TARGET= install_include install_lib install_utilities
-CFLAGS+= -I${OPENSSLINC}
+CFLAGS+= -I${OPENSSLINC} -Wno-deprecated-non-prototype \
+ -Wno-incompatible-library-redeclaration -Wno-int-conversion
CPPFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}