aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-10-11 14:46:57 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-07 22:39:16 +0000
commitcb303a7043617a189b1efcac64fb088bcb6f528f (patch)
treea4834a998085cd579bcff9ddc78d38ca55b0a333
parent48f7263ba853a28936f456e64ccf472fd1ab8ff5 (diff)
downloadports-cb303a7043617a189b1efcac64fb088bcb6f528f.tar.gz
ports-cb303a7043617a189b1efcac64fb088bcb6f528f.zip
x11-wm/kwinft: update to 5.26.0 after d06d26f8c45e
-rw-r--r--x11-wm/kwinft/Makefile28
-rw-r--r--x11-wm/kwinft/distinfo8
-rw-r--r--x11-wm/kwinft/files/patch-xwl_xwayland.cpp34
-rw-r--r--x11-wm/kwinft/pkg-plist17
4 files changed, 34 insertions, 53 deletions
diff --git a/x11-wm/kwinft/Makefile b/x11-wm/kwinft/Makefile
index 3c698b2a400b..ee5cbd3afc6f 100644
--- a/x11-wm/kwinft/Makefile
+++ b/x11-wm/kwinft/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kwinft
DISTVERSIONPREFIX= ${PORTNAME}@
-DISTVERSION= 5.25.0
+DISTVERSION= 5.26.0
CATEGORIES= x11-wm wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -10,8 +10,6 @@ WWW= https://gitlab.com/kwinft/kwinft
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= requires https://gitlab.com/kwinft/kwinft/-/commit/2f5ba95e376f
-
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libwayland-server.so:graphics/wayland \
@@ -42,7 +40,7 @@ USE_QT= qmake:build buildtools:build core dbus declarative gui \
multimedia:run quickcontrols2:run widgets x11extras
USE_XORG= pixman x11 xcb xi
SHEBANG_FILES= effect/effects/*.py kconf_update/*.py kconf_update/*.pl
-GL_COMMIT= a70cd81ac8f81189782831e52b6fec01aeeefdfd
+GL_COMMIT= 3005b261c7e069a2cee5f35ed676356b1a8c11b0
PLIST_SUB= VERSION=${PORTVERSION}
LDFLAGS+= -Wl,--as-needed # GL, ICE/SM/Xext, glib, intl, Qt5*, KF5*
@@ -60,5 +58,27 @@ QA11Y_DESC= Accessibility (focus tracking) for Zoom effect
QA11Y_LIB_DEPENDS= libqaccessibilityclient-qt5.so:accessibility/libqaccessibilityclient
QA11Y_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_QAccessibilityClient
+# XXX Drop after FreeBSD 12.3 EOL around 2023-03-01 (don't forget distinfo)
+.if !exists(/usr/include/c++/v1/concepts) || make(makesum) || make(fetch)
+USES+= llvm:13,build
+CC= clang${LLVM_VERSION}
+CXX= clang++${LLVM_VERSION}
+CPP= clang-cpp${LLVM_VERSION}
+
+# XXX Move into separate port and standardize via USES
+USE_GITHUB= nodefault
+GH_TUPLE+= llvm:llvm-project:llvmorg-13.0.1:libcxx
+CXXFLAGS+= -nostdinc++ -isystem${WRKDIR}/libcxx_prefix/include/c++/v1
+# Don't link against new libc++ to avoid ABI mismatch in Qt
+#LDFLAGS+= -nostdlib++ -L${WRKDIR}/libcxx_prefix/lib -l:libc++.a -lcxxrt
+
+pre-configure: bundled-libcxx
+bundled-libcxx:
+ @${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS:M*Ninja*} \
+ -DCMAKE_INSTALL_PREFIX:PATH=${WRKDIR}/libcxx_prefix \
+ -B ${WRKDIR}/libcxx_build -S ${WRKSRC_libcxx}/libcxx
+ @${DO_MAKE_BUILD:NDESTDIR*} install -C ${WRKDIR}/libcxx_build
+.endif
+
.include "${.CURDIR:H:H}/x11-toolkits/wlroots015/override.mk"
.include <bsd.port.mk>
diff --git a/x11-wm/kwinft/distinfo b/x11-wm/kwinft/distinfo
index 8f606fa3adf7..9b9544fa7cf5 100644
--- a/x11-wm/kwinft/distinfo
+++ b/x11-wm/kwinft/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1655228107
-SHA256 (kwinft-kwinft-a70cd81ac8f81189782831e52b6fec01aeeefdfd_GL0.tar.gz) = 68c5df0b9d0dba56391c8e4ec788a7d1a64c2195d6312b360d79c3afe76c5389
-SIZE (kwinft-kwinft-a70cd81ac8f81189782831e52b6fec01aeeefdfd_GL0.tar.gz) = 4988371
+TIMESTAMP = 1665499617
+SHA256 (llvm-llvm-project-llvmorg-13.0.1_GH0.tar.gz) = 09c50d558bd975c41157364421820228df66632802a4a6a7c9c17f86a7340802
+SIZE (llvm-llvm-project-llvmorg-13.0.1_GH0.tar.gz) = 147290251
+SHA256 (kwinft-kwinft-3005b261c7e069a2cee5f35ed676356b1a8c11b0_GL0.tar.gz) = 8ca664a1a780be5c0fed63abbd145624a308404742903591e353790028ba66ba
+SIZE (kwinft-kwinft-3005b261c7e069a2cee5f35ed676356b1a8c11b0_GL0.tar.gz) = 5021610
diff --git a/x11-wm/kwinft/files/patch-xwl_xwayland.cpp b/x11-wm/kwinft/files/patch-xwl_xwayland.cpp
deleted file mode 100644
index 38481a7c9916..000000000000
--- a/x11-wm/kwinft/files/patch-xwl_xwayland.cpp
+++ /dev/null
@@ -1,34 +0,0 @@
-Revert https://gitlab.com/kwinft/kwinft/-/commit/e22b49694e87
-
-xwl/xwayland.cpp:64:5: error: use of undeclared identifier 'close'
- close(pipe);
- ^
-xwl/xwayland.cpp:79:9: error: use of undeclared identifier 'pipe'
- if (pipe(pipeFds) != 0) {
- ^
-xwl/xwayland.cpp:88:14: error: use of undeclared identifier 'dup'
- int fd = dup(sx[1]);
- ^
-xwl/xwayland.cpp:96:9: error: use of undeclared identifier 'close'
- close(fd);
- ^
-xwl/xwayland.cpp:99:23: error: use of undeclared identifier 'dup'
- auto const wlfd = dup(waylandSocket);
- ^
-xwl/xwayland.cpp:101:9: error: use of undeclared identifier 'close'
- close(fd);
- ^
-xwl/xwayland.cpp:153:5: error: use of undeclared identifier 'close'
- close(pipeFds[1]);
- ^
-
---- xwl/xwayland.cpp.orig 2022-06-14 17:35:07 UTC
-+++ xwl/xwayland.cpp
-@@ -44,6 +44,7 @@ along with this program. If not, see <http://www.gnu.
- #include <compositor.h>
- #include <iostream>
- #include <sys/socket.h>
-+#include <unistd.h>
-
- static void readDisplay(int pipe)
- {
diff --git a/x11-wm/kwinft/pkg-plist b/x11-wm/kwinft/pkg-plist
index c12d73794517..86e3ff47847e 100644
--- a/x11-wm/kwinft/pkg-plist
+++ b/x11-wm/kwinft/pkg-plist
@@ -4,11 +4,9 @@ bin/kwin_x11
include/kwin_export.h
include/kwinanimationeffect.h
include/kwinconfig.h
-include/kwindeformeffect.h
include/kwineffectquickview.h
include/kwineffects.h
include/kwineffects/animation_effect.h
-include/kwineffects/deform_effect.h
include/kwineffects/effect.h
include/kwineffects/effect_frame.h
include/kwineffects/effect_integration.h
@@ -19,6 +17,7 @@ include/kwineffects/effect_window.h
include/kwineffects/effects_handler.h
include/kwineffects/export.h
include/kwineffects/motions.h
+include/kwineffects/offscreen_effect.h
include/kwineffects/paint_clipper.h
include/kwineffects/paint_data.h
include/kwineffects/time_line.h
@@ -36,6 +35,7 @@ include/kwingltexture.h
include/kwinglutils.h
include/kwinglutils_export.h
include/kwinglutils_funcs.h
+include/kwinoffscreeneffect.h
include/kwinxrender/export.h
include/kwinxrender/utils.h
include/kwinxrenderutils.h
@@ -123,8 +123,7 @@ share/applications/kcm_kwin_virtualdesktops.desktop
share/applications/kcm_kwindecoration.desktop
share/applications/kcm_kwinoptions.desktop
share/applications/kcm_kwinrules.desktop
-share/applications/kcm_kwinscreenedges.desktop
-share/applications/kcm_kwintouchscreen.desktop
+share/applications/kcm_kwintabbox.desktop
share/applications/kwincompositing.desktop
share/applications/org.kde.kwin_rules_dialog.desktop
share/config.kcfg/kwin.kcfg
@@ -208,6 +207,7 @@ share/kconf_update/kwin-5.23-placement.pl
share/kconf_update/kwin.upd
share/kconf_update/kwinrules-5.19-placement.pl
share/kconf_update/kwinrules-5.23-placement.pl
+share/kconf_update/kwinrules-5.23-virtual-desktop-ids.py
share/kconf_update/kwinrules.upd
share/knotifications5/kwin.notifyrc
share/knsrcfiles/aurorae.knsrc
@@ -218,27 +218,20 @@ share/knsrcfiles/window-decorations.knsrc
share/kpackage/kcms/kcm_kwin_effects/contents/ui/Effect.qml
share/kpackage/kcms/kcm_kwin_effects/contents/ui/Video.qml
share/kpackage/kcms/kcm_kwin_effects/contents/ui/main.qml
-share/kpackage/kcms/kcm_kwin_effects/metadata.desktop
-share/kpackage/kcms/kcm_kwin_effects/metadata.json
share/kpackage/kcms/kcm_kwin_scripts/contents/ui/main.qml
share/kpackage/kcms/kcm_kwin_virtualdesktops/contents/ui/main.qml
-share/kpackage/kcms/kcm_kwin_virtualdesktops/metadata.desktop
-share/kpackage/kcms/kcm_kwin_virtualdesktops/metadata.json
share/kpackage/kcms/kcm_kwindecoration/contents/ui/ButtonGroup.qml
share/kpackage/kcms/kcm_kwindecoration/contents/ui/Buttons.qml
share/kpackage/kcms/kcm_kwindecoration/contents/ui/Themes.qml
share/kpackage/kcms/kcm_kwindecoration/contents/ui/main.qml
-share/kpackage/kcms/kcm_kwindecoration/metadata.desktop
-share/kpackage/kcms/kcm_kwindecoration/metadata.json
share/kpackage/kcms/kcm_kwinrules/contents/ui/FileDialogLoader.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/OptionsComboBox.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/RuleItemDelegate.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/RulesEditor.qml
-share/kpackage/kcms/kcm_kwinrules/contents/ui/RulesList.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/ValueEditor.qml
+share/kpackage/kcms/kcm_kwinrules/contents/ui/main.qml
share/kpackage/kcms/kcm_kwinrules/metadata.desktop
share/kpackage/kcms/kcm_kwinrules/metadata.json
-share/kservices5/kcm_kwintabbox.desktop
share/kservices5/kwin/kwin4_decoration_qml_plastik.desktop
share/kservicetypes5/kwindecoration.desktop
share/kservicetypes5/kwindesktopswitcher.desktop