aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-05-31 12:09:49 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-05-31 12:09:49 +0000
commitcb57e6ca4f880641c17fd9f0e1ec5638d7b6dc83 (patch)
tree0db8b4fd7b4219eab18db74adb78de2ca763eae3
parent162e1461c4f40f9d85cda1539984f355a2ba3e65 (diff)
downloadports-cb57e6ca4f880641c17fd9f0e1ec5638d7b6dc83.tar.gz
ports-cb57e6ca4f880641c17fd9f0e1ec5638d7b6dc83.zip
Fix autoscan script with newer versions of Perl (escape left brace in regex)
PR: 209768 Submitted by: mat
Notes
Notes: svn path=/head/; revision=416194
-rw-r--r--devel/autoconf/Makefile1
-rw-r--r--devel/autoconf/files/patch-bin-autoscan.in11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index 09cb64088c84..da2b8dde268b 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -3,6 +3,7 @@
PORTNAME= autoconf
PORTVERSION= 2.69
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU
DISTNAME= autoconf-${PORTVERSION}
diff --git a/devel/autoconf/files/patch-bin-autoscan.in b/devel/autoconf/files/patch-bin-autoscan.in
new file mode 100644
index 000000000000..a55345cc5593
--- /dev/null
+++ b/devel/autoconf/files/patch-bin-autoscan.in
@@ -0,0 +1,11 @@
+--- bin/autoscan.in.orig 2012-04-25 02:37:26 UTC
++++ bin/autoscan.in
+@@ -358,7 +358,7 @@ sub scan_sh_file ($)
+ {
+ # Strip out comments and variable references.
+ s/#.*//;
+- s/\${[^\}]*}//g;
++ s/\$\{[^\}]*}//g;
+ s/@[^@]*@//g;
+
+ # Tokens in the code.