aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-21 20:57:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-22 01:37:21 +0000
commitcb6ca134ee11502a336336d5be35b4d82eaa2de4 (patch)
tree5aff11010a267447ffc52515a17ef0b78ab47b8f
parentb5fd5c2ceaa4ffed24fbc37eb2aa4c343c2bd63b (diff)
science/py-hoomd-blue: Backport patch supporting latest cereal.
-rw-r--r--science/py-hoomd-blue/Makefile3
-rw-r--r--science/py-hoomd-blue/distinfo4
-rw-r--r--science/py-hoomd-blue/files/patch-CMake_hoomd_HOOMDMPISetup.cmake11
-rw-r--r--science/py-hoomd-blue/files/patch-hoomd_CMakeLists.txt11
4 files changed, 6 insertions, 23 deletions
diff --git a/science/py-hoomd-blue/Makefile b/science/py-hoomd-blue/Makefile
index c6f16513e948..a2de9dba94a5 100644
--- a/science/py-hoomd-blue/Makefile
+++ b/science/py-hoomd-blue/Makefile
@@ -4,6 +4,9 @@ DISTVERSION= 3.0.0-beta.13
CATEGORIES= science # physics
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
+PATCHFILES= 3f8ed3abb36aa51c6d91c3ff1c1563ffc6ee37c2.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Molecular dynamics and Monte Carlo soft matter simulation
diff --git a/science/py-hoomd-blue/distinfo b/science/py-hoomd-blue/distinfo
index 4452bb97ba91..4430413de391 100644
--- a/science/py-hoomd-blue/distinfo
+++ b/science/py-hoomd-blue/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1642744229
+TIMESTAMP = 1642797728
SHA256 (glotzerlab-hoomd-blue-v3.0.0-beta.13_GH0.tar.gz) = e655a9afc7a8f7fe668552e0ffd9ba4a38884e791afd8ab45d81cc0df614fb40
SIZE (glotzerlab-hoomd-blue-v3.0.0-beta.13_GH0.tar.gz) = 2525133
SHA256 (glotzerlab-libgetar-85de0f2355ea938474452aaf6bb78904a91293ec_GH0.tar.gz) = 12815869b556c09f537e3d5ebed830298c61d458a8c967a60f7af607201750ed
@@ -25,3 +25,5 @@ SHA256 (glotzerlab-hoomd-examples-5a5e4e11e96397b761e90b27983cc38e2fb1a324_GH0.t
SIZE (glotzerlab-hoomd-examples-5a5e4e11e96397b761e90b27983cc38e2fb1a324_GH0.tar.gz) = 5054053
SHA256 (mphowardlab-hipper-b6da049a516ada03e4e1b66ca6b4c2c7c9668595_GH0.tar.gz) = c64a484884eaab3eb9fd8f7b27b144a7bfadfeab101e95d82bc2a6f7e4fb7cec
SIZE (mphowardlab-hipper-b6da049a516ada03e4e1b66ca6b4c2c7c9668595_GH0.tar.gz) = 20228
+SHA256 (3f8ed3abb36aa51c6d91c3ff1c1563ffc6ee37c2.patch) = c2e0fecf532d9a73dd42cfce40302d7fe8402ff5d98620b70aca434032c1d0c9
+SIZE (3f8ed3abb36aa51c6d91c3ff1c1563ffc6ee37c2.patch) = 2719
diff --git a/science/py-hoomd-blue/files/patch-CMake_hoomd_HOOMDMPISetup.cmake b/science/py-hoomd-blue/files/patch-CMake_hoomd_HOOMDMPISetup.cmake
deleted file mode 100644
index 51c295f79964..000000000000
--- a/science/py-hoomd-blue/files/patch-CMake_hoomd_HOOMDMPISetup.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- CMake/hoomd/HOOMDMPISetup.cmake.orig 2022-01-21 08:21:04 UTC
-+++ CMake/hoomd/HOOMDMPISetup.cmake
-@@ -13,7 +13,7 @@ if (ENABLE_MPI)
-
- find_path(cereal_INCLUDE_DIR NAMES cereal/cereal.hpp
- PATHS ${CMAKE_INSTALL_PREFIX}/include)
-- add_library(cereal INTERFACE IMPORTED)
-+ #add_library(cereal INTERFACE IMPORTED)
- set_target_properties(cereal PROPERTIES INTERFACE_INCLUDE_DIRECTORIES "${cereal_INCLUDE_DIR}")
- find_package_message(cereal "Could not find cereal, assuming it is on a default path" "[${cereal_INCLUDE_DIR}]")
- endif()
diff --git a/science/py-hoomd-blue/files/patch-hoomd_CMakeLists.txt b/science/py-hoomd-blue/files/patch-hoomd_CMakeLists.txt
deleted file mode 100644
index 0e99b6d6de1b..000000000000
--- a/science/py-hoomd-blue/files/patch-hoomd_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- hoomd/CMakeLists.txt.orig 2022-01-21 08:28:13 UTC
-+++ hoomd/CMakeLists.txt
-@@ -338,7 +338,7 @@ endif()
- # Libraries and compile definitions for MPI enabled builds
- if (ENABLE_MPI)
- target_compile_definitions(_hoomd PUBLIC ENABLE_MPI)
-- target_link_libraries(_hoomd PUBLIC MPI::MPI_CXX cereal)
-+ target_link_libraries(_hoomd PUBLIC MPI::MPI_CXX)
-
- if (ENABLE_MPI_CUDA)
- target_compile_definitions(_hoomd PUBLIC ENABLE_MPI_CUDA)