aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:09:55 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-11-19 08:09:55 +0000
commitcb8efe9d2fcfd80b302ec64e054c1f8cfc002df8 (patch)
tree3135bd2e5b17e0b129e499276bdfd43970878e22
parent97a6d0658931454ebaa96079e9c240185dda2d93 (diff)
downloadports-cb8efe9d2fcfd80b302ec64e054c1f8cfc002df8.tar.gz
ports-cb8efe9d2fcfd80b302ec64e054c1f8cfc002df8.zip
devel/py-pytest-console-scripts: Add py-pytest-console-scripts 1.3.1
Pytest-console-scripts is a pytest plugin for running python scripts from within tests. It's quite similar to subprocess.run(), but it also has an in-process mode, where the scripts are executed by the interpreter that's running pytest (using some amount of sandboxing). In-process mode significantly reduces the run time of the test suites that run many external scripts. This is speeds up development. In the CI environment subprocess mode can be used to make sure the scripts also work (and behave the same) when run by a fresh interpreter.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pytest-console-scripts/Makefile22
-rw-r--r--devel/py-pytest-console-scripts/distinfo3
-rw-r--r--devel/py-pytest-console-scripts/pkg-descr9
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c9d84159dec2..b4696168455a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5140,6 +5140,7 @@
SUBDIR += py-pytest-canonical-data
SUBDIR += py-pytest-capturelog
SUBDIR += py-pytest-checkdocs
+ SUBDIR += py-pytest-console-scripts
SUBDIR += py-pytest-cov
SUBDIR += py-pytest-datadir
SUBDIR += py-pytest-django
diff --git a/devel/py-pytest-console-scripts/Makefile b/devel/py-pytest-console-scripts/Makefile
new file mode 100644
index 000000000000..0bb2d19b6e32
--- /dev/null
+++ b/devel/py-pytest-console-scripts/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= pytest-console-scripts
+PORTVERSION= 1.3.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Pytest plugin for testing console scripts
+WWW= https://github.com/kvas-it/pytest-console-scripts
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=4.0.0,1:devel/py-pytest@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-pytest-console-scripts/distinfo b/devel/py-pytest-console-scripts/distinfo
new file mode 100644
index 000000000000..8b81d8c03663
--- /dev/null
+++ b/devel/py-pytest-console-scripts/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1665651054
+SHA256 (pytest-console-scripts-1.3.1.tar.gz) = 5c6c3daae9cf9fbed0e655072128938600193dc002a5cf1b187248644ba02857
+SIZE (pytest-console-scripts-1.3.1.tar.gz) = 14238
diff --git a/devel/py-pytest-console-scripts/pkg-descr b/devel/py-pytest-console-scripts/pkg-descr
new file mode 100644
index 000000000000..125628b54db4
--- /dev/null
+++ b/devel/py-pytest-console-scripts/pkg-descr
@@ -0,0 +1,9 @@
+Pytest-console-scripts is a pytest plugin for running python scripts from within
+tests. It's quite similar to subprocess.run(), but it also has an in-process
+mode, where the scripts are executed by the interpreter that's running pytest
+(using some amount of sandboxing).
+
+In-process mode significantly reduces the run time of the test suites that run
+many external scripts. This is speeds up development. In the CI environment
+subprocess mode can be used to make sure the scripts also work (and behave the
+same) when run by a fresh interpreter.