aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Duchateau <duchateau.olivier@gmail.com>2023-01-25 06:55:18 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-01-26 18:02:41 +0000
commitcb9331513e988aac57fb681934758290315df33c (patch)
tree7e1ebdcd4a87996605964c7d815864c6efe05a4a
parent59c9a04edabaa0630318d25d82ec8bd1e2ae3ced (diff)
downloadports-cb9331513e988aac57fb681934758290315df33c.tar.gz
ports-cb9331513e988aac57fb681934758290315df33c.zip
editors/elementary-code: update to 7.0.0
ChangeLog: https://github.com/elementary/code/releases/tag/7.0.0 * Fix compile warnings * add code to keywords * Fix drag and drop of accented text and between tabs * Git ignore flatpak build files * Ensure tab toggle label is always correct * Add follow system style switch * Explicitly handle missing cases * Remove unused properties * Change key to trigger rebuild completion word list * Global search selected * Move strip trailing whitespace into main code; remove plugin * Fix meson warning for run_command * Add custom elementary syntax styles * Hide non-active documents when project manually chosen * Show symbol outline pane on right of document * ProjectFolderItem: Fix wrong ngettext syntax * Redesign app icon as a tile * Put the ProjectChooserButton inside the sidebar * HeaderBar: put find actions in menu * EditorConfig plugin overrides global settings for indent width and style * Make sidebar pane the toplevel container * Use elementary styles when following system style * Change panel menu items to linkbutton * FormatBar: use SwitchModelButton in tab popover * Move Terminal to core * Headerbar: remove sep before Revert * FormatBar: use menubuttons instead of ToggleButtons * Sidebar: Remove minimum width * GSchema: follow system style * Only restore documents for first window. * Do not add duplicate project * Update ci.yml * FormatBar: Set sensitivity of affected items, fix binding * PluginManager: Remove unused hooks * Make Control-Scroll zooming controllable * Metainfo improvements * Headerbar: code style, small fixes * Application: use built-in GLib functions in Activate * Inactivate find actions when no current doc * Fix startup warnings * Styles: misc refinements PR: 269135 Reported by: duchateau.olivier@gmail.com Approved by: miguel@gocobachi.dev (maintainer)
-rw-r--r--editors/elementary-code/Makefile7
-rw-r--r--editors/elementary-code/distinfo6
-rw-r--r--editors/elementary-code/files/patch-plugins_terminal_terminal.vala21
-rw-r--r--editors/elementary-code/files/patch-src_Widgets_Terminal.vala20
-rw-r--r--editors/elementary-code/pkg-plist10
5 files changed, 29 insertions, 35 deletions
diff --git a/editors/elementary-code/Makefile b/editors/elementary-code/Makefile
index 204ec074a858..5043aa0fea51 100644
--- a/editors/elementary-code/Makefile
+++ b/editors/elementary-code/Makefile
@@ -1,5 +1,5 @@
PORTNAME= elementary-code
-DISTVERSION= 6.2.0
+DISTVERSION= 7.0.0
CATEGORIES= editors
MAINTAINER= miguel@gocobachi.dev
@@ -26,14 +26,13 @@ RUN_DEPENDS= droid-fonts-ttf>0:x11-fonts/droid-fonts-ttf \
pkcheck:sysutils/polkit
USES= compiler:c++11-lang desktop-file-utils gettext gnome meson \
- ninja pkgconfig python:3.6+,build xorg vala:lib
+ ninja pkgconfig python:3.7+,build vala:lib xorg
USE_GITHUB= yes
GH_ACCOUNT= elementary
GH_PROJECT= code
USE_GNOME= cairo glib20 gtk30 gtksourceview4 pango vte3
GLIB_SCHEMAS= io.elementary.code.gschema.xml \
- io.elementary.code.plugins.spell.gschema.xml \
- io.elementary.code.plugins.terminal.gschema.xml
+ io.elementary.code.plugins.spell.gschema.xml
USE_LDCONFIG= yes
USE_XORG= x11
diff --git a/editors/elementary-code/distinfo b/editors/elementary-code/distinfo
index 35db590b7c97..2c8ceda5da26 100644
--- a/editors/elementary-code/distinfo
+++ b/editors/elementary-code/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1653761499
-SHA256 (elementary-code-6.2.0_GH0.tar.gz) = 9ec273182b053fb424cc78ddd8da869d13261d35f22cd2198f2899b654d13d4f
-SIZE (elementary-code-6.2.0_GH0.tar.gz) = 1427323
+TIMESTAMP = 1674590479
+SHA256 (elementary-code-7.0.0_GH0.tar.gz) = 5bf167102fd735ee74fb72b7fbc06dc67a6e6383f603be0ee97321213a4a7ce0
+SIZE (elementary-code-7.0.0_GH0.tar.gz) = 1696976
diff --git a/editors/elementary-code/files/patch-plugins_terminal_terminal.vala b/editors/elementary-code/files/patch-plugins_terminal_terminal.vala
deleted file mode 100644
index 8443bc31aca0..000000000000
--- a/editors/elementary-code/files/patch-plugins_terminal_terminal.vala
+++ /dev/null
@@ -1,21 +0,0 @@
---- plugins/terminal/terminal.vala.orig 2022-04-04 16:20:49 UTC
-+++ plugins/terminal/terminal.vala
-@@ -200,13 +200,16 @@ public class Scratch.Plugins.Terminal : Peas.Extension
-
- public string get_shell_location () {
- int pid = (!) (this.child_pid);
-+ string cwd = "";
-
- try {
-- return GLib.FileUtils.read_link ("/proc/%d/cwd".printf (pid));
-+ //return GLib.FileUtils.read_link ("/proc/%d/cwd".printf (pid));
-+ GLib.Process.spawn_command_line_sync ("pwd", out cwd);
- } catch (GLib.FileError error) {
- warning ("An error occurred while fetching the current dir of shell");
-- return "";
- }
-+
-+ return cwd;
- }
-
- void on_hook_notebook () {
diff --git a/editors/elementary-code/files/patch-src_Widgets_Terminal.vala b/editors/elementary-code/files/patch-src_Widgets_Terminal.vala
new file mode 100644
index 000000000000..20ddab2d0fab
--- /dev/null
+++ b/editors/elementary-code/files/patch-src_Widgets_Terminal.vala
@@ -0,0 +1,20 @@
+--- src/Widgets/Terminal.vala.orig 2023-01-24 16:59:41 UTC
++++ src/Widgets/Terminal.vala
+@@ -87,13 +87,14 @@ public class Code.Terminal : Gtk.Box {
+ }
+
+ private string get_shell_location () {
+- int pid = (!) (this.child_pid);
++ string cwd = "";
+ try {
+- return GLib.FileUtils.read_link ("/proc/%d/cwd".printf (pid));
++ GLib.Process.spawn_command_line_sync ("pwd", out cwd);
+ } catch (GLib.FileError error) {
+ warning ("An error occurred while fetching the current dir of shell: %s", error.message);
+- return "";
+ }
++
++ return cwd;
+ }
+
+ private void update_terminal_settings (string settings_schema) {
diff --git a/editors/elementary-code/pkg-plist b/editors/elementary-code/pkg-plist
index 8841554e8ba1..fa9b76097748 100644
--- a/editors/elementary-code/pkg-plist
+++ b/editors/elementary-code/pkg-plist
@@ -10,18 +10,12 @@ lib/io.elementary.code/plugins/highlight-word-selection/highlight-word-selection
lib/io.elementary.code/plugins/highlight-word-selection/libhighlight-word-selection.so
lib/io.elementary.code/plugins/markdown-actions/libmarkdown-actions.so
lib/io.elementary.code/plugins/markdown-actions/markdown-actions.plugin
-lib/io.elementary.code/plugins/outline/liboutline.so
-lib/io.elementary.code/plugins/outline/outline.plugin
lib/io.elementary.code/plugins/pastebin/libpastebin.so
lib/io.elementary.code/plugins/pastebin/pastebin.plugin
lib/io.elementary.code/plugins/preserve-indent/libpreserve-indent.so
lib/io.elementary.code/plugins/preserve-indent/preserve-indent.plugin
lib/io.elementary.code/plugins/spell/libspell.so
lib/io.elementary.code/plugins/spell/spell.plugin
-lib/io.elementary.code/plugins/strip-trailing-save/libstrip-trailing-save.so
-lib/io.elementary.code/plugins/strip-trailing-save/strip-trailing-save.plugin
-lib/io.elementary.code/plugins/terminal/libterminal.so
-lib/io.elementary.code/plugins/terminal/terminal.plugin
lib/io.elementary.code/plugins/vim-emulation/libvim-emulation.so
lib/io.elementary.code/plugins/vim-emulation/vim-emulation.plugin
lib/io.elementary.code/plugins/word-completion/libword-completion.so
@@ -31,6 +25,8 @@ lib/libcodecore.so.0
lib/libcodecore.so.0.0
libdata/pkgconfig/codecore.pc
share/applications/io.elementary.code.desktop
+share/gtksourceview-4/styles/elementary-dark.xml
+share/gtksourceview-4/styles/elementary-light.xml
share/icons/hicolor/128x128/apps/io.elementary.code.svg
share/icons/hicolor/128x128@2/apps/io.elementary.code.svg
share/icons/hicolor/16x16/apps/io.elementary.code.svg
@@ -242,7 +238,7 @@ share/locale/zh_CN/LC_MESSAGES/io.elementary.code.mo
share/locale/zh_HK/LC_MESSAGES/io.elementary.code.mo
share/locale/zh_TW/LC_MESSAGES/io.elementary.code.mo
share/locale/zu/LC_MESSAGES/io.elementary.code.mo
-share/metainfo/io.elementary.code.appdata.xml
+share/metainfo/io.elementary.code.metainfo.xml
share/polkit-1/actions/io.elementary.code.policy
share/vala/vapi/codecore.deps
share/vala/vapi/codecore.vapi