aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-03-24 03:23:53 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-03-24 08:20:52 +0000
commitcbb2b3f6c4d9ab204c38bff77ada374ff2d95f59 (patch)
tree91c9b1609de81030673fbab98aea83732bbcf504
parent3a1f0991ae70c6cc7d94c6b3458bf57b46a4b4c1 (diff)
downloadports-cbb2b3f6c4d9ab204c38bff77ada374ff2d95f59.tar.gz
ports-cbb2b3f6c4d9ab204c38bff77ada374ff2d95f59.zip
x11/hyprcursor: update to 0.1.5
Changes: https://github.com/hyprwm/hyprcursor/releases/tag/v0.1.5 Reported by: GitHub (watch releases)
-rw-r--r--x11/hyprcursor/Makefile2
-rw-r--r--x11/hyprcursor/distinfo6
-rw-r--r--x11/hyprcursor/files/patch-clang32
3 files changed, 4 insertions, 36 deletions
diff --git a/x11/hyprcursor/Makefile b/x11/hyprcursor/Makefile
index b9f4541f1904..376249153231 100644
--- a/x11/hyprcursor/Makefile
+++ b/x11/hyprcursor/Makefile
@@ -1,6 +1,6 @@
PORTNAME= hyprcursor
DISTVERSIONPREFIX= v
-DISTVERSION= 0.1.4
+DISTVERSION= 0.1.5
CATEGORIES= x11
MAINTAINER= jbeich@FreeBSD.org
diff --git a/x11/hyprcursor/distinfo b/x11/hyprcursor/distinfo
index 9b5b3210e8dc..ede0d662cbfd 100644
--- a/x11/hyprcursor/distinfo
+++ b/x11/hyprcursor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1710203373
-SHA256 (hyprwm-hyprcursor-v0.1.4_GH0.tar.gz) = 082c7866a8139993be0c476873dafea357bb579c8d1839280be6bfdef3177193
-SIZE (hyprwm-hyprcursor-v0.1.4_GH0.tar.gz) = 20072
+TIMESTAMP = 1711250633
+SHA256 (hyprwm-hyprcursor-v0.1.5_GH0.tar.gz) = 3958b0d7b80bcabca1c46841016c7354afc3cbcbf86b785b7b6289524cb5ec5c
+SIZE (hyprwm-hyprcursor-v0.1.5_GH0.tar.gz) = 20096
diff --git a/x11/hyprcursor/files/patch-clang b/x11/hyprcursor/files/patch-clang
deleted file mode 100644
index 43161820f00a..000000000000
--- a/x11/hyprcursor/files/patch-clang
+++ /dev/null
@@ -1,32 +0,0 @@
-error: invalid argument '-std=gnu++2b' not allowed with 'C'
-
-libhyprcursor/hyprcursor.cpp:471:36: error: arithmetic on a pointer to void
- 471 | std::memcpy(output, DATA->data + DATA->readNeedle, toRead);
- | ~~~~~~~~~~ ^
-
---- CMakeLists.txt.orig 2024-03-08 17:32:40 UTC
-+++ CMakeLists.txt
-@@ -44,12 +44,6 @@ target_link_libraries(hyprcursor PkgConfig::deps)
-
- target_link_libraries(hyprcursor PkgConfig::deps)
-
--if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
-- # for std::expected.
-- # probably evil. Arch's clang is very outdated tho...
-- target_compile_options(hyprcursor PUBLIC -std=gnu++2b -D__cpp_concepts=202002L -Wno-macro-redefined)
--endif()
--
- # hyprcursor-util
- add_subdirectory(hyprcursor-util)
-
---- libhyprcursor/hyprcursor.cpp.orig 2024-03-08 17:32:40 UTC
-+++ libhyprcursor/hyprcursor.cpp
-@@ -468,7 +468,7 @@ static cairo_status_t readPNG(void* data, unsigned cha
-
- size_t toRead = len > DATA->dataLen - DATA->readNeedle ? DATA->dataLen - DATA->readNeedle : len;
-
-- std::memcpy(output, DATA->data + DATA->readNeedle, toRead);
-+ std::memcpy(output, (uint8_t*)DATA->data + DATA->readNeedle, toRead);
- DATA->readNeedle += toRead;
-
- if (DATA->readNeedle >= DATA->dataLen) {