aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2023-03-30 08:27:26 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2023-03-30 08:28:50 +0000
commitcbb4a1e96c064fac3db7c0a236a07335e80974aa (patch)
tree62f12b2f6556dd98e3f6e538f20570df2527f17f
parentf2c782027df337d31d5361987a4085f5fad0f9a5 (diff)
downloadports-cbb4a1e96c064fac3db7c0a236a07335e80974aa.tar.gz
ports-cbb4a1e96c064fac3db7c0a236a07335e80974aa.zip
misc/py-shell-gpt: add port: Command-line productivity tool powered by ChatGPT
A command-line productivity tool powered by OpenAI's ChatGPT (GPT-3.5). As developers, we can leverage ChatGPT capabilities to generate shell commands, code snippets, comments, and documentation, among other things. Forget about cheat sheets and notes, with this tool you can get accurate answers right in your terminal, and you'll probably find yourself reducing your daily Google searches, saving you valuable time and effort. WWW: https://github.com/TheR1D/shell_gpt
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-shell-gpt/Makefile31
-rw-r--r--misc/py-shell-gpt/distinfo3
-rw-r--r--misc/py-shell-gpt/pkg-descr7
4 files changed, 42 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index fa5ebf0a6bbd..b45123492196 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -451,6 +451,7 @@
SUBDIR += py-scikit-fusion
SUBDIR += py-serverfiles
SUBDIR += py-shap2
+ SUBDIR += py-shell-gpt
SUBDIR += py-soapy_power
SUBDIR += py-spdx
SUBDIR += py-spdx-lookup
diff --git a/misc/py-shell-gpt/Makefile b/misc/py-shell-gpt/Makefile
new file mode 100644
index 000000000000..8331ba46c8c4
--- /dev/null
+++ b/misc/py-shell-gpt/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= shell-gpt
+DISTVERSION= 0.8.1
+CATEGORIES= misc python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
+
+MAINTAINER= tagattie@FreeBSD.org
+COMMENT= Command-line productivity tool powered by ChatGPT
+WWW= https://github.com/TheR1D/shell_gpt
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}typer>=0.7.0<0.8:devel/py-typer@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}distro>=1.8.0<1.9:sysutils/py-distro@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rich>=13.3.1<13.4:textproc/py-rich@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.28.2<2.29:www/py-requests@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests-mock>0:www/py-requests-mock@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils pytest
+
+BINARY_ALIAS= python=${PYTHON_CMD}
+NO_ARCH= yes
+
+do-test:
+ cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} tests/unittests.py
+ cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest tests/integrational_tests.py
+
+.include <bsd.port.mk>
diff --git a/misc/py-shell-gpt/distinfo b/misc/py-shell-gpt/distinfo
new file mode 100644
index 000000000000..d4f233c186f4
--- /dev/null
+++ b/misc/py-shell-gpt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680088583
+SHA256 (shell_gpt-0.8.1.tar.gz) = bfd8eca822483ea9e8d87c7d120b6b686fc899845af0ae5b202580886d1f1ef1
+SIZE (shell_gpt-0.8.1.tar.gz) = 17235
diff --git a/misc/py-shell-gpt/pkg-descr b/misc/py-shell-gpt/pkg-descr
new file mode 100644
index 000000000000..cc3128ff1917
--- /dev/null
+++ b/misc/py-shell-gpt/pkg-descr
@@ -0,0 +1,7 @@
+A command-line productivity tool powered by OpenAI's ChatGPT
+(GPT-3.5). As developers, we can leverage ChatGPT capabilities to
+generate shell commands, code snippets, comments, and documentation,
+among other things. Forget about cheat sheets and notes, with this
+tool you can get accurate answers right in your terminal, and you'll
+probably find yourself reducing your daily Google searches, saving you
+valuable time and effort.