aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Ost <bsd@philippost.de>2023-08-23 06:36:42 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-08-25 06:49:45 +0000
commitcbf6cea662f53deb0477cfd5f52b3dffb4cd2de5 (patch)
tree7bf3161ad75afd4387d512987f69a0b1bb773a55
parentbd189a7ca102971f9cd91bf2d217f135d4f4b754 (diff)
downloadports-cbf6cea662f53deb0477cfd5f52b3dffb4cd2de5.tar.gz
ports-cbf6cea662f53deb0477cfd5f52b3dffb4cd2de5.zip
graphics/povray37: Clean up Makefile
- set COMPILED_BY variable as proposed by diizzy@ - drop the STATIC option - make use of ports framework for options PNG, JPEG, TIFF, OPENEXR PR: 273299 Reported by: bsd@philippost.de (maintainer)
-rw-r--r--graphics/povray37/Makefile72
1 files changed, 18 insertions, 54 deletions
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index e839e06e9049..07f3f9ef497d 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -1,7 +1,7 @@
PORTNAME= povray
DISTVERSIONPREFIX= v
DISTVERSION= 3.7.0.10
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
PKGNAMESUFFIX= 37
@@ -20,72 +20,42 @@ USE_GITHUB= yes
GH_ACCOUNT= POV-Ray
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= COMPILED_BY=${MAINTAINER} \
+CONFIGURE_ARGS= COMPILED_BY=${HOSTARCH}-portbld-${OPSYS:tl}-${OSREL:R} \
--program-transform-name='s/povray/${PKGBASE}/' \
--disable-optimiz
VERSION_BASE= ${PORTVERSION:C/([0-9]+\.[0-9]+).*/\1/}
+ETCDIR= ${PREFIX}/etc/${PORTNAME}/${VERSION_BASE}
DATADIR= ${PREFIX}/share/${PORTNAME}-${VERSION_BASE}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${VERSION_BASE}
-ETCDIR= ${PREFIX}/etc/${PORTNAME}/${VERSION_BASE}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}-${VERSION_BASE}
-OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR STATIC IO EXAMPLES DOCS
+OPTIONS_DEFINE= X11 PNG JPEG TIFF OPENEXR IO EXAMPLES DOCS
OPTIONS_DEFAULT=PNG JPEG
OPTIONS_SUB= yes
-DOCS_DESC= Install HTML documentation
-EXAMPLES_DESC= Install example scenes
IO_DESC= Without I/O restrictions (security risk)
IO_CONFIGURE_ON= --disable-io-restrictions
-STATIC_CONFIGURE_ON= --enable-static
-X11_USES= sdl xorg
-X11_USE= XORG=xpm,sm,ice,x11 SDL=sdl
-X11_CONFIGURE_OFF= --without-x
-.include <bsd.port.options.mk>
+JPEG_USES= jpeg
+JPEG_CONFIGURE_OFF= --without-jpeg
-.if ${PORT_OPTIONS:MPNG}
-.if ${PORT_OPTIONS:MSTATIC}
-BUILD_DEPENDS+= png>=1.4:graphics/png
-.else
-LIB_DEPENDS+= libpng.so:graphics/png
-.endif
-.else
-CONFIGURE_ARGS+=--without-libpng
-.endif
+OPENEXR_LIB_DEPENDS= libImath.so:math/Imath \
+ libOpenEXR.so:graphics/openexr
+OPENEXR_CONFIGURE_WITH= openexr
-.if ${PORT_OPTIONS:MJPEG}
-.if ${PORT_OPTIONS:MSTATIC}
-USES+= jpeg:build
-.else
-USES+= jpeg
-.endif
-.else
-CONFIGURE_ARGS+=--without-libjpeg
-.endif
+PNG_LIB_DEPENDS= libpng.so:graphics/png
+PNG_CONFIGURE_WITH= libpng
-.if ${PORT_OPTIONS:MTIFF}
-.if ${PORT_OPTIONS:MSTATIC}
-BUILD_DEPENDS+= tiff>=4:graphics/tiff
-.else
-LIB_DEPENDS+= libtiff.so:graphics/tiff
-.endif
-.else
-CONFIGURE_ARGS+=--without-libtiff
-.endif
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_CONFIGURE_WITH= libtiff
-.if ${PORT_OPTIONS:MOPENEXR}
-.if ${PORT_OPTIONS:MSTATIC}
-BUILD_DEPENDS+= openexr>=1.6:graphics/openexr
-.else
-LIB_DEPENDS+= libOpenEXR.so:graphics/openexr libImath.so:math/Imath
-CPPFLAGS+= -I${LOCALBASE}/include/OpenEXR -I${LOCALBASE}/include/Imath -DInt64=uint64_t
-.endif
-.else
-CONFIGURE_ARGS+=--without-openexr
-.endif
+X11_USES= sdl xorg
+X11_USE= XORG=xpm,sm,ice,x11 SDL=sdl
+X11_CONFIGURE_OFF= --without-x
+
+.include <bsd.port.options.mk>
.if !${PORT_OPTIONS:MPNG} || !${PORT_OPTIONS:MJPEG} || !${PORT_OPTIONS:MTIFF}
CONFIGURE_ARGS+=NON_REDISTRIBUTABLE_BUILD=yes
@@ -102,12 +72,6 @@ post-patch:
pre-configure:
cd ${WRKSRC}/unix && ./prebuild.sh
-pre-build:
-.if ${PORT_OPTIONS:MSTATIC} && ${PORT_OPTIONS:MTIFF}
-# graphics/tiff adds dependencies on libjpeg, libjbig and liblzma
- @${REINPLACE_CMD} -e 's,^\(LIBS = .*\)-ltiff\(.*\),\1-ltiff -ljpeg -ljbig -llzma\2,' ${WRKSRC}/unix/Makefile
-.endif
-
post-install:
${MV} ${STAGEDIR}${DATADIR}/scenes ${STAGEDIR}${EXAMPLESDIR}
.for i in povray.conf povray.ini