aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-15 14:48:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-15 15:31:47 +0000
commitcc7f11758877328278a24ff32b1c1e35e6174ebc (patch)
tree25df75c73971ac6cc5919fddaa92f94e17d95b56
parent256f97b6e252a63ebe28f7162ab1de1b2db4c105 (diff)
downloadports-cc7f11758877328278a24ff32b1c1e35e6174ebc.tar.gz
ports-cc7f11758877328278a24ff32b1c1e35e6174ebc.zip
cad/magic: Unbreak on HEAD
- Refactor with USES=localbase:ldflags Approved by: portmgr (blanket)
-rw-r--r--cad/magic/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index f57710a491cf..770e775d22de 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libBLT25.so:x11-toolkits/blt \
libfreetype.so:print/freetype2
RUN_DEPENDS= bash:shells/bash
-USES= gmake gnome gl localbase python:3.6+,build shebangfix tk:tea tar:tgz xorg
+USES= gmake gnome gl localbase:ldflags python:3.6+,build shebangfix tk:tea tar:tgz xorg
USE_GNOME= cairo
USE_XORG= ice x11 xext xi xmu
USE_GL= gl glu
@@ -28,8 +28,6 @@ CONFIGURE_WRKSRC= ${WRKSRC}/scripts
ALL_TARGET= tcllibrary
CFLAGS+= -Wno-return-type # workaround for https://github.com/RTimothyEdwards/magic/issues/67
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
DESKTOP_ENTRIES="Magic" "" "" "${PORTNAME}" "" ""
@@ -37,6 +35,12 @@ PORTSCOUT= limit:^8\.
BINARY_ALIAS= python3=${PYTHON_CMD} # this is needed, see https://github.com/RTimothyEdwards/magic/issues/173#issuecomment-1200065429
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|^#!.*|#!${AWK} -f|' ${WRKSRC}/ext2spice/spice2sim
@@ -59,4 +63,4 @@ pre-build:
post-install:
@cd ${STAGEDIR}${PREFIX}/lib/magic/tcl && ${STRIP_CMD} magicexec magicdnull tclmagic.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>