aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2001-02-09 23:06:50 +0000
committerKris Kennaway <kris@FreeBSD.org>2001-02-09 23:06:50 +0000
commitccd8c2a7718848972a4f5cef25c26bb3e9014d09 (patch)
tree6b528f72953e84cc71a658a73bd0c226aa87050b
parentd6bcba78376a7f5f10789644764c663f2b8ca1ae (diff)
downloadports-ccd8c2a7718848972a4f5cef25c26bb3e9014d09.tar.gz
ports-ccd8c2a7718848972a4f5cef25c26bb3e9014d09.zip
Sigh, the patch released by ssh.com was wrong (kill() had the arguments
in the wrong order). Fix this, and bump PORTREVISION again. The window was only a few minutes, but this won't disrupt things, and someone may have updated in that window given the prominence of the problem. Obtained from: Matt Power <mhpower@BOS.BINDVIEW.COM> via Bugtraq
Notes
Notes: svn path=/head/; revision=38157
-rw-r--r--security/ssh/Makefile2
-rw-r--r--security/ssh/files/patch-ay2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index cd1cae108e01..11e4183e0704 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -10,7 +10,7 @@
PORTNAME= ssh
PORTVERSION= 1.2.27 # Note, 1.2.30 is under a more restrictive license
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.cs.engr.uky.edu/cs/software/ \
ftp://ftp.cs.umn.edu/dept/users/rybski/ \
diff --git a/security/ssh/files/patch-ay b/security/ssh/files/patch-ay
index 51e949e323e3..71daac2ca4a9 100644
--- a/security/ssh/files/patch-ay
+++ b/security/ssh/files/patch-ay
@@ -10,7 +10,7 @@
+ if (time(NULL) - last_kill_time > 60 && getppid() != 1)
+ {
+ last_kill_time = time(NULL);
-+ kill(SIGALRM, getppid());
++ kill(getppid(), SIGALRM);
+ }
+ fatal("Bad result from rsa_private_decrypt");
+ }