aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2022-05-19 07:07:36 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2022-05-19 07:10:57 +0000
commitcd14a91411b3b58f44c7d7b4d5940c356bb3602e (patch)
treee9637f909ed81e0afd6684425db0aed5e8333757
parente841d702dd1143eaaee054b7b72817237e3993bd (diff)
downloadports-cd14a91411b3b58f44c7d7b4d5940c356bb3602e.tar.gz
ports-cd14a91411b3b58f44c7d7b4d5940c356bb3602e.zip
benchmarks/fio: Disable libnfs support by default
PR: 258349 Reported by: John Hein <jcfyecrayz@liamekaens.com>
-rw-r--r--benchmarks/fio/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index 14ab9f2bf920..0079e46eb77e 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fio
PORTVERSION= 3.30
+PORTREVISION= 1
CATEGORIES= benchmarks
MASTER_SITES= https://brick.kernel.dk/snaps/
@@ -13,15 +14,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c11 gmake tar:bzip2
-HAS_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-native
-OPTIONS_DEFINE= EXAMPLES GNUPLOT
+CONFLICTS_INSTALL= py*-Fiona
+
+OPTIONS_DEFINE= EXAMPLES GNUPLOT LIBNFS
GNUPLOT_DESC= Support for plotting graphs
+LIBNFS_DESC= Enable NFS support using libnfs
GNUPLOT_BUILD_DEPENDS= ${LOCALBASE}/bin/gnuplot:math/gnuplot
+LIBNFS_LIB_DEPENDS= libnfs.so:net/libnfs
-CONFLICTS_INSTALL= py*-Fiona
+LIBNFS_CONFIGURE_OFF= --disable-nfs
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fio ${STAGEDIR}${PREFIX}/bin