aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVVD <vvd@unislabs.com>2022-02-09 08:12:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-02-09 08:15:24 +0000
commitcd2c8b5c599c4b6e030469c6844287a92bc8f6cd (patch)
tree629590710566f42f620e449729b863048cf4437e
parent846ff4e9529104b008946f89b9fb3d3a27c13773 (diff)
downloadports-cd2c8b5c599c4b6e030469c6844287a92bc8f6cd.tar.gz
ports-cd2c8b5c599c4b6e030469c6844287a92bc8f6cd.zip
devel/ispc: Make ARM support conditional on the new ARM option on amd64 and i386 architectures
PR: 261735
-rw-r--r--devel/ispc/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/ispc/Makefile b/devel/ispc/Makefile
index 351eee3e4bde..e889a3938d63 100644
--- a/devel/ispc/Makefile
+++ b/devel/ispc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ispc
DISTVERSIONPREFIX= v
DISTVERSION= 1.17.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -40,7 +40,11 @@ BINARY_ALIAS= flex=${LOCALBASE}/bin/flex python=${PYTHON_CMD} m4=${LOCALBASE}/bi
PLIST_FILES= bin/ispc \
bin/check_isa
-OPTIONS_DEFINE_amd64= XE
+OPTIONS_DEFINE_amd64= ARM XE
+OPTIONS_DEFINE_i386= ARM
+
+ARM_DESC= Enable ARM support - requires ARM backend in LLVM
+ARM_CMAKE_BOOL= ARM_ENABLED
XE_DESC= Enable Intel Xe support
XE_BUILD_DEPENDS= ${LOCALBASE}/llvm${LLVM_VERSION}/lib/libLLVMGenXIntrinsics.a:devel/vc-intrinsics@llvm${LLVM_VERSION}