aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2024-01-05 17:04:54 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2024-01-05 17:06:34 +0000
commitcd37364b666c0aa59ad83ac367db9b992d71e39d (patch)
treecc3bd08b0a2f0f38157275437acd3404ef791e55
parent45cc712c1ddcae9f90e3e926d5023a424d2eb36b (diff)
downloadports-cd37364b666c0aa59ad83ac367db9b992d71e39d.tar.gz
ports-cd37364b666c0aa59ad83ac367db9b992d71e39d.zip
sysutils/signon-ui: revert bad flavorization
- this was premature, unfinished, and unneeded This reverts commit 6d08faea51214414969d21706dead305e9eab673.
-rw-r--r--net-im/kaccounts-integration/Makefile4
-rw-r--r--sysutils/signon-ui/Makefile12
2 files changed, 6 insertions, 10 deletions
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index f3b99dec617a..4494d104be3e 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -1,6 +1,6 @@
PORTNAME= kaccounts-integration
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-im kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -10,7 +10,7 @@ WWW= https://projects.kde.org/projects/kdereview/kaccounts-integration
LIB_DEPENDS= libQCoro5Core.so:devel/qcoro@qt5 \
libaccounts-qt5.so:net-im/libaccounts-qt@qt5 \
libsignon-qt5.so:sysutils/signond@qt5
-RUN_DEPENDS= signon-ui:sysutils/signon-ui@qt5
+RUN_DEPENDS= signon-ui:sysutils/signon-ui
USES= cmake compiler:c++11-lang gettext-tools pkgconfig kde:5 \
qt:5 tar:xz
diff --git a/sysutils/signon-ui/Makefile b/sysutils/signon-ui/Makefile
index 8f697ddbc76f..132dbd74d298 100644
--- a/sysutils/signon-ui/Makefile
+++ b/sysutils/signon-ui/Makefile
@@ -3,10 +3,9 @@ PORTNAME= signon-ui
# > git rev-list 0.17+15.10.20150810-0ubuntu1.. --count
DISTVERSION= 0.17-355
DISTVERSIONSUFFIX= -g4368bb7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils kde
DIST_SUBDIR= KDE/${GL_ACCOUNT}
-PKGNAMESUFFIX= -${FLAVOR}
MAINTAINER= kde@FreeBSD.org
COMMENT= Component for handling accounts-sso user interactions
@@ -15,16 +14,13 @@ WWW= https://gitlab.com/accounts-sso/signon-ui
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-FLAVORS= qt5 qt6
-FLAVOR?= qt5
-
-LIB_DEPENDS= libaccounts-${FLAVOR}.so:net-im/libaccounts-qt@${FLAVOR} \
+LIB_DEPENDS= libaccounts-qt5.so:net-im/libaccounts-qt@qt5 \
libnotify.so:devel/libnotify \
- libsignon-${FLAVOR}.so:sysutils/signond@${FLAVOR} \
+ libsignon-qt5.so:sysutils/signond@qt5 \
libproxy.so:net/libproxy
USES= compiler:c++11-lang gettext-runtime gl gnome pkgconfig python \
- qmake qt:${FLAVOR:S/qt//} tar:bz2
+ qmake qt:5 tar:bz2
USE_GL= gl
USE_GNOME= gdkpixbuf2 glib20
USE_QT= core dbus declarative gui location network webchannel webengine widgets xml \