aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-13 20:33:53 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-13 20:33:53 +0000
commitce2fc14864c360de5ddb0878fdcda0e04e0ea849 (patch)
treecbae50784e0a00acaffb27b2f9c2ef09fe45e4b8
parent588ae8f65e8ba012b45a415aeaa148e8412587ba (diff)
downloadports-ce2fc14864c360de5ddb0878fdcda0e04e0ea849.tar.gz
ports-ce2fc14864c360de5ddb0878fdcda0e04e0ea849.zip
- update japanese/eb to 4.4.3
- add support for NOPORTDOCS and WITHOUT_NLS - bump PORTREVISION for dependent ports: - japanese/eblook - japanese/ebview - japanese/ebview-gtk2 - japanese/ebnetd while here, common changes: - strip Makefile headers - remove shlib versions from dependent ports - remove deprecated attributions from pkg-descr - whitespace fixes to pkg-descr PR: 167175 Submitted by: Muhammad Moinur Rahman <5u623l20 at gmail dot com> (original patch) Submitted by: Yasuhiro KIMURA <yasu at utahime dot org> (maintainer, final patch)
Notes
Notes: svn path=/head/; revision=304232
-rw-r--r--japanese/eb/Makefile46
-rw-r--r--japanese/eb/distinfo6
-rw-r--r--japanese/eb/pkg-descr3
-rw-r--r--japanese/eb/pkg-plist64
-rw-r--r--japanese/eblook/Makefile9
-rw-r--r--japanese/eblook/pkg-descr2
-rw-r--r--japanese/ebnetd/Makefile9
-rw-r--r--japanese/ebnetd/pkg-descr3
-rw-r--r--japanese/ebview-gtk2/Makefile9
-rw-r--r--japanese/ebview/Makefile9
10 files changed, 57 insertions, 103 deletions
diff --git a/japanese/eb/Makefile b/japanese/eb/Makefile
index 40d724485591..7f6f120b6baf 100644
--- a/japanese/eb/Makefile
+++ b/japanese/eb/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: eb
-# Date created: 20 Jan 1999
-# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
-#
# $FreeBSD$
-#
PORTNAME= eb
-PORTVERSION= 4.4.2
-PORTREVISION= 1
+PORTVERSION= 4.4.3
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ \
ftp://ftp.sra.co.jp/pub/misc/eb/old/eb-${PORTVERSION:C/^([0-9]+)\.([0-9]+).*/\1.\2/}/
@@ -36,6 +30,7 @@ APPENDIXFILES= appendix/cencro-1.0.tar.gz \
appendix/genius2-1.1.tar.gz \
appendix/global-2.0.tar.gz \
appendix/heritage-2.2.tar.gz \
+ appendix/hyogen-1.0.tar.gz \
appendix/izumi-2.0.tar.gz \
appendix/jitenban-2.4.tar.gz \
appendix/jitenban97-2.1.tar.gz \
@@ -53,30 +48,55 @@ APPENDIXFILES= appendix/cencro-1.0.tar.gz \
DIST_SUBDIR= eb
+PORTDOCS= eb-01.html eb-02.html eb-03.html eb-04.html eb-05.html eb-06.html \
+ eb-07.html eb-08.html eb-09.html eb-10.html eb-11.html eb-12.html \
+ eb-13.html eb-14.html eb.html ebappendix-01.html ebappendix-02.html \
+ ebappendix-03.html ebappendix-04.html ebappendix.html ebfont-01.html \
+ ebfont-02.html ebfont-03.html ebfont-04.html ebfont.html \
+ ebinfo-01.html ebinfo-02.html ebinfo-03.html ebinfo-04.html \
+ ebinfo-05.html ebinfo.html ebrefile-01.html ebrefile-02.html \
+ ebrefile-03.html ebrefile.html ebstopcode-01.html ebstopcode-02.html \
+ ebstopcode-03.html ebstopcode.html ebzip-01.html ebzip-02.html \
+ ebzip-03.html ebzip-04.html ebzip-05.html ebzip-06.html ebzip-07.html \
+ ebzip-08.html ebzip-09.html ebzip-10.html ebzip.html
+
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --enable-nls \
+CONFIGURE_ARGS= --with-pkgdocdir=${DOCSDIR}
+
+APPENDIXDIR= ${DATADIR}/appendix
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls \
--with-gettext-includes=${LOCALBASE}/include \
--with-gettext-libraries=${LOCALBASE}/lib \
--with-iconv-includes=${LOCALBASE}/include \
- --with-iconv-libraries=${LOCALBASE}/lib \
- --with-pkgdocdir=${DOCSDIR}
-
-APPENDIXDIR= ${DATADIR}/appendix
+ --with-iconv-libraries=${LOCALBASE}/lib
+PLIST_SUB= NLS=""
+.else
+PLIST_SUB= NLS="@comment "
+.endif
post-extract:
${RM} -fr ${WRKSRC}/zlib
${MKDIR} ${WRKDIR}/appendix
.for file in ${APPENDIXFILES}
${TAR} --exclude CVS -C ${WRKDIR}/appendix -zxmf \
- ${DISTDIR}/${DIST_SUBDIR}/${file}
+ ${DISTDIR}/${DIST_SUBDIR}/${file}
.endfor
post-install:
${CP} -R ${WRKDIR}/appendix/ ${APPENDIXDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/japanese/eb/distinfo b/japanese/eb/distinfo
index 46f5bd090337..e6f8fd1975be 100644
--- a/japanese/eb/distinfo
+++ b/japanese/eb/distinfo
@@ -1,5 +1,5 @@
-SHA256 (eb/eb-4.4.2.tar.bz2) = 3abb92211e0c04640973a93ece1914da0895486fe784a7dac2ced091c64500d6
-SIZE (eb/eb-4.4.2.tar.bz2) = 505293
+SHA256 (eb/eb-4.4.3.tar.bz2) = abe710a77c6fc3588232977bb2f30a2e69ddfbe9fa8d0b05b0d67d95e36f4b5f
+SIZE (eb/eb-4.4.3.tar.bz2) = 505510
SHA256 (eb/appendix/cencro-1.0.tar.gz) = 02d7937f4cd0b3bebb23f9d5917a261d382b4f1004b3b49830c64762d58a02e5
SIZE (eb/appendix/cencro-1.0.tar.gz) = 1666
SHA256 (eb/appendix/chujiten-2.3.tar.gz) = 07bb4ae37b8e3bfaa219dc243b70db5ccce1e30a574f43e53c083c36f69090ba
@@ -32,6 +32,8 @@ SHA256 (eb/appendix/global-2.0.tar.gz) = 756310bc9434e20e8a5f7043f4acf7085ef8c2c
SIZE (eb/appendix/global-2.0.tar.gz) = 4034
SHA256 (eb/appendix/heritage-2.2.tar.gz) = 67974914e27c6874d7520b4c7ce90c56da959631d7edd602a29e902b2ee86997
SIZE (eb/appendix/heritage-2.2.tar.gz) = 3968
+SHA256 (eb/appendix/hyogen-1.0.tar.gz) = fe2e6fa528c0ba689051ed068182f9554f9c3cbe73972dca27f97c9a2a977ad8
+SIZE (eb/appendix/hyogen-1.0.tar.gz) = 1309
SHA256 (eb/appendix/izumi-2.0.tar.gz) = be358a301d4f4e51f0c97930baab80960ba84fc32ee3b06095d6b860bc43d0ce
SIZE (eb/appendix/izumi-2.0.tar.gz) = 984
SHA256 (eb/appendix/jitenban-2.4.tar.gz) = d02941a6991400bf0dfdb0b075ca0827a30147691347294b674ab7bdbbbd3204
diff --git a/japanese/eb/pkg-descr b/japanese/eb/pkg-descr
index 02fd2e8b44bf..b2735138d5f7 100644
--- a/japanese/eb/pkg-descr
+++ b/japanese/eb/pkg-descr
@@ -2,7 +2,4 @@ EB Library is a C library for accessing CD-ROM books. EB Library
supports to access CD-ROM books of EB, EBG, EBXA and EPWING formats.
CD-ROM books of those formats are popular in Japan.
--- Motoyuki Kasahara <m-kasahr@sra.co.jp>
--- Kazu TAKAMUNE <takamune2004@yahoo.co.jp>
-
WWW: http://www.sra.co.jp/people/m-kasahr/eb/
diff --git a/japanese/eb/pkg-plist b/japanese/eb/pkg-plist
index bf8008781d8c..668e1821ad2f 100644
--- a/japanese/eb/pkg-plist
+++ b/japanese/eb/pkg-plist
@@ -21,59 +21,8 @@ include/eb/zio.h
lib/libeb.a
lib/libeb.la
lib/libeb.so
-lib/libeb.so.15
+lib/libeb.so.16
share/aclocal/eb4.m4
-%%DOCSDIR%%/eb-01.html
-%%DOCSDIR%%/eb-02.html
-%%DOCSDIR%%/eb-03.html
-%%DOCSDIR%%/eb-04.html
-%%DOCSDIR%%/eb-05.html
-%%DOCSDIR%%/eb-06.html
-%%DOCSDIR%%/eb-07.html
-%%DOCSDIR%%/eb-08.html
-%%DOCSDIR%%/eb-09.html
-%%DOCSDIR%%/eb-10.html
-%%DOCSDIR%%/eb-11.html
-%%DOCSDIR%%/eb-12.html
-%%DOCSDIR%%/eb-13.html
-%%DOCSDIR%%/eb-14.html
-%%DOCSDIR%%/eb.html
-%%DOCSDIR%%/ebappendix-01.html
-%%DOCSDIR%%/ebappendix-02.html
-%%DOCSDIR%%/ebappendix-03.html
-%%DOCSDIR%%/ebappendix-04.html
-%%DOCSDIR%%/ebappendix.html
-%%DOCSDIR%%/ebfont-01.html
-%%DOCSDIR%%/ebfont-02.html
-%%DOCSDIR%%/ebfont-03.html
-%%DOCSDIR%%/ebfont-04.html
-%%DOCSDIR%%/ebfont.html
-%%DOCSDIR%%/ebinfo-01.html
-%%DOCSDIR%%/ebinfo-02.html
-%%DOCSDIR%%/ebinfo-03.html
-%%DOCSDIR%%/ebinfo-04.html
-%%DOCSDIR%%/ebinfo-05.html
-%%DOCSDIR%%/ebinfo.html
-%%DOCSDIR%%/ebrefile-01.html
-%%DOCSDIR%%/ebrefile-02.html
-%%DOCSDIR%%/ebrefile-03.html
-%%DOCSDIR%%/ebrefile.html
-%%DOCSDIR%%/ebstopcode-01.html
-%%DOCSDIR%%/ebstopcode-02.html
-%%DOCSDIR%%/ebstopcode-03.html
-%%DOCSDIR%%/ebstopcode.html
-%%DOCSDIR%%/ebzip-01.html
-%%DOCSDIR%%/ebzip-02.html
-%%DOCSDIR%%/ebzip-03.html
-%%DOCSDIR%%/ebzip-04.html
-%%DOCSDIR%%/ebzip-05.html
-%%DOCSDIR%%/ebzip-06.html
-%%DOCSDIR%%/ebzip-07.html
-%%DOCSDIR%%/ebzip-08.html
-%%DOCSDIR%%/ebzip-09.html
-%%DOCSDIR%%/ebzip-10.html
-%%DOCSDIR%%/ebzip.html
-@dirrm %%DOCSDIR%%
%%DATADIR%%/appendix/cencro-1.0/catalog
%%DATADIR%%/appendix/cencro-1.0/catalog.app
%%DATADIR%%/appendix/cencro-1.0/cencro.app
@@ -161,6 +110,10 @@ share/aclocal/eb4.m4
%%DATADIR%%/appendix/heritage-2.2/roget/appendix
%%DATADIR%%/appendix/heritage-2.2/root.app
%%DATADIR%%/appendix/heritage-2.2/root/appendix
+%%DATADIR%%/appendix/hyogen-1.0/catalogs
+%%DATADIR%%/appendix/hyogen-1.0/catalogs.app
+%%DATADIR%%/appendix/hyogen-1.0/hyogen.app
+%%DATADIR%%/appendix/hyogen-1.0/hyogen/data/furoku
%%DATADIR%%/appendix/izumi-2.0/catalog
%%DATADIR%%/appendix/izumi-2.0/catalog.app
%%DATADIR%%/appendix/izumi-2.0/file1.app
@@ -301,6 +254,9 @@ share/aclocal/eb4.m4
@dirrm %%DATADIR%%/appendix/heritage-2.2/roget
@dirrm %%DATADIR%%/appendix/heritage-2.2/root
@dirrm %%DATADIR%%/appendix/heritage-2.2
+@dirrm %%DATADIR%%/appendix/hyogen-1.0/hyogen/data
+@dirrm %%DATADIR%%/appendix/hyogen-1.0/hyogen
+@dirrm %%DATADIR%%/appendix/hyogen-1.0
@dirrm %%DATADIR%%/appendix/izumi-2.0/file1
@dirrm %%DATADIR%%/appendix/izumi-2.0
@dirrm %%DATADIR%%/appendix/jitenban-2.4/chiezo/data
@@ -369,5 +325,5 @@ share/aclocal/eb4.m4
@dirrm %%DATADIR%%/appendix/superdic98-1.0
@dirrm %%DATADIR%%/appendix
@dirrm %%DATADIR%%
-share/locale/ja/LC_MESSAGES/eb.mo
-share/locale/ja/LC_MESSAGES/ebutils.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/eb.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/ebutils.mo
diff --git a/japanese/eblook/Makefile b/japanese/eblook/Makefile
index c574eef754f4..af7f3d3bfd2f 100644
--- a/japanese/eblook/Makefile
+++ b/japanese/eblook/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: eblook
-# Date created: 20 August 1999
-# Whom: Shigeyuki Fukushima <shige@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= eblook
PORTVERSION= 1.6.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese textproc
MASTER_SITES= http://openlab.ring.gr.jp/edict/eblook/dist/
DIST_SUBDIR= eb
@@ -15,7 +10,7 @@ DIST_SUBDIR= eb
MAINTAINER= yasu@utahime.org
COMMENT= Interactive EB interface command for searching words in electronic dictionaries
-LIB_DEPENDS= eb.15:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= eb:${PORTSDIR}/japanese/eb
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-eb-includes=${PREFIX}/include \
diff --git a/japanese/eblook/pkg-descr b/japanese/eblook/pkg-descr
index 4dc719a683b6..9e97f6e43b92 100644
--- a/japanese/eblook/pkg-descr
+++ b/japanese/eblook/pkg-descr
@@ -2,7 +2,7 @@ Interactive EB interface command for seraching words in CD-ROM books.
Eblook supports to access CD-ROM books of EB, EBG, EBXA and EPWING formats
directly. CD-ROM books of those formats are popular in Japan.
-Since CD-ROM books themseves are stands on the ISO 9660 format,
+Since CD-ROM books themseves are stands on the ISO 9660 format,
you can mount the discs by the same way as other ISO 9660 discs.
You can get more information from ja-eblook.info.
diff --git a/japanese/ebnetd/Makefile b/japanese/ebnetd/Makefile
index 7679f652a518..75bf935815a4 100644
--- a/japanese/ebnetd/Makefile
+++ b/japanese/ebnetd/Makefile
@@ -1,20 +1,15 @@
-# New ports collection makefile for: ebnetd
-# Date created: 4 Aug 1998
-# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
-#
# $FreeBSD$
-#
PORTNAME= ebnetd
PORTVERSION= 1.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese ipv6
MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/
MAINTAINER= yasu@utahime.org
COMMENT= Servers for accessing CD-ROM books via TCP/IP
-LIB_DEPENDS= eb.15:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= eb:${PORTSDIR}/japanese/eb
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${RUNDIR} --with-logdir=${LOGDIR}
diff --git a/japanese/ebnetd/pkg-descr b/japanese/ebnetd/pkg-descr
index 090a976da4a2..0e77179c7c92 100644
--- a/japanese/ebnetd/pkg-descr
+++ b/japanese/ebnetd/pkg-descr
@@ -21,5 +21,4 @@ In addition, you must follow the licenses of your CD-ROM books. Though
EBNETD is free software, your books may not be free. Don't open your
books to unlicensed hosts nor users.
-Author: Motoyuki Kasahara <m-kasahr@sra.co.jp>
-WWW: http://www.sra.co.jp/people/m-kasahr/ebnetd/
+WWW: http://www.sra.co.jp/people/m-kasahr/ebnetd/
diff --git a/japanese/ebview-gtk2/Makefile b/japanese/ebview-gtk2/Makefile
index 1f9bc5ea1e47..53b287c37697 100644
--- a/japanese/ebview-gtk2/Makefile
+++ b/japanese/ebview-gtk2/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: ebview-gtk2
-# Date Created: 7 Dec 2003
-# Whom: <faust@ua.airnet.ne.jp>
-#
# $FreeBSD$
-#
PORTNAME= ebview
PORTVERSION= 0.3.6
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= japanese
MASTER_SITES= SF
PKGNAMESUFFIX= -gtk2
@@ -15,7 +10,7 @@ PKGNAMESUFFIX= -gtk2
MAINTAINER= ports@FreeBSD.org
COMMENT= Electronic Book Viewer
-LIB_DEPENDS= eb.15:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= eb:${PORTSDIR}/japanese/eb
CONFLICTS= ja-ebview-0*
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
index c6d05920975a..a25bd8d5cd24 100644
--- a/japanese/ebview/Makefile
+++ b/japanese/ebview/Makefile
@@ -1,20 +1,15 @@
-# New ports collection makefile for: ebview
-# Date Created: 28 Jan 2002
-# Whom: Yoichi NAKAYAMA <yoichi@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= ebview
PORTVERSION= 0.2.1
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= japanese
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Electronic Book Viewer
-LIB_DEPENDS= eb.15:${PORTSDIR}/japanese/eb
+LIB_DEPENDS= eb:${PORTSDIR}/japanese/eb
CONFLICTS= ja-ebview-gtk2-*