aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2021-09-27 03:54:10 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2021-09-27 03:54:10 +0000
commitce7b2a9d4da12a1b3a8746f05de202cdf8271240 (patch)
treee323f72fb0de788cd01e39b8afb25b4e3665f80f
parent4686ef45aa4f0afbfe201d6fa4b6a552c46c2598 (diff)
downloadports-ce7b2a9d4da12a1b3a8746f05de202cdf8271240.tar.gz
ports-ce7b2a9d4da12a1b3a8746f05de202cdf8271240.zip
math/qhull8: New port.
- qhull-8.* has a significantly different API from qhull-7.* in that the only shared libraries are now libqhull_r.so*. - Add conflicts to math/qhull. Qhull computes convex hulls, Delaunay triangulations, halfspace intersections about a point, Voronoi diagrams, furthest-site Delaunay triangulations, and furthest-site Voronoi diagrams. It runs in 2-d, 3-d, 4-d, and higher dimensions. It implements the Quickhull algorithm for computing the convex hull. Qhull handles roundoff errors from floating point arithmetic. It computes volumes, surface areas, and approximations to the convex hull. WWW: http://www.qhull.org
-rw-r--r--math/qhull/Makefile2
-rw-r--r--math/qhull8/Makefile28
-rw-r--r--math/qhull8/distinfo3
-rw-r--r--math/qhull8/files/extra-patch-CMakeLists.txt12
-rw-r--r--math/qhull8/files/patch-CMakeLists.txt22
-rw-r--r--math/qhull8/pkg-descr9
-rw-r--r--math/qhull8/pkg-plist71
7 files changed, 146 insertions, 1 deletions
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 9963e8d34aed..42f6aa9bf6bb 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -18,7 +18,7 @@ USES= cmake
USE_GITHUB= yes
USE_LDCONFIG= yes
-CONFLICTS= qhull afni qhull5
+CONFLICTS= qhull-8.* afni qhull5
OPTIONS_DEFINE= DOCS
diff --git a/math/qhull8/Makefile b/math/qhull8/Makefile
new file mode 100644
index 000000000000..c8ab7e5b56da
--- /dev/null
+++ b/math/qhull8/Makefile
@@ -0,0 +1,28 @@
+# Created by: pusto@web.de
+
+PORTNAME= qhull
+DISTVERSIONPREFIX= v
+DISTVERSION= 8.0.2
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Qhull computes convex hulls, Delaunay triangulations, and halfspaces
+
+LICENSE= Qhull
+LICENSE_NAME= Qhull License
+LICENSE_FILE= ${WRKSRC}/COPYING.txt
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= cmake
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+
+CONFLICTS= qhull-7.* afni qhull5
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+DOCS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/math/qhull8/distinfo b/math/qhull8/distinfo
new file mode 100644
index 000000000000..3478ba805ffc
--- /dev/null
+++ b/math/qhull8/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632711422
+SHA256 (qhull-qhull-v8.0.2_GH0.tar.gz) = 8774e9a12c70b0180b95d6b0b563c5aa4bea8d5960c15e18ae3b6d2521d64f8b
+SIZE (qhull-qhull-v8.0.2_GH0.tar.gz) = 1307301
diff --git a/math/qhull8/files/extra-patch-CMakeLists.txt b/math/qhull8/files/extra-patch-CMakeLists.txt
new file mode 100644
index 000000000000..fa6cb16cb2c2
--- /dev/null
+++ b/math/qhull8/files/extra-patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt-orig 2021-09-26 22:47:09.634188000 -0500
++++ CMakeLists.txt 2021-09-26 22:47:25.546756000 -0500
+@@ -752,9 +752,6 @@
+ install(FILES ${libqhullcpp_HEADERS} DESTINATION ${INCLUDE_INSTALL_DIR}/libqhullcpp)
+ install(FILES html/qhull.man DESTINATION ${MAN_INSTALL_DIR} RENAME qhull.1)
+ install(FILES html/rbox.man DESTINATION ${MAN_INSTALL_DIR} RENAME rbox.1)
+-install(FILES ${doc_FILES} DESTINATION ${DOC_INSTALL_DIR})
+-install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR}/html)
+-install(FILES src/Changes.txt DESTINATION ${DOC_INSTALL_DIR}/src)
+
+ add_custom_target(uninstall
+ COMMENT "uninstall Qhull by deleting files in install_manifest.txt"
diff --git a/math/qhull8/files/patch-CMakeLists.txt b/math/qhull8/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e1e5abb35816
--- /dev/null
+++ b/math/qhull8/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+Install docs into share/doc/ rather than include/
+
+--- CMakeLists.txt.orig 2021-09-27 03:45:38 UTC
++++ CMakeLists.txt
+@@ -128,7 +128,7 @@ else()
+ endif()
+ if(MAN_INSTALL_DIR)
+ else()
+- set(MAN_INSTALL_DIR share/man/man1)
++ set(MAN_INSTALL_DIR man/man1)
+ endif()
+ if(DOC_INSTALL_DIR)
+ else()
+@@ -737,7 +737,7 @@ foreach(pkgconfig IN ITEMS "${qhull_SHAREDR};Qhull ree
+ if(LIBRARY_NAME STREQUAL "libqhull")
+ set(LIBRARY_NAME "qhull")
+ endif()
+- if(CMAKE_BUILD_TYPE STREQUAL "Debug")
++ if(FALSE AND CMAKE_BUILD_TYPE STREQUAL "Debug")
+ string(REGEX REPLACE "_(.)$" "_\\1d" LIBRARY_NAME ${LIBRARY_NAME})
+ string(REGEX REPLACE "([^d])$" "\\1_d" LIBRARY_NAME ${LIBRARY_NAME})
+ endif()
diff --git a/math/qhull8/pkg-descr b/math/qhull8/pkg-descr
new file mode 100644
index 000000000000..08361b27cc71
--- /dev/null
+++ b/math/qhull8/pkg-descr
@@ -0,0 +1,9 @@
+Qhull computes convex hulls, Delaunay triangulations, halfspace
+intersections about a point, Voronoi diagrams, furthest-site Delaunay
+triangulations, and furthest-site Voronoi diagrams. It runs in 2-d,
+3-d, 4-d, and higher dimensions. It implements the Quickhull algorithm
+for computing the convex hull. Qhull handles roundoff errors from
+floating point arithmetic. It computes volumes, surface areas, and
+approximations to the convex hull.
+
+WWW: http://www.qhull.org
diff --git a/math/qhull8/pkg-plist b/math/qhull8/pkg-plist
new file mode 100644
index 000000000000..1c08a85c08eb
--- /dev/null
+++ b/math/qhull8/pkg-plist
@@ -0,0 +1,71 @@
+bin/qconvex
+bin/qdelaunay
+bin/qhalf
+bin/qhull
+bin/qvoronoi
+bin/rbox
+include/libqhull/DEPRECATED.txt
+include/libqhull/geom.h
+include/libqhull/io.h
+include/libqhull/libqhull.h
+include/libqhull/mem.h
+include/libqhull/merge.h
+include/libqhull/poly.h
+include/libqhull/qhull_a.h
+include/libqhull/qset.h
+include/libqhull/random.h
+include/libqhull/stat.h
+include/libqhull/user.h
+include/libqhull_r/geom_r.h
+include/libqhull_r/io_r.h
+include/libqhull_r/libqhull_r.h
+include/libqhull_r/mem_r.h
+include/libqhull_r/merge_r.h
+include/libqhull_r/poly_r.h
+include/libqhull_r/qhull_ra.h
+include/libqhull_r/qset_r.h
+include/libqhull_r/random_r.h
+include/libqhull_r/stat_r.h
+include/libqhull_r/user_r.h
+include/libqhullcpp/Coordinates.h
+include/libqhullcpp/PointCoordinates.h
+include/libqhullcpp/Qhull.h
+include/libqhullcpp/QhullError.h
+include/libqhullcpp/QhullFacet.h
+include/libqhullcpp/QhullFacetList.h
+include/libqhullcpp/QhullFacetSet.h
+include/libqhullcpp/QhullHyperplane.h
+include/libqhullcpp/QhullIterator.h
+include/libqhullcpp/QhullLinkedList.h
+include/libqhullcpp/QhullPoint.h
+include/libqhullcpp/QhullPointSet.h
+include/libqhullcpp/QhullPoints.h
+include/libqhullcpp/QhullQh.h
+include/libqhullcpp/QhullRidge.h
+include/libqhullcpp/QhullSet.h
+include/libqhullcpp/QhullSets.h
+include/libqhullcpp/QhullStat.h
+include/libqhullcpp/QhullUser.h
+include/libqhullcpp/QhullVertex.h
+include/libqhullcpp/QhullVertexSet.h
+include/libqhullcpp/RboxPoints.h
+include/libqhullcpp/RoadError.h
+include/libqhullcpp/RoadLogEvent.h
+include/libqhullcpp/RoadTest.h
+include/libqhullcpp/functionObjects.h
+lib/cmake/Qhull/QhullConfig.cmake
+lib/cmake/Qhull/QhullConfigVersion.cmake
+lib/cmake/Qhull/QhullTargets-release.cmake
+lib/cmake/Qhull/QhullTargets.cmake
+lib/libqhull_r.so
+lib/libqhull_r.so.8.0
+lib/libqhull_r.so.8.0.2
+lib/libqhullcpp.a
+lib/libqhullstatic.a
+lib/libqhullstatic_r.a
+libdata/pkgconfig/qhull_r.pc
+libdata/pkgconfig/qhullcpp.pc
+libdata/pkgconfig/qhullstatic.pc
+libdata/pkgconfig/qhullstatic_r.pc
+man/man1/qhull.1.gz
+man/man1/rbox.1.gz