aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-24 03:26:34 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-24 03:26:40 +0000
commitce9b2ed6b1ce7a80749d725936d68d5fd59494f6 (patch)
tree24f23ae4206f6c9e4dfcf994d07b86aee794142a
parent65fdc2b6d37c095f2ec443943f8b8aeda2fdc4f3 (diff)
downloadports-ce9b2ed6b1ce7a80749d725936d68d5fd59494f6.tar.gz
ports-ce9b2ed6b1ce7a80749d725936d68d5fd59494f6.zip
cad/magic: update 8.3.315 → 8.3.459
-rw-r--r--cad/magic/Makefile3
-rw-r--r--cad/magic/distinfo6
-rw-r--r--cad/magic/files/patch-textio__textioInt.h6
-rw-r--r--cad/magic/files/patch-textio__txInput.c85
-rw-r--r--cad/magic/pkg-plist5
5 files changed, 53 insertions, 52 deletions
diff --git a/cad/magic/Makefile b/cad/magic/Makefile
index 9448c2ac244a..68d5c883cb3f 100644
--- a/cad/magic/Makefile
+++ b/cad/magic/Makefile
@@ -1,6 +1,5 @@
PORTNAME= magic
-DISTVERSION= 8.3.315
-PORTREVISION= 1
+DISTVERSION= 8.3.459
CATEGORIES= cad
MASTER_SITES= http://opencircuitdesign.com/magic/archive/
diff --git a/cad/magic/distinfo b/cad/magic/distinfo
index c02c531e6426..d50a52ecdd2b 100644
--- a/cad/magic/distinfo
+++ b/cad/magic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1659123533
-SHA256 (magic-8.3.315.tgz) = c9b5b86287bb286b5db391c31b7a55bf4212458b073942383ff947162d758e1e
-SIZE (magic-8.3.315.tgz) = 4175094
+TIMESTAMP = 1706064662
+SHA256 (magic-8.3.459.tgz) = 12b34564766227e0b0f1039044463da6ce7ff16a196045308fc688bb8d9d4fd4
+SIZE (magic-8.3.459.tgz) = 4237442
diff --git a/cad/magic/files/patch-textio__textioInt.h b/cad/magic/files/patch-textio__textioInt.h
index 8e55d7b95244..4a03a32c8e8a 100644
--- a/cad/magic/files/patch-textio__textioInt.h
+++ b/cad/magic/files/patch-textio__textioInt.h
@@ -1,11 +1,11 @@
---- textio/textioInt.h.orig 2020-05-24 07:00:08 UTC
+--- textio/textioInt.h.orig 2023-07-12 06:00:01 UTC
+++ textio/textioInt.h
@@ -41,7 +41,7 @@ typedef struct {
#define TX_CMD_PROMPT ":"
/* all of the state associated with a tty terminal */
--#if !defined(SYSV) && !defined(CYGWIN)
-+#if !defined(SYSV) && !defined(CYGWIN) && !defined(__FreeBSD__)
+-#if !defined(SYSV) && !defined(CYGWIN) && !defined(__OpenBSD__) && !defined(EMSCRIPTEN)
++#if !defined(SYSV) && !defined(CYGWIN) && !defined(__FreeBSD__) && !defined(__OpenBSD__) && !defined(EMSCRIPTEN)
typedef struct {
struct sgttyb tx_i_sgtty;
struct tchars tx_i_tchars;
diff --git a/cad/magic/files/patch-textio__txInput.c b/cad/magic/files/patch-textio__txInput.c
index 37c792e58e21..18fa353bd1a5 100644
--- a/cad/magic/files/patch-textio__txInput.c
+++ b/cad/magic/files/patch-textio__txInput.c
@@ -1,4 +1,4 @@
---- textio/txInput.c.orig 2020-05-24 07:00:08 UTC
+--- textio/txInput.c.orig 2023-07-12 06:00:01 UTC
+++ textio/txInput.c
@@ -28,6 +28,7 @@ static char rcsid[] __attribute__ ((unused)) = "$Heade
#include <unistd.h>
@@ -8,7 +8,7 @@
#include "utils/magsgtty.h"
-@@ -1205,14 +1206,14 @@ TxGetLine(dest, maxChars)
+@@ -1208,14 +1209,14 @@ TxGetLine(dest, maxChars)
* ----------------------------------------------------------------------------
*/
@@ -25,73 +25,72 @@
+ ioctl( fileno( stdin ), TIOCGETA, buf);
}
- #else
-@@ -1245,14 +1246,14 @@ txGetTermState(buf)
+ #elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
+@@ -1257,7 +1258,7 @@ txSetTermState(buf)
void
txSetTermState(buf)
-#if defined(SYSV) || defined(CYGWIN)
-- struct termio *buf;
+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
-+ struct termios *buf;
- #else
- txTermState *buf;
- #endif /* SYSV */
+ struct termio *buf;
+ #elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
+ struct termios *buf;
+@@ -1267,7 +1268,7 @@ txSetTermState(buf)
{
--#if defined(SYSV) || defined(CYGWIN)
-- ioctl( fileno(stdin), TCSETAF, buf );
-+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
-+ ioctl( fileno(stdin), TIOCSETAF, buf );
+ #if defined(SYSV) || defined(CYGWIN)
+ ioctl( fileno(stdin), TCSETAF, buf );
+-#elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(EMSCRIPTEN)
+ (void) tcsetattr( fileno(stdin), TCSANOW, buf );
#else
/* set the current terminal characteristics */
- (void) ioctl(fileno(stdin), TIOCSETN, (char *) &(buf->tx_i_sgtty) );
-@@ -1280,13 +1281,13 @@ txSetTermState(buf)
-
- void
+@@ -1298,13 +1299,13 @@ txInitTermRec(buf)
txInitTermRec(buf)
--#if defined(SYSV) || defined(CYGWIN)
-- struct termio *buf;
-+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
-+ struct termios *buf;
+ #if defined(SYSV) || defined(CYGWIN)
+ struct termio *buf;
+-#elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(EMSCRIPTEN)
+ struct termios *buf;
#else
txTermState *buf;
#endif /* SYSV */
{
--#if defined(SYSV) || defined(CYGWIN)
-+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
+-#if defined(SYSV) || defined(CYGWIN) || defined(__OpenBSD__) || defined(EMSCRIPTEN)
++#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(EMSCRIPTEN)
buf->c_lflag = ISIG; /* raw: no echo and no processing, allow signals */
buf->c_cc[ VMIN ] = 1;
buf->c_cc[ VTIME ] = 0;
-@@ -1301,8 +1302,8 @@ txInitTermRec(buf)
-
+@@ -1321,7 +1322,7 @@ struct termio closeTermState;
-
--#if defined(SYSV) || defined(CYGWIN)
--struct termio closeTermState;
-+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
-+struct termios closeTermState;
+ #if defined(SYSV) || defined(CYGWIN)
+ struct termio closeTermState;
+-#elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(EMSCRIPTEN)
+ struct termios closeTermState;
#else
static txTermState closeTermState;
- #endif /* SYSV */
-@@ -1328,8 +1329,8 @@ static bool haveCloseState = FALSE;
- void
+@@ -1349,13 +1350,13 @@ txSaveTerm()
txSaveTerm()
{
--#if defined(SYSV) || defined(CYGWIN)
+ #if defined(SYSV) || defined(CYGWIN)
- ioctl( fileno( stdin ), TCGETA, &closeTermState);
-+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
+ ioctl( fileno( stdin ), TIOCGETA, &closeTermState);
txEraseChar = closeTermState.c_cc[VERASE];
txKillChar = closeTermState.c_cc[VKILL];
TxEOFChar = closeTermState.c_cc[VEOF];
-@@ -1369,8 +1370,8 @@ txSaveTerm()
- void
- TxSetTerminal()
+ TxInterruptChar = closeTermState.c_cc[VINTR];
+ haveCloseState = TRUE;
+-#elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(EMSCRIPTEN)
+ (void) tcgetattr( fileno( stdin ), &closeTermState);
+ txEraseChar = closeTermState.c_cc[VERASE];
+ txKillChar = closeTermState.c_cc[VKILL];
+@@ -1398,7 +1399,7 @@ TxSetTerminal()
{
--#if defined(SYSV) || defined(CYGWIN)
-- struct termio buf;
-+#if defined(SYSV) || defined(CYGWIN) || defined(__FreeBSD__)
-+ struct termios buf;
+ #if defined(SYSV) || defined(CYGWIN)
+ struct termio buf;
+-#elif defined (__OpenBSD__) || defined(EMSCRIPTEN)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined(EMSCRIPTEN)
+ struct termios buf;
#else
txTermState buf;
- #endif /* SYSV */
diff --git a/cad/magic/pkg-plist b/cad/magic/pkg-plist
index 1e6b97ee8cb4..262ee6e39233 100644
--- a/cad/magic/pkg-plist
+++ b/cad/magic/pkg-plist
@@ -76,7 +76,8 @@ lib/magic/doc/html/graphics/corner2.gif
lib/magic/doc/html/graphics/email_address.png
lib/magic/doc/html/graphics/line1.gif
lib/magic/doc/html/graphics/magic_OGL_sm.gif
-lib/magic/doc/html/graphics/magic_title2.gif
+lib/magic/doc/html/graphics/magic_title8_3.gif
+lib/magic/doc/html/graphics/magic_title8_3.png
lib/magic/doc/html/graphics/techmgr.gif
lib/magic/doc/html/graphics/toolbar.gif
lib/magic/doc/html/graphics/writeall.gif
@@ -289,6 +290,7 @@ lib/magic/tcl/magicdnull
lib/magic/tcl/magicexec
lib/magic/tcl/mazeroute.tcl
lib/magic/tcl/readspice.tcl
+lib/magic/tcl/reorderLayers.tcl
lib/magic/tcl/socketcmd.tcl
lib/magic/tcl/strip_reflibs.tcl
lib/magic/tcl/tclmagic.so
@@ -296,6 +298,7 @@ lib/magic/tcl/techbuilder.tcl
lib/magic/tcl/texthelper.tcl
lib/magic/tcl/tkcon.tcl
lib/magic/tcl/tkshell.tcl
+lib/magic/tcl/toolbar.tcl
lib/magic/tcl/toolkit.tcl
lib/magic/tcl/toolkit_rev0.tcl
lib/magic/tcl/tools.tcl