aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2024-02-05 04:33:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2024-02-05 04:33:38 +0000
commitcf444dfaa9fb6eb8f5452830ed2b6c66cdc3ac1a (patch)
tree46756810a0c7f70a27dd8808fdc2a76523a65f0b
parent097ff820d4c53b011d3d0c7caa8d7bdf2c5de7e4 (diff)
downloadports-cf444dfaa9fb6eb8f5452830ed2b6c66cdc3ac1a.tar.gz
ports-cf444dfaa9fb6eb8f5452830ed2b6c66cdc3ac1a.zip
graphics/goxel: update the port to version 0.14.0
- Modernize the general UI of the program; add detachable UI panels, layer origin control - Improved glTF export and files opening (recent file list, remember last opened directory) - Last but not least, no longer needs GTK 3.x! Reported by: portscout
-rw-r--r--graphics/goxel/Makefile5
-rw-r--r--graphics/goxel/distinfo6
-rw-r--r--graphics/goxel/files/patch-SConstruct12
3 files changed, 11 insertions, 12 deletions
diff --git a/graphics/goxel/Makefile b/graphics/goxel/Makefile
index da578d77d189..1a41ecb50e8d 100644
--- a/graphics/goxel/Makefile
+++ b/graphics/goxel/Makefile
@@ -1,5 +1,5 @@
PORTNAME= goxel
-PORTVERSION= 0.13.0
+PORTVERSION= 0.14.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics
@@ -13,11 +13,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libglfw.so:graphics/glfw \
libpng.so:graphics/png
-USES= compiler:c++17-lang gl gnome pkgconfig scons
+USES= compiler:c++17-lang gl pkgconfig scons
USE_GITHUB= yes
GH_ACCOUNT= guillaumechereau
USE_GL= gl
-USE_GNOME= cairo gdkpixbuf2 gtk30
MAKE_ARGS= mode=release werror=false
diff --git a/graphics/goxel/distinfo b/graphics/goxel/distinfo
index 774ed67475e1..4df71ec3d6ae 100644
--- a/graphics/goxel/distinfo
+++ b/graphics/goxel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1703647244
-SHA256 (guillaumechereau-goxel-v0.13.0_GH0.tar.gz) = 33f92578bbd53c426ab577411aeba971f5164a0b7853ace1bad60386ebbb589e
-SIZE (guillaumechereau-goxel-v0.13.0_GH0.tar.gz) = 3087165
+TIMESTAMP = 1706879971
+SHA256 (guillaumechereau-goxel-v0.14.0_GH0.tar.gz) = f22aef2cd520f0a13a6fb08c63c6c0f8abc9c9814b6e9ce8978fc834a1824696
+SIZE (guillaumechereau-goxel-v0.14.0_GH0.tar.gz) = 3307561
diff --git a/graphics/goxel/files/patch-SConstruct b/graphics/goxel/files/patch-SConstruct
index 4714c01d0b9b..4e12a42d2c97 100644
--- a/graphics/goxel/files/patch-SConstruct
+++ b/graphics/goxel/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2022-08-16 08:30:35 UTC
+--- SConstruct.orig 2024-02-02 13:19:31 UTC
+++ SConstruct
-@@ -70,7 +66,7 @@ if env['mode'] not in ['debug', 'analyze']:
+@@ -66,7 +66,7 @@ if env['werror']:
env.Append(CCFLAGS='-Werror')
if env['mode'] not in ['debug', 'analyze']:
@@ -9,7 +9,7 @@
if env['mode'] == 'debug':
env.Append(CCFLAGS=['-O0'])
-@@ -88,16 +84,14 @@ for root, dirnames, filenames in os.walk('src'):
+@@ -84,15 +84,13 @@ for root, dirnames, filenames in os.walk('src'):
if filename.endswith('.c') or filename.endswith('.cpp'):
sources.append(os.path.join(root, filename))
@@ -20,10 +20,10 @@
# Linux compilation support.
if target_os == 'posix':
+ env.Append(CPPDEFINES='HAVE_LIBPNG=1')
- env.Append(LIBS=['GL', 'm', 'dl'])
+ env.Append(LIBS=['GL', 'm', 'dl', 'pthread'])
# Note: add '--static' to link with all the libs needed by glfw3.
- env.ParseConfig('pkg-config --libs glfw3')
- env.ParseConfig('pkg-config --cflags --libs gtk+-3.0')
+- env.ParseConfig('pkg-config --libs glfw3')
++ env.ParseConfig('pkg-config --cflags --libs glfw3')
+ env.ParseConfig('pkg-config --libs libpng')
# Windows compilation support.