aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 06:59:35 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-06-30 06:59:35 +0000
commitcfa9bd9252aa1c8c8278c93f58b8ea87be3116c3 (patch)
tree245592ce930bc602c099051ab4e7e3cce25e5ff5
parent3de28a30dc2d62ae500a87f7335c36483fae9625 (diff)
downloadports-cfa9bd9252aa1c8c8278c93f58b8ea87be3116c3.tar.gz
ports-cfa9bd9252aa1c8c8278c93f58b8ea87be3116c3.zip
devel/py-check-sdist: Add py-check-sdist 0.1.2
Have you ever shipped broken sdists with missing files or possibly dirty sdists with files that shouldn't have been there? Have you noticed that standards compliant tools aren't making the same sdist that flit build is? Is hatchling adding .DSStore files when you ship from your macOS? No matter what build-backend you use, check-sdist can help! Check-sdist builds an sdist and compares the contents with your Git repository contents. It can even temporarily inject common junk files (like pycache files or OS specific files) and help verify that those aren't getting bundled into your sdist. If you are getting files you didn't expect or missing files you did expect, consult your build backend's docs to see how to include or exclude files.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-check-sdist/Makefile34
-rw-r--r--devel/py-check-sdist/distinfo3
-rw-r--r--devel/py-check-sdist/pkg-descr12
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ab1b31a5785c..737c5dcf8b08 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4433,6 +4433,7 @@
SUBDIR += py-characteristic
SUBDIR += py-check-jsonschema
SUBDIR += py-check-manifest
+ SUBDIR += py-check-sdist
SUBDIR += py-cheetah3
SUBDIR += py-circuitbreaker
SUBDIR += py-circuits
diff --git a/devel/py-check-sdist/Makefile b/devel/py-check-sdist/Makefile
new file mode 100644
index 000000000000..78016d5fafeb
--- /dev/null
+++ b/devel/py-check-sdist/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= check-sdist
+PORTVERSION= 0.1.2
+CATEGORIES= devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= check_sdist-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Check the contents of an sdist vs git
+WWW= https://github.com/henryiii/check-sdist
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0:devel/py-hatchling@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}build>=0:devel/py-build@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pathspec>=0:devel/py-pathspec@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 30900
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=0:devel/py-importlib-resources@${PY_FLAVOR}
+.endif
+
+.if ${PYTHON_REL} < 31100
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tomli>=0:textproc/py-tomli@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-check-sdist/distinfo b/devel/py-check-sdist/distinfo
new file mode 100644
index 000000000000..a19fa392721c
--- /dev/null
+++ b/devel/py-check-sdist/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1686496666
+SHA256 (check_sdist-0.1.2.tar.gz) = c331275c72760ee5b5fac8f9085652c2be4da1a09bcd566cae1d3301b528e1ca
+SIZE (check_sdist-0.1.2.tar.gz) = 12845
diff --git a/devel/py-check-sdist/pkg-descr b/devel/py-check-sdist/pkg-descr
new file mode 100644
index 000000000000..7c10032019d5
--- /dev/null
+++ b/devel/py-check-sdist/pkg-descr
@@ -0,0 +1,12 @@
+Have you ever shipped broken sdists with missing files or possibly dirty sdists
+with files that shouldn't have been there? Have you noticed that standards
+compliant tools aren't making the same sdist that flit build is? Is hatchling
+adding .DSStore files when you ship from your macOS? No matter what
+build-backend you use, check-sdist can help!
+
+Check-sdist builds an sdist and compares the contents with your Git repository
+contents. It can even temporarily inject common junk files (like pycache files
+or OS specific files) and help verify that those aren't getting bundled into
+your sdist. If you are getting files you didn't expect or missing files you did
+expect, consult your build backend's docs to see how to include or exclude
+files.