aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-06-26 02:21:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-06-26 15:53:03 +0000
commitcfac51d76e5f4115db4e3bd1fdf242d19ffb17b8 (patch)
treebe6542e050f2e3d19473c28a275dd3bac6049233
parent852ccdb4dcdd02b48a461f49c3b076ef106db352 (diff)
downloadports-cfac51d76e5f4115db4e3bd1fdf242d19ffb17b8.tar.gz
ports-cfac51d76e5f4115db4e3bd1fdf242d19ffb17b8.zip
devel/actor-framework: Update 0.19.0 → 0.19.2
Reported by: portscout
-rw-r--r--devel/actor-framework/Makefile4
-rw-r--r--devel/actor-framework/distinfo6
-rw-r--r--devel/actor-framework/pkg-plist15
3 files changed, 13 insertions, 12 deletions
diff --git a/devel/actor-framework/Makefile b/devel/actor-framework/Makefile
index c821bd4ed6f1..00c0ebdda77b 100644
--- a/devel/actor-framework/Makefile
+++ b/devel/actor-framework/Makefile
@@ -1,5 +1,5 @@
PORTNAME= actor-framework
-DISTVERSION= 0.19.0
+DISTVERSION= 0.19.2
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -15,7 +15,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
CMAKE_OFF= CAF_ENABLE_TESTING
-CMAKE_TESTING_ON= CAF_ENABLE_TESTING
+CMAKE_TESTING_ON= CAF_ENABLE_TESTING # the decorator.sequencer testcase fails intermittently, see https://github.com/actor-framework/actor-framework/issues/1456
OPTIONS_DEFINE= DEBUG
OPTIONS_RADIO= LOG_LEVEL
diff --git a/devel/actor-framework/distinfo b/devel/actor-framework/distinfo
index ef679f838779..4d6e53568deb 100644
--- a/devel/actor-framework/distinfo
+++ b/devel/actor-framework/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1681882978
-SHA256 (actor-framework-actor-framework-0.19.0_GH0.tar.gz) = 9ecf8bf9b4add10a44f71332f15e02a4ac7799062de76efb8e8f2999aa9b3713
-SIZE (actor-framework-actor-framework-0.19.0_GH0.tar.gz) = 3177012
+TIMESTAMP = 1687735259
+SHA256 (actor-framework-actor-framework-0.19.2_GH0.tar.gz) = aa3fcc494424e0e20b177125458a6a6ed39c751a3d3d5193054e88bdf8a146d2
+SIZE (actor-framework-actor-framework-0.19.2_GH0.tar.gz) = 3188536
diff --git a/devel/actor-framework/pkg-plist b/devel/actor-framework/pkg-plist
index 403c2d94c945..57e4948488c7 100644
--- a/devel/actor-framework/pkg-plist
+++ b/devel/actor-framework/pkg-plist
@@ -1,3 +1,5 @@
+bin/caf-run
+bin/caf-vec
include/caf/abstract_actor.hpp
include/caf/abstract_channel.hpp
include/caf/abstract_group.hpp
@@ -51,6 +53,7 @@ include/caf/caf_main.hpp
include/caf/callback.hpp
include/caf/catch_all.hpp
include/caf/check_typed_input.hpp
+include/caf/chrono.hpp
include/caf/composed_type.hpp
include/caf/config.hpp
include/caf/config_option.hpp
@@ -152,6 +155,7 @@ include/caf/detail/parser/read_number_or_timespan.hpp
include/caf/detail/parser/read_signed_integer.hpp
include/caf/detail/parser/read_string.hpp
include/caf/detail/parser/read_timespan.hpp
+include/caf/detail/parser/read_timestamp.hpp
include/caf/detail/parser/read_unsigned_integer.hpp
include/caf/detail/parser/read_uri.hpp
include/caf/detail/parser/sub_ascii.hpp
@@ -342,7 +346,6 @@ include/caf/io/network/stream_manager.hpp
include/caf/io/network/test_multiplexer.hpp
include/caf/io/open.hpp
include/caf/io/publish.hpp
-include/caf/io/publish_local_groups.hpp
include/caf/io/receive_policy.hpp
include/caf/io/remote_actor.hpp
include/caf/io/remote_group.hpp
@@ -604,13 +607,13 @@ lib/cmake/CAF/CAFConfigVersion.cmake
lib/cmake/CAF/CAFTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/CAF/CAFTargets.cmake
lib/libcaf_core.so
-lib/libcaf_core.so.0.19.0
+lib/libcaf_core.so.0.19.2
lib/libcaf_io.so
-lib/libcaf_io.so.0.19.0
+lib/libcaf_io.so.0.19.2
lib/libcaf_net.so
-lib/libcaf_net.so.0.19.0
+lib/libcaf_net.so.0.19.2
lib/libcaf_openssl.so
-lib/libcaf_openssl.so.0.19.0
+lib/libcaf_openssl.so.0.19.2
share/caf/examples/aout.cpp
share/caf/examples/config/read-json.cpp
share/caf/examples/custom_type/custom_types_1.cpp
@@ -644,5 +647,3 @@ share/caf/examples/web_socket/echo.cpp
share/caf/examples/web_socket/hello-client.cpp
share/caf/examples/web_socket/quote-server.cpp
share/caf/examples/web_socket/stock-ticker.cpp
-share/caf/tools/caf-run
-share/caf/tools/caf-vec