aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-16 17:46:13 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-16 17:46:51 +0000
commitd063fe8268d6ab29f725c67007692fd3eb12d6d3 (patch)
treedde4d11a0584b29ce87e559460ecc2dfb7cf3850
parent6c200f6b41b28acc6f4a758d4386fd9ebbff3f74 (diff)
downloadports-d063fe8268d6ab29f725c67007692fd3eb12d6d3.tar.gz
ports-d063fe8268d6ab29f725c67007692fd3eb12d6d3.zip
converters/wkhtmltopdf: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--converters/wkhtmltopdf/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index eef0ffa05404..bd9433401cfd 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -78,6 +78,13 @@ post-patch:
${ECHO} 'LIBS+= -lcrypto' >>${WRKSRC}/src/pdf/pdf.pro
${MKDIR} ${WRKSRC}/build/app ${WRKSRC}/build/qt \
${WRKSRC}/build/wkhtmltox
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+ ${REINPLACE_CMD} -e "s|register int|int|g" \
+ ${PATCH_WRKSRC}/src/corelib/kernel/qcore_unix_p.h
+ ${REINPLACE_CMD} -e "s|register UWORD32|UWORD32|g" \
+ ${PATCH_WRKSRC}/../qt-5db36ec/src/3rdparty/md5/md5.cpp
+.endif
+
post-build:
cd ${WRKSRC}/build/app && ${SETENV} ${MAKE_ENV} \