aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
commitd09ed096c44ca516f3e4922e292b4afabd03ff11 (patch)
tree8472e59ca02578120ca7b8bc5e2af50d2954440e
parent31a195fb72446a7d02336b8fa1b9c1e0032f95cb (diff)
downloadports-d09ed096c44ca516f3e4922e292b4afabd03ff11.tar.gz
ports-d09ed096c44ca516f3e4922e292b4afabd03ff11.zip
*/*: Replace USE_GCC=any with USE_GCC=yes
USE_GCC=any has been equivalent to USE_GCC=yes in most cases (such as i386 and amd64 since 12.x and depending on configuration 11.x, most newer installations on other platforms, and 13.x across the board). Since commit 96c17633d90386b5bcf8 Mk/bsd.gcc.mk is treating them as different spellings of the same, so continue the deorbiting of the USE_GCC=any form and simply replace it with USE_GCC=yes. This should not make any functional difference at all. Discussed with: mat, linimon, pkubaj
-rw-r--r--archivers/paq/Makefile2
-rw-r--r--audio/openspc/Makefile2
-rw-r--r--benchmarks/polygraph/Makefile2
-rw-r--r--cad/freehdl/Makefile2
-rw-r--r--cad/graywolf/Makefile2
-rw-r--r--databases/dbixx/Makefile2
-rw-r--r--databases/fastdb/Makefile2
-rw-r--r--databases/gigabase/Makefile2
-rw-r--r--databases/gnats4/Makefile2
-rw-r--r--databases/mysql-q4m/Makefile2
-rw-r--r--deskutils/sliderule/Makefile2
-rw-r--r--devel/asmutils/Makefile2
-rw-r--r--devel/jna/Makefile2
-rw-r--r--devel/raknet/Makefile2
-rw-r--r--editors/cooledit/Makefile2
-rw-r--r--emulators/skyeye/Makefile2
-rw-r--r--emulators/x49gp/Makefile2
-rw-r--r--games/mirrormagic/Makefile2
-rw-r--r--games/shaaft/Makefile2
-rw-r--r--graphics/dcp2icc/Makefile2
-rw-r--r--graphics/geomorph/Makefile2
-rw-r--r--graphics/nurbs++/Makefile2
-rw-r--r--irc/ezbounce/Makefile2
-rw-r--r--japanese/skkinput3/Makefile2
-rw-r--r--java/sigar/Makefile2
-rw-r--r--lang/clisp/Makefile2
-rw-r--r--lang/gforth/Makefile2
-rw-r--r--lang/mlton/Makefile2
-rw-r--r--lang/oo2c/Makefile2
-rw-r--r--mail/hashcash/Makefile2
-rw-r--r--mail/milter-callback/Makefile2
-rw-r--r--mail/spamdyke/Makefile2
-rw-r--r--math/cvc3/Makefile2
-rw-r--r--math/lidia/Makefile2
-rw-r--r--multimedia/vdr/Makefile2
-rw-r--r--multimedia/x264/Makefile2
-rw-r--r--multimedia/xanim/Makefile2
-rw-r--r--net/libtnl/Makefile2
-rw-r--r--net/nepenthes/Makefile2
-rw-r--r--net/tightvnc/Makefile2
-rw-r--r--security/hashcat-legacy/Makefile2
-rw-r--r--security/masscan/Makefile2
-rw-r--r--security/pks/Makefile2
-rw-r--r--security/seccure/Makefile2
-rw-r--r--sysutils/lcdproc/Makefile2
-rw-r--r--sysutils/libdnf/Makefile2
-rw-r--r--sysutils/libretto-config/Makefile2
-rw-r--r--textproc/senna/Makefile2
-rw-r--r--www/anyterm/Makefile2
-rw-r--r--www/mod_authnz_crowd/Makefile2
-rw-r--r--www/thundercache/Makefile2
-rw-r--r--x11-drivers/xf86-video-vmware/Makefile2
52 files changed, 52 insertions, 52 deletions
diff --git a/archivers/paq/Makefile b/archivers/paq/Makefile
index 1a627ac58038..bf8a58ba238b 100644
--- a/archivers/paq/Makefile
+++ b/archivers/paq/Makefile
@@ -65,7 +65,7 @@ PORTDATA= ${WDATA} ${DDATA} zpsfx
.if ${PORT_OPTIONS:MOPENMP}
OPENMP_CFLAGS+= -fopenmp
-USE_GCC= any
+USE_GCC= yes
BROKEN= does not build
.endif
diff --git a/audio/openspc/Makefile b/audio/openspc/Makefile
index 23a97551740c..7ee3e82bcda6 100644
--- a/audio/openspc/Makefile
+++ b/audio/openspc/Makefile
@@ -15,7 +15,7 @@ ONLY_FOR_ARCHS= i386 # contains x86 asm code
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= autoreconf libtool
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= yes
PORTDOCS= README
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index 3f7a5dab616c..d616581fafc6 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake ncurses shebangfix
SHEBANG_FILES= tools/*.pl
-USE_GCC= any
+USE_GCC= yes
GNU_CONFIGURE= yes
# The port does not build with C++11 or later (bug 219275).
diff --git a/cad/freehdl/Makefile b/cad/freehdl/Makefile
index a256e21d52ff..5981b6b90612 100644
--- a/cad/freehdl/Makefile
+++ b/cad/freehdl/Makefile
@@ -11,7 +11,7 @@ COMMENT= Free VHDL simulator
USES= gmake pathfix libtool makeinfo perl5 pkgconfig
USE_LDCONFIG= yes
-USE_GCC= any
+USE_GCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= SYSTEM_LIBTOOL=${FALSE}
INSTALL_TARGET= install-strip
diff --git a/cad/graywolf/Makefile b/cad/graywolf/Makefile
index d906a76b8d98..a2fa7d1d592c 100644
--- a/cad/graywolf/Makefile
+++ b/cad/graywolf/Makefile
@@ -33,7 +33,7 @@ GH_ACCOUNT= rubund
SHEBANG_GLOB= *.sh
-USE_GCC= any # lots of obviously incorrect C where clang fails, which gcc nevertheless magically finds a way to compile
+USE_GCC= yes # lots of obviously incorrect C where clang fails, which gcc nevertheless magically finds a way to compile
CFLAGS+= -fcommon
diff --git a/databases/dbixx/Makefile b/databases/dbixx/Makefile
index 43c29edbfb93..f9ca3f4ee197 100644
--- a/databases/dbixx/Makefile
+++ b/databases/dbixx/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= libdbi-drivers>=0:databases/libdbi-drivers
GNU_CONFIGURE= yes
USES= libtool localbase:ldflags pathfix
USE_LDCONFIG= yes
-USE_GCC= any
+USE_GCC= yes
INSTALL_TARGET= install-strip
diff --git a/databases/fastdb/Makefile b/databases/fastdb/Makefile
index 82ca5f93e48f..586c28e18d85 100644
--- a/databases/fastdb/Makefile
+++ b/databases/fastdb/Makefile
@@ -12,7 +12,7 @@ COMMENT= Main Memory Relational Database Management System
LICENSE= MIT
USES= gmake dos2unix
-USE_GCC= any
+USE_GCC= yes
MAKE_ENV= OSTYPE="${OPSYS}"
MAKEFILE= makefile
USE_LDCONFIG= yes
diff --git a/databases/gigabase/Makefile b/databases/gigabase/Makefile
index 3991281add70..8969a4d71fcb 100644
--- a/databases/gigabase/Makefile
+++ b/databases/gigabase/Makefile
@@ -17,7 +17,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
USES= autoreconf dos2unix gmake libtool
DOS2UNIX_FILES= Makefile.in configure.in *.cpp *.h
-USE_GCC= any
+USE_GCC= yes
USE_CXXSTD= gnu++98
USE_LDCONFIG= yes
diff --git a/databases/gnats4/Makefile b/databases/gnats4/Makefile
index 6c445399341f..207098da4a06 100644
--- a/databases/gnats4/Makefile
+++ b/databases/gnats4/Makefile
@@ -17,7 +17,7 @@ BROKEN_FreeBSD_12_powerpc64= fails to build on powerpc64 elfv1: conflicting type
GNU_CONFIGURE= yes
USES= cpe gmake makeinfo
-USE_GCC= any
+USE_GCC= yes
USERS= gnats
CPE_VENDOR= gnu
diff --git a/databases/mysql-q4m/Makefile b/databases/mysql-q4m/Makefile
index 1a1a797877fd..cd07099c09ff 100644
--- a/databases/mysql-q4m/Makefile
+++ b/databases/mysql-q4m/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS+= ${NONEXISTENT}:${_MYSQL_SERVER}:build
USES= gmake perl5 libtool mysql:server
IGNORE_WITH_MYSQL= 57 80 101m 102m 103m 57p 57w
-USE_GCC= any
+USE_GCC= yes
USE_PERL5= run
GNU_CONFIGURE= yes
diff --git a/deskutils/sliderule/Makefile b/deskutils/sliderule/Makefile
index a6b172278650..8197b2c55a59 100644
--- a/deskutils/sliderule/Makefile
+++ b/deskutils/sliderule/Makefile
@@ -12,7 +12,7 @@ COMMENT= The part of X11R3's xcalc featuring a slide rule
USES= imake xorg
USE_XORG= x11 xext
-USE_GCC= any
+USE_GCC= yes
PLIST_FILES= bin/sliderule man/man1/sliderule.1.gz
.include <bsd.port.mk>
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index f8a286097969..f3729fbe7b60 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -16,7 +16,7 @@ ONLY_FOR_ARCHS= i386
BUILD_DEPENDS= nasm:devel/nasm
USES= gmake
-USE_GCC= any
+USE_GCC= yes
MAKE_ARGS= OS="${OPSYS:tu}" KERNEL="${OSREL:S/.//g}" CC="${CC}" LD="${LD}"
# This will play merry hell with portlint(1)
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index b92d1455a47c..b911e9d37b09 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -41,7 +41,7 @@ ANT_ARCH= ${ARCH:S/amd64/x86-64/:S/i386/x86/:S/powerpc64/ppc64/}
.include <bsd.port.options.mk>
.if ${ARCH:Mpowerpc64*}
-USE_GCC= any
+USE_GCC= yes
.endif
post-patch:
diff --git a/devel/raknet/Makefile b/devel/raknet/Makefile
index f69fe6cd21b1..06be075caa3d 100644
--- a/devel/raknet/Makefile
+++ b/devel/raknet/Makefile
@@ -30,7 +30,7 @@ NO_WRKSUBDIR= yes
USES= dos2unix cmake:insource zip
USE_LDCONFIG= yes
-USE_GCC= any
+USE_GCC= yes
DOS2UNIX_REGEX= .*\.(cpp|h|txt)
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 441812e155de..c8cb968de494 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gettext gmake libtool python xorg # gettext is linked to despite .mo files having been deleted
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= yes
USE_XORG= x11 xt
GNU_CONFIGURE= yes
diff --git a/emulators/skyeye/Makefile b/emulators/skyeye/Makefile
index b953ccb8aad8..4a1b566115bd 100644
--- a/emulators/skyeye/Makefile
+++ b/emulators/skyeye/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
USE_CSTD= gnu89
USE_BINUTILS= yes
-USE_GCC= any
+USE_GCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_func_working_mktime=yes
CFLAGS+= -fcommon
diff --git a/emulators/x49gp/Makefile b/emulators/x49gp/Makefile
index d9193b2c3682..f94106bf4681 100644
--- a/emulators/x49gp/Makefile
+++ b/emulators/x49gp/Makefile
@@ -21,7 +21,7 @@ NOT_FOR_ARCHS_REASON= unsupported CPU = unknown
WRKSRC= ${WRKDIR}/x49gp/x49gp-code
USES= gmake gnome pkgconfig xorg
-USE_GCC= any
+USE_GCC= yes
USE_XORG= x11
USE_GNOME= gtk20
diff --git a/games/mirrormagic/Makefile b/games/mirrormagic/Makefile
index 925d210251a1..ede639c69356 100644
--- a/games/mirrormagic/Makefile
+++ b/games/mirrormagic/Makefile
@@ -16,7 +16,7 @@ USES= gmake
MAKE_ARGS= CC="${CC}" MAKE="${MAKE_CMD}" OPTIONS="${CFLAGS}" \
RO_GAME_DIR="${DATADIR}" RW_GAME_DIR="${DATADIR}/scores" \
X11_PATH="${LOCALBASE}"
-USE_GCC= any # doesn't start otherwise (UB?)
+USE_GCC= yes # doesn't start otherwise (UB?)
PORTDATA= *
PORTDOCS= *
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index f35903c651c4..574369fdc632 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= criticalmass-*
USES= gl sdl tar:bzip2
USE_SDL= mixer image sdl
USE_GL= gl
-USE_GCC= any
+USE_GCC= yes
USE_CXXSTD= gnu++98
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-optimize
diff --git a/graphics/dcp2icc/Makefile b/graphics/dcp2icc/Makefile
index 59a48c85dcb5..187d237480e2 100644
--- a/graphics/dcp2icc/Makefile
+++ b/graphics/dcp2icc/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
liblcms.so:graphics/lcms
USES= localbase:ldflags scons tar:bzip2
-USE_GCC= any # segfaults on exit when built with Clang
+USE_GCC= yes # segfaults on exit when built with Clang
PLIST_FILES= bin/${PORTNAME}
diff --git a/graphics/geomorph/Makefile b/graphics/geomorph/Makefile
index da7a82e5e7e3..df7cbe2e950f 100644
--- a/graphics/geomorph/Makefile
+++ b/graphics/geomorph/Makefile
@@ -16,7 +16,7 @@ SHEBANG_FILES= update-rc
USE_GL= gl glu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libintl-prefix="${LOCALBASE}"
-USE_GCC= any # lots of severely broken code
+USE_GCC= yes # lots of severely broken code
CFLAGS+= -fcommon
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/graphics/nurbs++/Makefile b/graphics/nurbs++/Makefile
index 75edc3a24440..7a8f838bca91 100644
--- a/graphics/nurbs++/Makefile
+++ b/graphics/nurbs++/Makefile
@@ -11,7 +11,7 @@ COMMENT= C++ library to manipulate and create NURBS curves and surfaces
USES= libtool tar:bzip2
GNU_CONFIGURE= yes
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/irc/ezbounce/Makefile b/irc/ezbounce/Makefile
index 35d40ded6160..318e06aa460e 100644
--- a/irc/ezbounce/Makefile
+++ b/irc/ezbounce/Makefile
@@ -21,7 +21,7 @@ COMPRESS_DESC= Chat log compression (requires boost)
GNU_CONFIGURE= yes
USES= compiler:c++0x gmake
-USE_GCC= any
+USE_GCC= yes
# ezbounce 1.99.15 isn't compatible with C++11 and later, which some compilers
# such as GCC 6 default to.
diff --git a/japanese/skkinput3/Makefile b/japanese/skkinput3/Makefile
index d5dabd523b2c..5384b237ad95 100644
--- a/japanese/skkinput3/Makefile
+++ b/japanese/skkinput3/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= koma2@lovepeers.org
COMMENT= SKK-like Japanese input method for X11
USES= imake xorg
-USE_GCC= any
+USE_GCC= yes
USE_CSTD= gnu89
USE_XORG= ice sm x11 xext xmu xt
MAKE_JOBS_UNSAFE= yes
diff --git a/java/sigar/Makefile b/java/sigar/Makefile
index 18106d98ad0f..12a2150be3ed 100644
--- a/java/sigar/Makefile
+++ b/java/sigar/Makefile
@@ -27,7 +27,7 @@ USE_PERL5= build
USE_JAVA= yes
JAVA_VERSION= 8
JAVA_RUN= yes
-USE_GCC= any
+USE_GCC= yes
NO_CCACHE= yes
ANT_CMD?= ${LOCALBASE}/bin/ant
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index ba855179a6cb..d87be5d8f86c 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libffcall.so:devel/libffcall \
libsigsegv.so:devel/libsigsegv
USES= compiler gettext ghostscript gnome iconv localbase:ldflags
-USE_GCC= any
+USE_GCC= yes
USE_GITLAB= yes
GL_ACCOUNT= gnu-clisp
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index c21b37935b8a..2b2f188b06d8 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libavcall.so:devel/libffcall \
libltdl.so:devel/libltdl
USES= gmake libtool:build localbase makeinfo
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= ${PREFIX}/lib/gforth/${PORTVERSION}/libcc-named
GNU_CONFIGURE= yes
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index 68b9afaa069d..407e3d7cf258 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -32,7 +32,7 @@ MINGW32_DESC= Add the mingw32 target (requires wine)
MAKE_JOBS_UNSAFE= yes
USES= gmake shebangfix
-USE_GCC= any
+USE_GCC= yes
.include <bsd.port.options.mk>
diff --git a/lang/oo2c/Makefile b/lang/oo2c/Makefile
index bc7cb9a51926..4b29a85cb3df 100644
--- a/lang/oo2c/Makefile
+++ b/lang/oo2c/Makefile
@@ -22,7 +22,7 @@ USES= gmake libtool:build localbase:ldflags tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_CSTD= gnu89
-USE_GCC= any
+USE_GCC= yes
OPTIONS_DEFINE= DOCS THREADS
OPTIONS_SUB= yes
diff --git a/mail/hashcash/Makefile b/mail/hashcash/Makefile
index b0b02201dee2..35ca86801903 100644
--- a/mail/hashcash/Makefile
+++ b/mail/hashcash/Makefile
@@ -29,7 +29,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${ARCH:Mpowerpc*}
-USE_GCC= any
+USE_GCC= yes
.endif
post-patch-DOCS-off:
diff --git a/mail/milter-callback/Makefile b/mail/milter-callback/Makefile
index 957548330aec..ce7809963394 100644
--- a/mail/milter-callback/Makefile
+++ b/mail/milter-callback/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libspf2.so:mail/libspf2
USES= compiler tar:xz
USE_RC_SUBR= milter-callback
-USE_GCC= any
+USE_GCC= yes
SUB_FILES= pkg-message
diff --git a/mail/spamdyke/Makefile b/mail/spamdyke/Makefile
index 9751a5a1af88..34d468f21e79 100644
--- a/mail/spamdyke/Makefile
+++ b/mail/spamdyke/Makefile
@@ -21,7 +21,7 @@ USES= cpe qmail tar:tgz
WRKSRC= ${WRKDIR}/${DISTNAME}/spamdyke
GNU_CONFIGURE= yes
ALL_TARGET= spamdyke
-USE_GCC= any
+USE_GCC= yes
OPTIONS_DEFINE= TLS DEBUG DEBUG_EXCESSIVE DOCS
OPTIONS_DEFAULT= TLS
diff --git a/math/cvc3/Makefile b/math/cvc3/Makefile
index 4f23e01e39ff..5581e7c38ddd 100644
--- a/math/cvc3/Makefile
+++ b/math/cvc3/Makefile
@@ -21,7 +21,7 @@ GNU_CONFIGURE= yes
USES= bison gmake pathfix perl5
PATHFIX_MAKEFILEIN= Makefile
USE_CXXSTD= gnu++98
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= yes
post-patch:
diff --git a/math/lidia/Makefile b/math/lidia/Makefile
index c8c8da6b5113..5d73c637e7b6 100644
--- a/math/lidia/Makefile
+++ b/math/lidia/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libgmp.so:math/gmp
USES= gmake localbase:ldflags tar:bz2 libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static --enable-shared --with-extra-libs=${LOCALBASE}/lib
-USE_GCC= any # doesn't build with clang, no active developers to fix this: https://github.com/mkoeppe/LiDIA/issues/6
+USE_GCC= yes # doesn't build with clang, no active developers to fix this: https://github.com/mkoeppe/LiDIA/issues/6
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/multimedia/vdr/Makefile b/multimedia/vdr/Makefile
index 240e1f25a455..5e5a3666d6b0 100644
--- a/multimedia/vdr/Makefile
+++ b/multimedia/vdr/Makefile
@@ -68,7 +68,7 @@ IGNORE= will not work due to lack of driver support
.endif
.if ${ARCH} == "i386"
-USE_GCC= any
+USE_GCC= yes
.endif
post-patch:
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 434d005f329b..788556e8738a 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -93,7 +93,7 @@ PGO_ALL_TARGET= fprofiled
# y4m sample video
Y4M_VIDEO= example.y4m
Y4M_VIDEO_DISTFILE= example.y4m.bz2
-PGO_VARS= USE_GCC=any \
+PGO_VARS= USE_GCC=yes \
LICENSE+=PGO LICENSE_COMB=multi
# ${Y4M_VIDEO_DISTFILE} file may not be mirrored
diff --git a/multimedia/xanim/Makefile b/multimedia/xanim/Makefile
index 35f67639d478..36e3c5806b17 100644
--- a/multimedia/xanim/Makefile
+++ b/multimedia/xanim/Makefile
@@ -22,7 +22,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
# which is fatal for imake.
USES= alias imake xorg
-USE_GCC= any
+USE_GCC= yes
USE_XORG= xext xt sm ice xext x11
MAKE_ARGS+= -j 2 # safe and helps even the single-CPU machines
DLLDIR= ${PREFIX}/lib/X11/xanim
diff --git a/net/libtnl/Makefile b/net/libtnl/Makefile
index 2b010bbfd048..580d3985d941 100644
--- a/net/libtnl/Makefile
+++ b/net/libtnl/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
USES= uidfix
-USE_GCC= any
+USE_GCC= yes
WRKSRC= ${WRKDIR}/tnl/tnl
USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index 1841e160b1a6..a477d0452935 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre \
USES= dos2unix libtool perl5
USE_CXXSTD= gnu++98
-USE_GCC= any
+USE_GCC= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
INSTALL_TARGET= install-strip
diff --git a/net/tightvnc/Makefile b/net/tightvnc/Makefile
index 8cdae360d05f..491c709fc2f3 100644
--- a/net/tightvnc/Makefile
+++ b/net/tightvnc/Makefile
@@ -44,7 +44,7 @@ PREFIX=${TIGHTVNC_BASE}
.include <bsd.port.pre.mk>
.if ${ARCH} == aarch64 || ${ARCH:Mpowerpc64*} || ${ARCH} == riscv64
-USE_GCC= any
+USE_GCC= yes
.endif
.if exists(${PREFIX}/share/vnc/classes/index.vnc)
diff --git a/security/hashcat-legacy/Makefile b/security/hashcat-legacy/Makefile
index 7135fa3ca679..7644c757eb26 100644
--- a/security/hashcat-legacy/Makefile
+++ b/security/hashcat-legacy/Makefile
@@ -20,7 +20,7 @@ USE_GITHUB= yes
GH_ACCOUNT= hashcat
USES= gmake
-USE_GCC= any
+USE_GCC= yes
ALL_TARGET= posix64 posixXOP
diff --git a/security/masscan/Makefile b/security/masscan/Makefile
index 363abd1f6590..a74b6e7ff90b 100644
--- a/security/masscan/Makefile
+++ b/security/masscan/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= bin/masscan man/man8/masscan.8.gz
.include <bsd.port.options.mk>
.if ${ARCH} == powerpc64 || ${ARCH} == powerpc
-USE_GCC= any
+USE_GCC= yes
.endif
do-install:
diff --git a/security/pks/Makefile b/security/pks/Makefile
index f2d122e32b86..af3c2c3db49c 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -17,7 +17,7 @@ BROKEN_SSL= openssl
BROKEN_SSL_REASON_openssl= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')
USES= bdb ssl
-USE_GCC= any
+USE_GCC= yes
USE_RC_SUBR= pksd
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/security/seccure/Makefile b/security/seccure/Makefile
index 68a82524e77f..65c6c8878b44 100644
--- a/security/seccure/Makefile
+++ b/security/seccure/Makefile
@@ -15,6 +15,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libgcrypt.so:security/libgcrypt
-USE_GCC= any
+USE_GCC= yes
.include <bsd.port.mk>
diff --git a/sysutils/lcdproc/Makefile b/sysutils/lcdproc/Makefile
index 2d701d4ddbc1..57deb81b9d3d 100644
--- a/sysutils/lcdproc/Makefile
+++ b/sysutils/lcdproc/Makefile
@@ -93,7 +93,7 @@ PLIST_SUB+= X86="@comment "
.endif
.if ${ARCH:Mpowerpc64*}
-USE_GCC= any
+USE_GCC= yes
.endif
.if ${PORT_OPTIONS:MUSB}
diff --git a/sysutils/libdnf/Makefile b/sysutils/libdnf/Makefile
index 64c04c636c1d..39d31c9db03e 100644
--- a/sysutils/libdnf/Makefile
+++ b/sysutils/libdnf/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
USES= cmake compiler:c++11-lang gettext gnome pkgconfig sqlite ssl
USE_GNOME= glib20
USE_LDCONFIG= yes
-USE_GCC= any # clang fails: https://github.com/rpm-software-management/libdnf/issues/1038
+USE_GCC= yes # clang fails: https://github.com/rpm-software-management/libdnf/issues/1038
USE_GITHUB= yes
GH_ACCOUNT= rpm-software-management
diff --git a/sysutils/libretto-config/Makefile b/sysutils/libretto-config/Makefile
index 4f905468b860..69533141a590 100644
--- a/sysutils/libretto-config/Makefile
+++ b/sysutils/libretto-config/Makefile
@@ -14,7 +14,7 @@ ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/libapm
-USE_GCC= any
+USE_GCC= yes
PORTDOCS= *
OPTIONS_DEFINE= DOCS
diff --git a/textproc/senna/Makefile b/textproc/senna/Makefile
index 4a8a45595192..48dfef0d8030 100644
--- a/textproc/senna/Makefile
+++ b/textproc/senna/Makefile
@@ -15,7 +15,7 @@ BROKEN_sparc64= does not build: libsenna.so: undefined reference to SEN_ATOMIC_
USES= compiler:c11 gmake libtool pathfix
GNU_CONFIGURE= yes
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-sennahome=${SENNA_HOME}
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
diff --git a/www/anyterm/Makefile b/www/anyterm/Makefile
index a1709fd69258..ae8c22bd90eb 100644
--- a/www/anyterm/Makefile
+++ b/www/anyterm/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs
USE_RC_SUBR= anytermd
USES= compiler:c++11-lang gmake iconv localbase tar:tbz2
-USE_GCC= any
+USE_GCC= yes
ALL_TARGET= default_target
PLIST_FILES= man/man1/anytermd.1.gz \
sbin/anytermd
diff --git a/www/mod_authnz_crowd/Makefile b/www/mod_authnz_crowd/Makefile
index 7c534b5ac0e6..f165fd95cee2 100644
--- a/www/mod_authnz_crowd/Makefile
+++ b/www/mod_authnz_crowd/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
LIBS+= -L${LOCALBASE}/lib
USES= apache:2.2+ autoreconf gnome libtool
USE_GNOME= libxml2
-USE_GCC= any
+USE_GCC= yes
SUB_FILES= pkg-message zzz_authnz_crowd.conf
SUB_LIST+= APACHEETCDIR=${APACHEETCDIR} \
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index 905e0894d815..6e5ea4c79c65 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -26,7 +26,7 @@ PGSQL_DESC= Install PostgreSQL (report data storing)
USES= php shebangfix tar:bzip2 ssl
SHEBANG_FILES= sbin/thunderlog.php
-USE_GCC= any
+USE_GCC= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/x11-drivers/xf86-video-vmware/Makefile b/x11-drivers/xf86-video-vmware/Makefile
index a654f41cd228..53f8b54191a4 100644
--- a/x11-drivers/xf86-video-vmware/Makefile
+++ b/x11-drivers/xf86-video-vmware/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ARGS= --without-libudev
.include <bsd.port.options.mk>
.if ${ARCH} == i386
-USE_GCC= any
+USE_GCC= yes
.endif
.include <bsd.port.mk>