aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-09-21 22:12:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-09-21 22:12:11 +0000
commitd0eab093ac5a5f877a0093a6f7b3e064f7657f43 (patch)
treea1298d4e9d14f5ff13243722d8050ce4887df53d
parentcba83fe17a41f3bc21186730bbf1eb15a573af25 (diff)
downloadports-d0eab093ac5a5f877a0093a6f7b3e064f7657f43.tar.gz
ports-d0eab093ac5a5f877a0093a6f7b3e064f7657f43.zip
- Update to 0.8.1
PR: ports/116406 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=199873
-rw-r--r--graphics/gnash-devel/Makefile162
-rw-r--r--graphics/gnash-devel/distinfo6
-rw-r--r--graphics/gnash-devel/files/patch-configure11
-rw-r--r--graphics/gnash-devel/pkg-descr10
-rw-r--r--graphics/gnash-devel/pkg-plist30
-rw-r--r--graphics/gnash/Makefile162
-rw-r--r--graphics/gnash/distinfo6
-rw-r--r--graphics/gnash/files/patch-configure11
-rw-r--r--graphics/gnash/pkg-descr10
-rw-r--r--graphics/gnash/pkg-plist30
10 files changed, 306 insertions, 132 deletions
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index 8e12e4c4930d..f71fc2ccbed7 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTVERSION= 0.8.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -20,68 +19,151 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
curl.4:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
-USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+WANT_SDL= yes
+WANT_GNOME= yes
+WANT_GSTREAMER= yes
USE_GNOME= pkgconfig libxml2
USE_XLIB= yes
+USE_AUTOTOOLS= libltdl:15
PLUGIN_DIR= ${PREFIX}/lib/browser_plugins
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash" \
- CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
+ --with-boost-lib="${LOCALBASE}/lib" \
+ --with-plugindir="${PLUGIN_DIR}"
-CONFIGURE_ARGS= --libdir="${PREFIX}/lib/gnash" \
- --with-plugindir=${PLUGIN_DIR} \
- --enable-jpeg --disable-klash
+USE_LDCONFIG= ${PREFIX}/lib/gnash
MAN1= gnash.1
-OPTIONS= PLUGIN "Enable browser plugin" on \
- GTK "Enable GTK GUI (required for plugin)" on \
- SOUND "Enable sound" on \
- GSTREAMER "Use GStreamer sound output instead of SDL" off \
- MAD "Support mp3 decoding through libmad" on
+# WITH_KDE option is untested - please uncomment related .if's below
+# build gnash -DWITH_KDE -DWITH_PLUGIN. Check whether the plugin works
+# and then contact the maintainer: plist and depends should be corrected
+OPTIONS= PLUGIN "Enable browser plugin" on \
+ CYGNAL "Enable Cygnal media server" off \
+ GTK "GUI: GTK (required for FF plugin)" on \
+ AGG "Renderer: AGG" off \
+ OPENGL "Renderer: OpenGL" on \
+ CAIRO "Renderer: Cairo (experimental)" off \
+ FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
+ GSTREAMER "Media handler: GStreamer" off \
+ MAD "Media handler: MAD (+SDL sound output)" off \
+ DEBUGLOG "Leave logfile in current directory on every run" off
+
+# KDE "GUI: KDE (required for Konqueror plugin)" off \
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_GTK)
-USE_SDL+= sdl
-CONFIGURE_ARGS+= --enable-gui=SDL
+# Plugin option processing
+.if defined(WITH_GTK) && !defined(WITHOUT_PLUGIN)
+PLIST_SUB+= FFPLUGIN=""
.else
-CONFIGURE_ARGS+= --enable-gui=GTK
-USE_GNOME+= atk pango gtk20
-LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+PLIST_SUB+= FFPLUGIN="@comment "
+CONFIGURE_ARGS+= --disable-nsapi
.endif
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+= --enable-sound=NO
+#.if defined(WITH_KDE) && !defined(WITHOUT_PLUGIN)
+#PLIST_SUB+= KONQPLUGIN=""
+#.else
+#PLIST_SUB+= KONQPLUGIN="@comment "
+CONFIGURE_ARGS+= --disable-kparts
+#.endif
+
+# Cygnal option processing
+.if defined(WITH_CYGNAL)
+PLIST_SUB+= CYGNAL=""
+CONFIGURE_ARGS+= --enable-cygnal
.else
-. if defined(WITH_GSTREAMER)
-USE_GSTREAMER= yes
-CONFIGURE_ARGS+= --enable-sound=GST
-. else
-USE_SDL+= sdl
-CONFIGURE_ARGS+= --enable-sound=SDL
-. if defined(WITHOUT_MAD)
-CONFIGURE_ARGS+= --without-mp3-decoder
-. else
-CONFIGURE_ARGS+= --with-mp3-decoder=mad
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
-. endif
-. endif
+PLIST_SUB+= CYGNAL="@comment "
+CONFIGURE_ARGS+= --disable-cygnal
+.endif
+
+# NLS option processing (not sure if --disable-nls actually has any effect)
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_PLUGIN) || defined(WITHOUT_GTK)
-PLIST_SUB+= PLUGIN="@comment "
-CONFIGURE_ARGS+= --disable-plugin
+#
+# GUI options processing
+#
+GNASH_GUIS=
+
+.if defined(WITH_GTK)
+USE_GNOME= gtk20
+GNASH_GUIS+= gtk
+PLIST_SUB+= GTK=""
.else
-PLIST_SUB+= PLUGIN=""
+PLIST_SUB+= GTK="@comment "
+.endif
+
+#.if defined(WITH_KDE)
+#GNASH_GUIS+= kde
+#PLIST_SUB+= KDE=""
+#.else
+PLIST_SUB+= KDE="@comment "
+#.endif
+
+CONFIGURE_ARGS+= --enable-gui=`${ECHO} ${GNASH_GUIS} | ${TR} ' ' ,`
+
+#
+# Renderer options processing
+#
+.if defined(WITH_AGG) && !defined(WITH_OPENGL) && !defined(WITH_CAIRO)
+LIB_DEPENDS+= agg.2:${PORTSDIR}/graphics/agg
+CONFIGURE_ARGS+= --enable-renderer=agg
+.elif !defined(WITH_AGG) && defined(WITH_OPENGL) && !defined(WITH_CAIRO)
+USE_GL= yes
+. if defined(WITH_GTK)
+LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+. endif
+CONFIGURE_ARGS+= --enable-renderer=ogl
+.elif !defined(WITH_AGG) && !defined(WITH_OPENGL) && defined(WITH_CAIRO)
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+CONFIGURE_ARGS+= --enable-renderer=cairo
+.else
+IGNORE= can't be built with multiple or without renderers enabled. Please rerun 'make config' and select exactly one renderer (agg|opengl|cairo)
+.endif
+
+#
+# Media handler options processing
+#
+.if defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER) && !defined(WITH_MAD)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --enable-media=ffmpeg
+USE_SDL+= sdl
+.elif !defined(WITH_FFMPEG) && defined(WITH_GSTREAMER) && !defined(WITH_MAD)
+USE_GSTREAMER= yes
+CONFIGURE_ARGS+= --enable-media=gst
+.elif !defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER) && defined(WITH_MAD)
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+CONFIGURE_ARGS+= --enable-media=mad
+USE_SDL+= sdl
+.elif !defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER) && !defined(WITH_MAD)
+CONFIGURE_ARGS+= --enable-media=none
+.else
+IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer|mad)
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g;s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^PTHREAD_[A-Z]*=/ d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/test/ s|==|=|; s|== x|= x|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure \
+ ${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
+.if !defined(WITH_DEBUGLOG)
+ @${REINPLACE_CMD} -e 's|gnash-dbg.log|/dev/null|' \
+ ${WRKSRC}/libbase/rc.cpp ${WRKSRC}/libbase/log.h
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
index ae85c44a00bb..30808a65f90b 100644
--- a/graphics/gnash-devel/distinfo
+++ b/graphics/gnash-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.7.2.tar.bz2) = ccef0f45be01a4c2992b46c2363a514f
-SHA256 (gnash-0.7.2.tar.bz2) = 12dccb4bc69488f516e0283e988412ba7db5dfad32744425f97d641392a2e98b
-SIZE (gnash-0.7.2.tar.bz2) = 1599810
+MD5 (gnash-0.8.1.tar.bz2) = 5f80a25cb7a37fb351d28fd2097d8f3e
+SHA256 (gnash-0.8.1.tar.bz2) = 30fb283e707bc209109ca313c83b069b1c482497b62f8c4cc37e9a23e0ba8993
+SIZE (gnash-0.8.1.tar.bz2) = 1983596
diff --git a/graphics/gnash-devel/files/patch-configure b/graphics/gnash-devel/files/patch-configure
deleted file mode 100644
index 3cb3452756e7..000000000000
--- a/graphics/gnash-devel/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Fri Nov 17 22:09:10 2006
-+++ configure Wed Jan 31 21:07:06 2007
-@@ -26598,7 +26598,7 @@
- if test x"${with_atk_lib}" != x ; then
- libname=atkatk-x11-${gnash_atk_version}
- if test -f ${with_atk_lib}/lib${libname}.a -o -f ${with_atk_lib}/lib${libname}.so; then
-- ac_cv_path_atk_lib="`-L(cd ${with_atk_lib}; pwd)` -l${libname}"
-+ ac_cv_path_atk_lib="-L`(cd ${with_atk_lib}; pwd)` -l${libname}"
- else
- { { echo "$as_me:$LINENO: error: ${with_atk_lib} directory doesn't contain libatkatk." >&5
- echo "$as_me: error: ${with_atk_lib} directory doesn't contain libatkatk." >&2;}
diff --git a/graphics/gnash-devel/pkg-descr b/graphics/gnash-devel/pkg-descr
index e50c17388ccf..8e9c07ebcc3c 100644
--- a/graphics/gnash-devel/pkg-descr
+++ b/graphics/gnash-devel/pkg-descr
@@ -3,14 +3,16 @@ to play flash movies with proprietary software. While there are
some other free flash players, none support anything beyond SWF v4.
Gnash is based on GameSWF, and supports many SWF v7 features.
-Features:
- Runs standalone
Gnash can run standalone to play flash movies.
- Browser plugin
Gnash can also run as a plugin from within most Mozilla derived
browsers, such as Firefox. Gnash also has support for Konqueror.
-- SWF v7 compliant
+- SWF v7+ compliant
Gnash can play many current flash movies.
+- Streaming Video
+ Gnash supports the viewing of streaming video from popular video
+ sharing sites like Lulu.tv or YouTube.com.
- XML Message server
Gnash also supports an XML based message system as documented in
the Flash Format specification.
@@ -23,5 +25,9 @@ Features:
- Better Security
Gnash pays extra attention to all network connections, and allows
the user to control access.
+- Extensible
+ Gnash supports extending ActionScript by creating your own. You
+ can write wrappers for any development library, and import them
+ into the player.
WWW: http://www.gnu.org/software/gnash/
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
index 82208260dc94..e24747551d4d 100644
--- a/graphics/gnash-devel/pkg-plist
+++ b/graphics/gnash-devel/pkg-plist
@@ -1,26 +1,36 @@
bin/gnash
bin/gparser
bin/gprocessor
-%%PLUGIN%%lib/browser_plugins/libgnashplugin.so
-lib/gnash/libgnashamf-0.7.2.so
+%%GTK%%bin/gtk-gnash
+%%CYGNAL%%bin/cygnal
+%%FFPLUGIN%%lib/browser_plugins/libgnashplugin.so
+lib/gnash/libgnashamf-0.8.1.so
+lib/gnash/libgnashamf.a
lib/gnash/libgnashamf.la
lib/gnash/libgnashamf.so
-lib/gnash/libgnashbackend-0.7.2.so
+lib/gnash/libgnashbackend-0.8.1.so
+lib/gnash/libgnashbackend.a
lib/gnash/libgnashbackend.la
lib/gnash/libgnashbackend.so
-lib/gnash/libgnashbase-0.7.2.so
+lib/gnash/libgnashbase-0.8.1.so
+lib/gnash/libgnashbase.a
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashgeo-0.7.2.so
+lib/gnash/libgnashgeo-0.8.1.so
+lib/gnash/libgnashgeo.a
lib/gnash/libgnashgeo.la
lib/gnash/libgnashgeo.so
-lib/gnash/libgnashgui-0.7.2.so
-lib/gnash/libgnashgui.la
-lib/gnash/libgnashgui.so
-lib/gnash/libgnashserver-0.7.2.so
+lib/gnash/libgnashserver-0.8.1.so
+lib/gnash/libgnashserver.a
lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
+%%DATADIR%%/GnashG.png
%%DATADIR%%/gnash_128_96.ico
+share/locale/cs/gnash.mo
+share/locale/de/gnash.mo
+share/locale/es/gnash.mo
+share/locale/fr/gnash.mo
+share/locale/it/gnash.mo
@dirrm %%DATADIR%%
@dirrm lib/gnash
-%%PLUGIN%%@dirrm lib/browser_plugins
+@dirrmtry lib/browser_plugins
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 8e12e4c4930d..f71fc2ccbed7 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnash
-PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTVERSION= 0.8.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
@@ -20,68 +19,151 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
curl.4:${PORTSDIR}/ftp/curl
USE_BZIP2= yes
-USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
+WANT_SDL= yes
+WANT_GNOME= yes
+WANT_GSTREAMER= yes
USE_GNOME= pkgconfig libxml2
USE_XLIB= yes
+USE_AUTOTOOLS= libltdl:15
PLUGIN_DIR= ${PREFIX}/lib/browser_plugins
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -Wl,--rpath,${PREFIX}/lib/gnash" \
- CFLAGS="-I${LOCALBASE}/include ${CFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
+ --with-boost-lib="${LOCALBASE}/lib" \
+ --with-plugindir="${PLUGIN_DIR}"
-CONFIGURE_ARGS= --libdir="${PREFIX}/lib/gnash" \
- --with-plugindir=${PLUGIN_DIR} \
- --enable-jpeg --disable-klash
+USE_LDCONFIG= ${PREFIX}/lib/gnash
MAN1= gnash.1
-OPTIONS= PLUGIN "Enable browser plugin" on \
- GTK "Enable GTK GUI (required for plugin)" on \
- SOUND "Enable sound" on \
- GSTREAMER "Use GStreamer sound output instead of SDL" off \
- MAD "Support mp3 decoding through libmad" on
+# WITH_KDE option is untested - please uncomment related .if's below
+# build gnash -DWITH_KDE -DWITH_PLUGIN. Check whether the plugin works
+# and then contact the maintainer: plist and depends should be corrected
+OPTIONS= PLUGIN "Enable browser plugin" on \
+ CYGNAL "Enable Cygnal media server" off \
+ GTK "GUI: GTK (required for FF plugin)" on \
+ AGG "Renderer: AGG" off \
+ OPENGL "Renderer: OpenGL" on \
+ CAIRO "Renderer: Cairo (experimental)" off \
+ FFMPEG "Media handler: ffmpeg (+SDL sound output)" on \
+ GSTREAMER "Media handler: GStreamer" off \
+ MAD "Media handler: MAD (+SDL sound output)" off \
+ DEBUGLOG "Leave logfile in current directory on every run" off
+
+# KDE "GUI: KDE (required for Konqueror plugin)" off \
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_GTK)
-USE_SDL+= sdl
-CONFIGURE_ARGS+= --enable-gui=SDL
+# Plugin option processing
+.if defined(WITH_GTK) && !defined(WITHOUT_PLUGIN)
+PLIST_SUB+= FFPLUGIN=""
.else
-CONFIGURE_ARGS+= --enable-gui=GTK
-USE_GNOME+= atk pango gtk20
-LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+PLIST_SUB+= FFPLUGIN="@comment "
+CONFIGURE_ARGS+= --disable-nsapi
.endif
-.if defined(WITHOUT_SOUND)
-CONFIGURE_ARGS+= --enable-sound=NO
+#.if defined(WITH_KDE) && !defined(WITHOUT_PLUGIN)
+#PLIST_SUB+= KONQPLUGIN=""
+#.else
+#PLIST_SUB+= KONQPLUGIN="@comment "
+CONFIGURE_ARGS+= --disable-kparts
+#.endif
+
+# Cygnal option processing
+.if defined(WITH_CYGNAL)
+PLIST_SUB+= CYGNAL=""
+CONFIGURE_ARGS+= --enable-cygnal
.else
-. if defined(WITH_GSTREAMER)
-USE_GSTREAMER= yes
-CONFIGURE_ARGS+= --enable-sound=GST
-. else
-USE_SDL+= sdl
-CONFIGURE_ARGS+= --enable-sound=SDL
-. if defined(WITHOUT_MAD)
-CONFIGURE_ARGS+= --without-mp3-decoder
-. else
-CONFIGURE_ARGS+= --with-mp3-decoder=mad
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
-. endif
-. endif
+PLIST_SUB+= CYGNAL="@comment "
+CONFIGURE_ARGS+= --disable-cygnal
+.endif
+
+# NLS option processing (not sure if --disable-nls actually has any effect)
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_PLUGIN) || defined(WITHOUT_GTK)
-PLIST_SUB+= PLUGIN="@comment "
-CONFIGURE_ARGS+= --disable-plugin
+#
+# GUI options processing
+#
+GNASH_GUIS=
+
+.if defined(WITH_GTK)
+USE_GNOME= gtk20
+GNASH_GUIS+= gtk
+PLIST_SUB+= GTK=""
.else
-PLIST_SUB+= PLUGIN=""
+PLIST_SUB+= GTK="@comment "
+.endif
+
+#.if defined(WITH_KDE)
+#GNASH_GUIS+= kde
+#PLIST_SUB+= KDE=""
+#.else
+PLIST_SUB+= KDE="@comment "
+#.endif
+
+CONFIGURE_ARGS+= --enable-gui=`${ECHO} ${GNASH_GUIS} | ${TR} ' ' ,`
+
+#
+# Renderer options processing
+#
+.if defined(WITH_AGG) && !defined(WITH_OPENGL) && !defined(WITH_CAIRO)
+LIB_DEPENDS+= agg.2:${PORTSDIR}/graphics/agg
+CONFIGURE_ARGS+= --enable-renderer=agg
+.elif !defined(WITH_AGG) && defined(WITH_OPENGL) && !defined(WITH_CAIRO)
+USE_GL= yes
+. if defined(WITH_GTK)
+LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+. endif
+CONFIGURE_ARGS+= --enable-renderer=ogl
+.elif !defined(WITH_AGG) && !defined(WITH_OPENGL) && defined(WITH_CAIRO)
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+CONFIGURE_ARGS+= --enable-renderer=cairo
+.else
+IGNORE= can't be built with multiple or without renderers enabled. Please rerun 'make config' and select exactly one renderer (agg|opengl|cairo)
+.endif
+
+#
+# Media handler options processing
+#
+.if defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER) && !defined(WITH_MAD)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+CONFIGURE_ARGS+= --enable-media=ffmpeg
+USE_SDL+= sdl
+.elif !defined(WITH_FFMPEG) && defined(WITH_GSTREAMER) && !defined(WITH_MAD)
+USE_GSTREAMER= yes
+CONFIGURE_ARGS+= --enable-media=gst
+.elif !defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER) && defined(WITH_MAD)
+LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+CONFIGURE_ARGS+= --enable-media=mad
+USE_SDL+= sdl
+.elif !defined(WITH_FFMPEG) && !defined(WITH_GSTREAMER) && !defined(WITH_MAD)
+CONFIGURE_ARGS+= --enable-media=none
+.else
+IGNORE= can't be built with multiple media handlers enabled. Please rerun 'make config' and leave one or none of them (ffmpeg|gstreamer|mad)
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g;s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/^PTHREAD_[A-Z]*=/ d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/test/ s|==|=|; s|== x|= x|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
+ s|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure \
+ ${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
+.if !defined(WITH_DEBUGLOG)
+ @${REINPLACE_CMD} -e 's|gnash-dbg.log|/dev/null|' \
+ ${WRKSRC}/libbase/rc.cpp ${WRKSRC}/libbase/log.h
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/gnash/distinfo b/graphics/gnash/distinfo
index ae85c44a00bb..30808a65f90b 100644
--- a/graphics/gnash/distinfo
+++ b/graphics/gnash/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.7.2.tar.bz2) = ccef0f45be01a4c2992b46c2363a514f
-SHA256 (gnash-0.7.2.tar.bz2) = 12dccb4bc69488f516e0283e988412ba7db5dfad32744425f97d641392a2e98b
-SIZE (gnash-0.7.2.tar.bz2) = 1599810
+MD5 (gnash-0.8.1.tar.bz2) = 5f80a25cb7a37fb351d28fd2097d8f3e
+SHA256 (gnash-0.8.1.tar.bz2) = 30fb283e707bc209109ca313c83b069b1c482497b62f8c4cc37e9a23e0ba8993
+SIZE (gnash-0.8.1.tar.bz2) = 1983596
diff --git a/graphics/gnash/files/patch-configure b/graphics/gnash/files/patch-configure
deleted file mode 100644
index 3cb3452756e7..000000000000
--- a/graphics/gnash/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Fri Nov 17 22:09:10 2006
-+++ configure Wed Jan 31 21:07:06 2007
-@@ -26598,7 +26598,7 @@
- if test x"${with_atk_lib}" != x ; then
- libname=atkatk-x11-${gnash_atk_version}
- if test -f ${with_atk_lib}/lib${libname}.a -o -f ${with_atk_lib}/lib${libname}.so; then
-- ac_cv_path_atk_lib="`-L(cd ${with_atk_lib}; pwd)` -l${libname}"
-+ ac_cv_path_atk_lib="-L`(cd ${with_atk_lib}; pwd)` -l${libname}"
- else
- { { echo "$as_me:$LINENO: error: ${with_atk_lib} directory doesn't contain libatkatk." >&5
- echo "$as_me: error: ${with_atk_lib} directory doesn't contain libatkatk." >&2;}
diff --git a/graphics/gnash/pkg-descr b/graphics/gnash/pkg-descr
index e50c17388ccf..8e9c07ebcc3c 100644
--- a/graphics/gnash/pkg-descr
+++ b/graphics/gnash/pkg-descr
@@ -3,14 +3,16 @@ to play flash movies with proprietary software. While there are
some other free flash players, none support anything beyond SWF v4.
Gnash is based on GameSWF, and supports many SWF v7 features.
-Features:
- Runs standalone
Gnash can run standalone to play flash movies.
- Browser plugin
Gnash can also run as a plugin from within most Mozilla derived
browsers, such as Firefox. Gnash also has support for Konqueror.
-- SWF v7 compliant
+- SWF v7+ compliant
Gnash can play many current flash movies.
+- Streaming Video
+ Gnash supports the viewing of streaming video from popular video
+ sharing sites like Lulu.tv or YouTube.com.
- XML Message server
Gnash also supports an XML based message system as documented in
the Flash Format specification.
@@ -23,5 +25,9 @@ Features:
- Better Security
Gnash pays extra attention to all network connections, and allows
the user to control access.
+- Extensible
+ Gnash supports extending ActionScript by creating your own. You
+ can write wrappers for any development library, and import them
+ into the player.
WWW: http://www.gnu.org/software/gnash/
diff --git a/graphics/gnash/pkg-plist b/graphics/gnash/pkg-plist
index 82208260dc94..e24747551d4d 100644
--- a/graphics/gnash/pkg-plist
+++ b/graphics/gnash/pkg-plist
@@ -1,26 +1,36 @@
bin/gnash
bin/gparser
bin/gprocessor
-%%PLUGIN%%lib/browser_plugins/libgnashplugin.so
-lib/gnash/libgnashamf-0.7.2.so
+%%GTK%%bin/gtk-gnash
+%%CYGNAL%%bin/cygnal
+%%FFPLUGIN%%lib/browser_plugins/libgnashplugin.so
+lib/gnash/libgnashamf-0.8.1.so
+lib/gnash/libgnashamf.a
lib/gnash/libgnashamf.la
lib/gnash/libgnashamf.so
-lib/gnash/libgnashbackend-0.7.2.so
+lib/gnash/libgnashbackend-0.8.1.so
+lib/gnash/libgnashbackend.a
lib/gnash/libgnashbackend.la
lib/gnash/libgnashbackend.so
-lib/gnash/libgnashbase-0.7.2.so
+lib/gnash/libgnashbase-0.8.1.so
+lib/gnash/libgnashbase.a
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashgeo-0.7.2.so
+lib/gnash/libgnashgeo-0.8.1.so
+lib/gnash/libgnashgeo.a
lib/gnash/libgnashgeo.la
lib/gnash/libgnashgeo.so
-lib/gnash/libgnashgui-0.7.2.so
-lib/gnash/libgnashgui.la
-lib/gnash/libgnashgui.so
-lib/gnash/libgnashserver-0.7.2.so
+lib/gnash/libgnashserver-0.8.1.so
+lib/gnash/libgnashserver.a
lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
+%%DATADIR%%/GnashG.png
%%DATADIR%%/gnash_128_96.ico
+share/locale/cs/gnash.mo
+share/locale/de/gnash.mo
+share/locale/es/gnash.mo
+share/locale/fr/gnash.mo
+share/locale/it/gnash.mo
@dirrm %%DATADIR%%
@dirrm lib/gnash
-%%PLUGIN%%@dirrm lib/browser_plugins
+@dirrmtry lib/browser_plugins