aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2022-07-04 02:28:02 +0000
committerCharlie Li <vishwin@FreeBSD.org>2022-07-05 00:44:09 +0000
commitd128a409234dfde7ee5edce6dc59f123bb89c892 (patch)
treed02bdc6d373de7107a7d679e1ca649ec12c0ffb8
parent1e3180f69d4eff32249f093baf82080448d22f75 (diff)
downloadports-d128a409234dfde7ee5edce6dc59f123bb89c892.tar.gz
ports-d128a409234dfde7ee5edce6dc59f123bb89c892.zip
editors/xed: update to 3.2.4
-rw-r--r--editors/xed/Makefile43
-rw-r--r--editors/xed/distinfo6
-rw-r--r--editors/xed/pkg-descr12
-rw-r--r--editors/xed/pkg-plist171
4 files changed, 84 insertions, 148 deletions
diff --git a/editors/xed/Makefile b/editors/xed/Makefile
index 26372330cebf..1bf26ebb48a0 100644
--- a/editors/xed/Makefile
+++ b/editors/xed/Makefile
@@ -1,31 +1,27 @@
-# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
-
PORTNAME= xed
-PORTVERSION= 3.2.2
-PORTREVISION= 2
+PORTVERSION= 3.2.4
CATEGORIES= editors gnome
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Small but powerful graphical text editor
+COMMENT= Small but powerful text editor for GTK
LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-PORTSCOUT= limit:^[0-9.]+$$ # ignore non-numeric tags
-
-BUILD_DEPENDS= intltool-merge:textproc/intltool \
- itstool:textproc/itstool
-LIB_DEPENDS= libpeas-1.0.so:devel/libpeas \
+BUILD_DEPENDS= itstool:textproc/itstool
+LIB_DEPENDS= libenchant-2.so:textproc/enchant2 \
+ libpeas-1.0.so:devel/libpeas \
libxapp.so:x11/xapp
RUN_DEPENDS= ${LOCALBASE}/share/glib-2.0/schemas/org.gnome.desktop.interface.gschema.xml:devel/gsettings-desktop-schemas \
${PYTHON_PKGNAMEPREFIX}libpeas>=0:devel/py-libpeas@${PY_FLAVOR} \
yelp:x11/yelp
-USES= compiler:c++11-lang desktop-file-utils gettext-tools gnome \
- meson pkgconfig python:3.6+,run xorg
+USES= compiler:c++11-lang desktop-file-utils gettext-tools gnome meson \
+ pkgconfig python:run xorg
USE_GITHUB= yes
GH_ACCOUNT= linuxmint
-USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview4 \
+USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 gtksourceview4 intltool \
introspection pango
USE_LDCONFIG= yes
USE_XORG= x11
@@ -34,18 +30,21 @@ GLIB_SCHEMAS= org.x.editor.gschema.xml \
org.x.editor.plugins.time.gschema.xml \
org.x.editor.plugins.wordcompletion.gschema.xml
-OPTIONS_DEFINE= DOCS GSPELL
-OPTIONS_DEFAULT= GSPELL
-GSPELL_DESC= Spell checking support via gspell
+PORTSCOUT= limit:^[0-9.]+$$ # ignore master.mint* tags
-DOCS_BUILD_DEPENDS= gtkdoc-scan:textproc/gtk-doc
-DOCS_MESON_ON= -Ddocs=true
+OPTIONS_DEFINE= DOCS GSPELL GVFS_METADATA
+OPTIONS_DEFAULT= DOCS GSPELL GVFS_METADATA
+OPTIONS_SUB= yes
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= docs
+
+GSPELL_DESC= Spell checking support via gspell
GSPELL_LIB_DEPENDS= libgspell-1.so:textproc/gspell
-GSPELL_MESON_OFF= -Denable_spell=false
-GSPELL_PLIST_FILES= lib/xed/plugins/libspell.so \
- lib/xed/plugins/spell.plugin \
- ${DATADIR_REL}/plugins/spell/xed-spell-setup-dialog.ui
+GSPELL_MESON_TRUE= enable_spell
GSPELL_VARS= GLIB_SCHEMAS+=org.x.editor.plugins.spell.gschema.xml
+GVFS_METADATA_DESC= GVFS metadata
+GVFS_METADATA_MESON_TRUE= enable_gvfs_metadata
+
.include <bsd.port.mk>
diff --git a/editors/xed/distinfo b/editors/xed/distinfo
index 6fb283bce988..89c573314a76 100644
--- a/editors/xed/distinfo
+++ b/editors/xed/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640956017
-SHA256 (gnome/linuxmint-xed-3.2.2_GH0.tar.gz) = 7f0a1a8abc85da66980354aa033c1215eb7bf4e23e71d14b6ae9a28956352632
-SIZE (gnome/linuxmint-xed-3.2.2_GH0.tar.gz) = 4542839
+TIMESTAMP = 1656710190
+SHA256 (gnome/linuxmint-xed-3.2.4_GH0.tar.gz) = 159e4e1a2def959b13b9ea5ce873a0fb4e24a3cbed24ab6afe5da291037b6595
+SIZE (gnome/linuxmint-xed-3.2.4_GH0.tar.gz) = 4558916
diff --git a/editors/xed/pkg-descr b/editors/xed/pkg-descr
index b3babad5a7b9..7b0bc3efa53d 100644
--- a/editors/xed/pkg-descr
+++ b/editors/xed/pkg-descr
@@ -1,6 +1,12 @@
-xed is a small and lightweight text editor, which supports most standard
-editing features, plus several not typically found in one's average text
-editor (plugins being the most notable of these).
+xed is a GTK-based text editor. Its features include:
+
+ * Complete integration with any GTK environment
+ * Global Search and Replace
+ * Dynamically loaded fonts
+ * Splitscreen Mode
+ * Printing support
+ * Configurable Plugins system
+ * Unlimited Undo/Redo
Although new features are always under development, currently xed has:
diff --git a/editors/xed/pkg-plist b/editors/xed/pkg-plist
index ff8a0f79ac7b..8816632e2508 100644
--- a/editors/xed/pkg-plist
+++ b/editors/xed/pkg-plist
@@ -31,6 +31,7 @@ lib/xed/plugins/libdocinfo.so
lib/xed/plugins/libfilebrowser.so
lib/xed/plugins/libmodelines.so
lib/xed/plugins/libsort.so
+%%GSPELL%%lib/xed/plugins/libspell.so
lib/xed/plugins/libtaglist.so
lib/xed/plugins/libtime.so
lib/xed/plugins/libtrailsave.so
@@ -40,6 +41,7 @@ lib/xed/plugins/open-uri-context-menu/COPYING
lib/xed/plugins/open-uri-context-menu/open-uri-context-menu.plugin
lib/xed/plugins/open-uri-context-menu/open-uri-context-menu.py
lib/xed/plugins/sort.plugin
+%%GSPELL%%lib/xed/plugins/spell.plugin
lib/xed/plugins/taglist.plugin
lib/xed/plugins/textsize.plugin
lib/xed/plugins/textsize/__init__.py
@@ -87,195 +89,123 @@ share/dbus-1/services/org.x.editor.service
%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-message-type.html
%%PORTDOCS%%share/gtk-doc/html/xed/xed-xed-utils.html
%%PORTDOCS%%share/gtk-doc/html/xed/xed.devhelp2
-share/help/C/xed/figures/xed_format_bold.png
-share/help/C/xed/figures/xed_format_italic.png
-share/help/C/xed/figures/xed_format_strikethrough.png
-share/help/C/xed/figures/xed_format_underline.png
-share/help/C/xed/figures/xed_recent_files_menu_icon.png
+share/help/C/xed/figures/xed_print_button.png
+share/help/C/xed/figures/xed_search_pane_buttons.png
share/help/C/xed/figures/xed_window.png
share/help/C/xed/index.docbook
share/help/C/xed/legal.xml
-share/help/ar/xed/figures/xed_format_bold.png
-share/help/ar/xed/figures/xed_format_italic.png
-share/help/ar/xed/figures/xed_format_strikethrough.png
-share/help/ar/xed/figures/xed_format_underline.png
-share/help/ar/xed/figures/xed_recent_files_menu_icon.png
+share/help/ar/xed/figures/xed_print_button.png
+share/help/ar/xed/figures/xed_search_pane_buttons.png
share/help/ar/xed/figures/xed_window.png
share/help/ar/xed/index.docbook
share/help/ar/xed/legal.xml
-share/help/bg/xed/figures/xed_format_bold.png
-share/help/bg/xed/figures/xed_format_italic.png
-share/help/bg/xed/figures/xed_format_strikethrough.png
-share/help/bg/xed/figures/xed_format_underline.png
-share/help/bg/xed/figures/xed_recent_files_menu_icon.png
+share/help/bg/xed/figures/xed_print_button.png
+share/help/bg/xed/figures/xed_search_pane_buttons.png
share/help/bg/xed/figures/xed_window.png
share/help/bg/xed/index.docbook
share/help/bg/xed/legal.xml
-share/help/ca/xed/figures/xed_format_bold.png
-share/help/ca/xed/figures/xed_format_italic.png
-share/help/ca/xed/figures/xed_format_strikethrough.png
-share/help/ca/xed/figures/xed_format_underline.png
-share/help/ca/xed/figures/xed_recent_files_menu_icon.png
+share/help/ca/xed/figures/xed_print_button.png
+share/help/ca/xed/figures/xed_search_pane_buttons.png
share/help/ca/xed/figures/xed_window.png
share/help/ca/xed/index.docbook
share/help/ca/xed/legal.xml
-share/help/cs/xed/figures/xed_format_bold.png
-share/help/cs/xed/figures/xed_format_italic.png
-share/help/cs/xed/figures/xed_format_strikethrough.png
-share/help/cs/xed/figures/xed_format_underline.png
-share/help/cs/xed/figures/xed_recent_files_menu_icon.png
+share/help/cs/xed/figures/xed_print_button.png
+share/help/cs/xed/figures/xed_search_pane_buttons.png
share/help/cs/xed/figures/xed_window.png
share/help/cs/xed/index.docbook
share/help/cs/xed/legal.xml
-share/help/da/xed/figures/xed_format_bold.png
-share/help/da/xed/figures/xed_format_italic.png
-share/help/da/xed/figures/xed_format_strikethrough.png
-share/help/da/xed/figures/xed_format_underline.png
-share/help/da/xed/figures/xed_recent_files_menu_icon.png
+share/help/da/xed/figures/xed_print_button.png
+share/help/da/xed/figures/xed_search_pane_buttons.png
share/help/da/xed/figures/xed_window.png
share/help/da/xed/index.docbook
share/help/da/xed/legal.xml
-share/help/de/xed/figures/xed_format_bold.png
-share/help/de/xed/figures/xed_format_italic.png
-share/help/de/xed/figures/xed_format_strikethrough.png
-share/help/de/xed/figures/xed_format_underline.png
-share/help/de/xed/figures/xed_recent_files_menu_icon.png
+share/help/de/xed/figures/xed_print_button.png
+share/help/de/xed/figures/xed_search_pane_buttons.png
share/help/de/xed/figures/xed_window.png
share/help/de/xed/index.docbook
share/help/de/xed/legal.xml
-share/help/el/xed/figures/xed_format_bold.png
-share/help/el/xed/figures/xed_format_italic.png
-share/help/el/xed/figures/xed_format_strikethrough.png
-share/help/el/xed/figures/xed_format_underline.png
-share/help/el/xed/figures/xed_recent_files_menu_icon.png
+share/help/el/xed/figures/xed_print_button.png
+share/help/el/xed/figures/xed_search_pane_buttons.png
share/help/el/xed/figures/xed_window.png
share/help/el/xed/index.docbook
share/help/el/xed/legal.xml
-share/help/es/xed/figures/xed_format_bold.png
-share/help/es/xed/figures/xed_format_italic.png
-share/help/es/xed/figures/xed_format_strikethrough.png
-share/help/es/xed/figures/xed_format_underline.png
-share/help/es/xed/figures/xed_recent_files_menu_icon.png
+share/help/es/xed/figures/xed_print_button.png
+share/help/es/xed/figures/xed_search_pane_buttons.png
share/help/es/xed/figures/xed_window.png
share/help/es/xed/index.docbook
share/help/es/xed/legal.xml
-share/help/fi/xed/figures/xed_format_bold.png
-share/help/fi/xed/figures/xed_format_italic.png
-share/help/fi/xed/figures/xed_format_strikethrough.png
-share/help/fi/xed/figures/xed_format_underline.png
-share/help/fi/xed/figures/xed_recent_files_menu_icon.png
+share/help/fi/xed/figures/xed_print_button.png
+share/help/fi/xed/figures/xed_search_pane_buttons.png
share/help/fi/xed/figures/xed_window.png
share/help/fi/xed/index.docbook
share/help/fi/xed/legal.xml
-share/help/fr/xed/figures/xed_format_bold.png
-share/help/fr/xed/figures/xed_format_italic.png
-share/help/fr/xed/figures/xed_format_strikethrough.png
-share/help/fr/xed/figures/xed_format_underline.png
-share/help/fr/xed/figures/xed_recent_files_menu_icon.png
+share/help/fr/xed/figures/xed_print_button.png
+share/help/fr/xed/figures/xed_search_pane_buttons.png
share/help/fr/xed/figures/xed_window.png
share/help/fr/xed/index.docbook
share/help/fr/xed/legal.xml
-share/help/hu/xed/figures/xed_format_bold.png
-share/help/hu/xed/figures/xed_format_italic.png
-share/help/hu/xed/figures/xed_format_strikethrough.png
-share/help/hu/xed/figures/xed_format_underline.png
-share/help/hu/xed/figures/xed_recent_files_menu_icon.png
+share/help/hu/xed/figures/xed_print_button.png
+share/help/hu/xed/figures/xed_search_pane_buttons.png
share/help/hu/xed/figures/xed_window.png
share/help/hu/xed/index.docbook
share/help/hu/xed/legal.xml
-share/help/it/xed/figures/xed_format_bold.png
-share/help/it/xed/figures/xed_format_italic.png
-share/help/it/xed/figures/xed_format_strikethrough.png
-share/help/it/xed/figures/xed_format_underline.png
-share/help/it/xed/figures/xed_recent_files_menu_icon.png
+share/help/it/xed/figures/xed_print_button.png
+share/help/it/xed/figures/xed_search_pane_buttons.png
share/help/it/xed/figures/xed_window.png
share/help/it/xed/index.docbook
share/help/it/xed/legal.xml
-share/help/ja/xed/figures/xed_format_bold.png
-share/help/ja/xed/figures/xed_format_italic.png
-share/help/ja/xed/figures/xed_format_strikethrough.png
-share/help/ja/xed/figures/xed_format_underline.png
-share/help/ja/xed/figures/xed_recent_files_menu_icon.png
+share/help/ja/xed/figures/xed_print_button.png
+share/help/ja/xed/figures/xed_search_pane_buttons.png
share/help/ja/xed/figures/xed_window.png
share/help/ja/xed/index.docbook
share/help/ja/xed/legal.xml
-share/help/ko/xed/figures/xed_format_bold.png
-share/help/ko/xed/figures/xed_format_italic.png
-share/help/ko/xed/figures/xed_format_strikethrough.png
-share/help/ko/xed/figures/xed_format_underline.png
-share/help/ko/xed/figures/xed_recent_files_menu_icon.png
+share/help/ko/xed/figures/xed_print_button.png
+share/help/ko/xed/figures/xed_search_pane_buttons.png
share/help/ko/xed/figures/xed_window.png
share/help/ko/xed/index.docbook
share/help/ko/xed/legal.xml
-share/help/oc/xed/figures/xed_format_bold.png
-share/help/oc/xed/figures/xed_format_italic.png
-share/help/oc/xed/figures/xed_format_strikethrough.png
-share/help/oc/xed/figures/xed_format_underline.png
-share/help/oc/xed/figures/xed_recent_files_menu_icon.png
+share/help/oc/xed/figures/xed_print_button.png
+share/help/oc/xed/figures/xed_search_pane_buttons.png
share/help/oc/xed/figures/xed_window.png
share/help/oc/xed/index.docbook
share/help/oc/xed/legal.xml
-share/help/pt_BR/xed/figures/xed_format_bold.png
-share/help/pt_BR/xed/figures/xed_format_italic.png
-share/help/pt_BR/xed/figures/xed_format_strikethrough.png
-share/help/pt_BR/xed/figures/xed_format_underline.png
-share/help/pt_BR/xed/figures/xed_recent_files_menu_icon.png
+share/help/pt_BR/xed/figures/xed_print_button.png
+share/help/pt_BR/xed/figures/xed_search_pane_buttons.png
share/help/pt_BR/xed/figures/xed_window.png
share/help/pt_BR/xed/index.docbook
share/help/pt_BR/xed/legal.xml
-share/help/ru/xed/figures/xed_format_bold.png
-share/help/ru/xed/figures/xed_format_italic.png
-share/help/ru/xed/figures/xed_format_strikethrough.png
-share/help/ru/xed/figures/xed_format_underline.png
-share/help/ru/xed/figures/xed_recent_files_menu_icon.png
+share/help/ru/xed/figures/xed_print_button.png
+share/help/ru/xed/figures/xed_search_pane_buttons.png
share/help/ru/xed/figures/xed_window.png
share/help/ru/xed/index.docbook
share/help/ru/xed/legal.xml
-share/help/sv/xed/figures/xed_format_bold.png
-share/help/sv/xed/figures/xed_format_italic.png
-share/help/sv/xed/figures/xed_format_strikethrough.png
-share/help/sv/xed/figures/xed_format_underline.png
-share/help/sv/xed/figures/xed_recent_files_menu_icon.png
+share/help/sv/xed/figures/xed_print_button.png
+share/help/sv/xed/figures/xed_search_pane_buttons.png
share/help/sv/xed/figures/xed_window.png
share/help/sv/xed/index.docbook
share/help/sv/xed/legal.xml
-share/help/th/xed/figures/xed_format_bold.png
-share/help/th/xed/figures/xed_format_italic.png
-share/help/th/xed/figures/xed_format_strikethrough.png
-share/help/th/xed/figures/xed_format_underline.png
-share/help/th/xed/figures/xed_recent_files_menu_icon.png
+share/help/th/xed/figures/xed_print_button.png
+share/help/th/xed/figures/xed_search_pane_buttons.png
share/help/th/xed/figures/xed_window.png
share/help/th/xed/index.docbook
share/help/th/xed/legal.xml
-share/help/uk/xed/figures/xed_format_bold.png
-share/help/uk/xed/figures/xed_format_italic.png
-share/help/uk/xed/figures/xed_format_strikethrough.png
-share/help/uk/xed/figures/xed_format_underline.png
-share/help/uk/xed/figures/xed_recent_files_menu_icon.png
+share/help/uk/xed/figures/xed_print_button.png
+share/help/uk/xed/figures/xed_search_pane_buttons.png
share/help/uk/xed/figures/xed_window.png
share/help/uk/xed/index.docbook
share/help/uk/xed/legal.xml
-share/help/zh_CN/xed/figures/xed_format_bold.png
-share/help/zh_CN/xed/figures/xed_format_italic.png
-share/help/zh_CN/xed/figures/xed_format_strikethrough.png
-share/help/zh_CN/xed/figures/xed_format_underline.png
-share/help/zh_CN/xed/figures/xed_recent_files_menu_icon.png
+share/help/zh_CN/xed/figures/xed_print_button.png
+share/help/zh_CN/xed/figures/xed_search_pane_buttons.png
share/help/zh_CN/xed/figures/xed_window.png
share/help/zh_CN/xed/index.docbook
share/help/zh_CN/xed/legal.xml
-share/help/zh_HK/xed/figures/xed_format_bold.png
-share/help/zh_HK/xed/figures/xed_format_italic.png
-share/help/zh_HK/xed/figures/xed_format_strikethrough.png
-share/help/zh_HK/xed/figures/xed_format_underline.png
-share/help/zh_HK/xed/figures/xed_recent_files_menu_icon.png
+share/help/zh_HK/xed/figures/xed_print_button.png
+share/help/zh_HK/xed/figures/xed_search_pane_buttons.png
share/help/zh_HK/xed/figures/xed_window.png
share/help/zh_HK/xed/index.docbook
share/help/zh_HK/xed/legal.xml
-share/help/zh_TW/xed/figures/xed_format_bold.png
-share/help/zh_TW/xed/figures/xed_format_italic.png
-share/help/zh_TW/xed/figures/xed_format_strikethrough.png
-share/help/zh_TW/xed/figures/xed_format_underline.png
-share/help/zh_TW/xed/figures/xed_recent_files_menu_icon.png
+share/help/zh_TW/xed/figures/xed_print_button.png
+share/help/zh_TW/xed/figures/xed_search_pane_buttons.png
share/help/zh_TW/xed/figures/xed_window.png
share/help/zh_TW/xed/index.docbook
share/help/zh_TW/xed/legal.xml
@@ -391,6 +321,7 @@ share/metainfo/xed.appdata.xml
%%DATADIR%%/plugins/docinfo/docinfo.ui
%%DATADIR%%/plugins/filebrowser/xed-file-browser-widget-ui.xml
%%DATADIR%%/plugins/modelines/language-mappings
+%%GSPELL%%%%DATADIR%%/plugins/spell/xed-spell-setup-dialog.ui
%%DATADIR%%/plugins/taglist/C.tags.gz
%%DATADIR%%/plugins/taglist/HTML.tags.gz
%%DATADIR%%/plugins/taglist/Latex.tags.gz