aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2023-06-07 19:01:09 +0000
committerGleb Popov <arrowd@FreeBSD.org>2023-06-07 19:01:45 +0000
commitd14c324e94927af3d41d062ef87b7368265dc4a7 (patch)
treefeb43b64f3f3105aadb5360a778f10f09066c36f
parentcbbff3b6c21b1cff79d3c083ecf9bf805d04c41b (diff)
downloadports-d14c324e94927af3d41d062ef87b7368265dc4a7.tar.gz
ports-d14c324e94927af3d41d062ef87b7368265dc4a7.zip
Haskell ports: Fix dependency on GHC 9.2 after its upgrade.
Reported by: pkg-fallout
-rw-r--r--cad/hs-verismith/Makefile2
-rw-r--r--devel/elm-format/Makefile2
-rw-r--r--devel/hs-darcs/Makefile2
-rw-r--r--devel/hs-git-annex/Makefile2
-rw-r--r--devel/hs-haskell-language-server/Makefile4
-rw-r--r--devel/hs-mueval/Makefile2
-rw-r--r--devel/hs-spago/Makefile2
-rw-r--r--devel/hs-threadscope/Makefile2
-rw-r--r--lang/purescript/Makefile2
-rw-r--r--misc/hs-hascard/Makefile2
-rw-r--r--security/hs-cryptol/Makefile2
-rw-r--r--www/hs-postgrest/Makefile2
12 files changed, 13 insertions, 13 deletions
diff --git a/cad/hs-verismith/Makefile b/cad/hs-verismith/Makefile
index 37d5c85dac8f..6d0d91cfa2ce 100644
--- a/cad/hs-verismith/Makefile
+++ b/cad/hs-verismith/Makefile
@@ -14,7 +14,7 @@ WWW= https://github.com/ymherklotz/verismith
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
USES= cabal
diff --git a/devel/elm-format/Makefile b/devel/elm-format/Makefile
index 759eefb24047..a090f2d6b30d 100644
--- a/devel/elm-format/Makefile
+++ b/devel/elm-format/Makefile
@@ -8,7 +8,7 @@ WWW= https://github.com/avh4/elm-format/
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
USES= cabal
USE_GITHUB= yes
diff --git a/devel/hs-darcs/Makefile b/devel/hs-darcs/Makefile
index 9145a35a804b..a68a5a38d541 100644
--- a/devel/hs-darcs/Makefile
+++ b/devel/hs-darcs/Makefile
@@ -9,7 +9,7 @@ WWW= http://darcs.net/
LICENSE= GPLv2+
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
LIB_DEPENDS= libcurl.so:ftp/curl
USES= cabal pkgconfig
diff --git a/devel/hs-git-annex/Makefile b/devel/hs-git-annex/Makefile
index b9691dab57ba..6f06133c2bcf 100644
--- a/devel/hs-git-annex/Makefile
+++ b/devel/hs-git-annex/Makefile
@@ -13,7 +13,7 @@ BROKEN_aarch64= compiler crashes
BUILD_DEPENDS= rsync:net/rsync \
git:devel/git \
gsha256sum:sysutils/coreutils \
- ghc-9.2.7:lang/ghc92
+ ghc-9.2.8:lang/ghc92
RUN_DEPENDS= rsync:net/rsync \
git:devel/git \
diff --git a/devel/hs-haskell-language-server/Makefile b/devel/hs-haskell-language-server/Makefile
index e787b4209207..646e917d3f7c 100644
--- a/devel/hs-haskell-language-server/Makefile
+++ b/devel/hs-haskell-language-server/Makefile
@@ -21,8 +21,8 @@ PKGNAMESUFFIX= -${FLAVOR}
BUILD_DEPENDS= ghc-8.10.7:lang/ghc810
GHC_VERSION= 8.10.7
.elif ${FLAVOR:U} == ghc92
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
-GHC_VERSION= 9.2.7
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
+GHC_VERSION= 9.2.8
.endif
USES= cabal
diff --git a/devel/hs-mueval/Makefile b/devel/hs-mueval/Makefile
index e0fb634e4686..7e3b5583c6f5 100644
--- a/devel/hs-mueval/Makefile
+++ b/devel/hs-mueval/Makefile
@@ -9,7 +9,7 @@ WWW= https://github.com/gwern/mueval
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
USES= cabal
diff --git a/devel/hs-spago/Makefile b/devel/hs-spago/Makefile
index dd888dd7a516..6409fb1df160 100644
--- a/devel/hs-spago/Makefile
+++ b/devel/hs-spago/Makefile
@@ -17,7 +17,7 @@ WWW= https://github.com/spacchetti/spago
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
RUN_DEPENDS= ca_root_nss>0:security/ca_root_nss
USES= cabal
diff --git a/devel/hs-threadscope/Makefile b/devel/hs-threadscope/Makefile
index eb2cd5c6818a..902f49b01fc3 100644
--- a/devel/hs-threadscope/Makefile
+++ b/devel/hs-threadscope/Makefile
@@ -9,7 +9,7 @@ WWW= https://www.haskell.org/haskellwiki/ThreadScope
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
diff --git a/lang/purescript/Makefile b/lang/purescript/Makefile
index a9eb91c71752..8d7c3947cc2f 100644
--- a/lang/purescript/Makefile
+++ b/lang/purescript/Makefile
@@ -10,7 +10,7 @@ LICENSE= BSD3CLAUSE
BROKEN_aarch64= compiler crashes
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
USES= cabal
diff --git a/misc/hs-hascard/Makefile b/misc/hs-hascard/Makefile
index 57c0391ea918..c3406f5f04dc 100644
--- a/misc/hs-hascard/Makefile
+++ b/misc/hs-hascard/Makefile
@@ -10,7 +10,7 @@ WWW= https://github.com/Yvee1/hascard
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
USES= cabal
USE_CABAL= MonadPrompt-1.0.0.5 \
diff --git a/security/hs-cryptol/Makefile b/security/hs-cryptol/Makefile
index affc1afc0637..d4885f00ab4b 100644
--- a/security/hs-cryptol/Makefile
+++ b/security/hs-cryptol/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to build: src/LibBF/Mutable.hsc error: Couldn't match type `Int64' with `Int32'
BROKEN_i386= One of dependencies doesn't build on i386
-BUILD_DEPENDS= ghc-9.2.7:lang/ghc92
+BUILD_DEPENDS= ghc-9.2.8:lang/ghc92
RUN_DEPENDS= z3:math/z3
USES= cabal
diff --git a/www/hs-postgrest/Makefile b/www/hs-postgrest/Makefile
index d9a4557c58d2..19a7dbd20bff 100644
--- a/www/hs-postgrest/Makefile
+++ b/www/hs-postgrest/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 i386
BUILD_DEPENDS= pg_config:databases/postgresql${PGSQL_DEFAULT}-client \
- ghc-9.2.7:lang/ghc92
+ ghc-9.2.8:lang/ghc92
USES= cabal pgsql