aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-05-19 13:54:39 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-05-19 13:54:39 +0000
commitd14dec2ee2ca6e901cde51d5666b0d5d3b67d7bb (patch)
tree52a1c3a5d94e5302fb7773c250f8ebf295c62568
parentaf3d859e515119a5e7ffa854a054434528a73170 (diff)
downloadports-d14dec2ee2ca6e901cde51d5666b0d5d3b67d7bb.tar.gz
ports-d14dec2ee2ca6e901cde51d5666b0d5d3b67d7bb.zip
There are a lot of XSS, a security hole typically found in web
applications, caused by incorrect (or lack of) JavaScript escaping. This module is aimed to provide a secure JavaScript escaping to avoid XSS with JavaScript values. The escaping routine JavaScript::Value::Escape provides escapes q!"!, q!'!, q!&!, q!=!, q!-!, q!+!, q!;!, q!<!, q!>!, q!/!, q!\! and control characters to JavaScript unicode entities like "\u0026". WWW: http://search.cpan.org/dist/JavaScript-Value-Escape/
Notes
Notes: svn path=/head/; revision=274317
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-JavaScript-Value-Escape/Makefile21
-rw-r--r--lang/p5-JavaScript-Value-Escape/distinfo2
-rw-r--r--lang/p5-JavaScript-Value-Escape/pkg-descr10
-rw-r--r--lang/p5-JavaScript-Value-Escape/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 64af218e3bb3..08a96db0cba7 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -213,6 +213,7 @@
SUBDIR += p5-JavaScript
SUBDIR += p5-JavaScript-SpiderMonkey
SUBDIR += p5-JavaScript-Squish
+ SUBDIR += p5-JavaScript-Value-Escape
SUBDIR += p5-List-MoreUtils
SUBDIR += p5-Modern-Perl
SUBDIR += p5-Parse-Perl
diff --git a/lang/p5-JavaScript-Value-Escape/Makefile b/lang/p5-JavaScript-Value-Escape/Makefile
new file mode 100644
index 000000000000..c1f182f4a4e8
--- /dev/null
+++ b/lang/p5-JavaScript-Value-Escape/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: JavaScript::Value::Escape
+# Date created: 19 May 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JavaScript-Value-Escape
+PORTVERSION= 0.05
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to avoid XSS with JavaScript value interpolation
+
+PERL_CONFIGURE= yes
+
+MAN3= JavaScript::Value::Escape.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-JavaScript-Value-Escape/distinfo b/lang/p5-JavaScript-Value-Escape/distinfo
new file mode 100644
index 000000000000..be05e6491265
--- /dev/null
+++ b/lang/p5-JavaScript-Value-Escape/distinfo
@@ -0,0 +1,2 @@
+SHA256 (JavaScript-Value-Escape-0.05.tar.gz) = 1fc6770c1a8d8fb0a9f17d3d40d71e52ae3b073676b8bc95f4f6eeca76a64011
+SIZE (JavaScript-Value-Escape-0.05.tar.gz) = 20856
diff --git a/lang/p5-JavaScript-Value-Escape/pkg-descr b/lang/p5-JavaScript-Value-Escape/pkg-descr
new file mode 100644
index 000000000000..896cdc59fc95
--- /dev/null
+++ b/lang/p5-JavaScript-Value-Escape/pkg-descr
@@ -0,0 +1,10 @@
+There are a lot of XSS, a security hole typically found in web
+applications, caused by incorrect (or lack of) JavaScript
+escaping. This module is aimed to provide a secure JavaScript
+escaping to avoid XSS with JavaScript values.
+
+The escaping routine JavaScript::Value::Escape provides escapes q!"!,
+q!'!, q!&!, q!=!, q!-!, q!+!, q!;!, q!<!, q!>!, q!/!, q!\! and control
+characters to JavaScript unicode entities like "\u0026".
+
+WWW: http://search.cpan.org/dist/JavaScript-Value-Escape/
diff --git a/lang/p5-JavaScript-Value-Escape/pkg-plist b/lang/p5-JavaScript-Value-Escape/pkg-plist
new file mode 100644
index 000000000000..37cb85c00bf7
--- /dev/null
+++ b/lang/p5-JavaScript-Value-Escape/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/Value/Escape/.packlist
+%%SITE_PERL%%/JavaScript/Value/Escape.pm
+@dirrm %%SITE_PERL%%/JavaScript/Value
+@dirrm %%SITE_PERL%%/JavaScript
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/Value/Escape
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/Value
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript