aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2022-02-08 17:38:33 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2022-02-08 17:38:33 +0000
commitd187db4415d7776fabf62996972958bf220276f1 (patch)
treed5283346e447eaf6ae6012cb6da36a4f70041aaf
parent5bb882788ca0b6f3ccd17f9c83f69e1863a79d92 (diff)
downloadports-d187db4415d7776fabf62996972958bf220276f1.tar.gz
ports-d187db4415d7776fabf62996972958bf220276f1.zip
sysutils/unetbootin: switch from p7zip to 7-zip
PR: 260866, 261569 Approved by: danfe@ (maintainer)
-rw-r--r--sysutils/unetbootin/Makefile4
-rw-r--r--sysutils/unetbootin/files/patch-unetbootin.cpp2
2 files changed, 3 insertions, 3 deletions
diff --git a/sysutils/unetbootin/Makefile b/sysutils/unetbootin/Makefile
index 70bb2cce05f5..88765958f716 100644
--- a/sysutils/unetbootin/Makefile
+++ b/sysutils/unetbootin/Makefile
@@ -2,7 +2,7 @@
PORTNAME= unetbootin
PORTVERSION= 702
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
@@ -12,7 +12,7 @@ COMMENT= Bootable Live USB creator for various Linux distributions
LICENSE= GPLv2+
-RUN_DEPENDS= 7z:archivers/p7zip \
+RUN_DEPENDS= 7zz:archivers/7-zip \
syslinux:sysutils/syslinux \
mke2fs:sysutils/e2fsprogs
diff --git a/sysutils/unetbootin/files/patch-unetbootin.cpp b/sysutils/unetbootin/files/patch-unetbootin.cpp
index f697ec06c21e..30be2861057e 100644
--- a/sysutils/unetbootin/files/patch-unetbootin.cpp
+++ b/sysutils/unetbootin/files/patch-unetbootin.cpp
@@ -6,7 +6,7 @@
#endif // Q_OS_LINUX
+#ifdef Q_OS_FREEBSD
+ syslinuxcommand = locatecommand("syslinux", tr("FAT32-formatted USB drive"), "syslinux");
-+ sevzcommand = locatecommand("7z", tr("either"), "p7zip");
++ sevzcommand = locatecommand("7zz", tr("either"), "7-zip");
+ mke2fscommand = locatecommand("mke2fs", tr("LiveUSB persistence"), "e2fsprogs");
+#endif // Q_OS_FREEBSD
ubntmpf = QDir::toNativeSeparators(QString("%1/").arg(QDir::tempPath()));