aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 07:56:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-11-01 07:56:05 +0000
commitd1887c1b96b5a2e32984aa5696fa97c77c289afd (patch)
tree15a6f26bed83d5e270d3f635ad9ee76c3ba5d9da
parent5486ece73365dff72bf07463c15d1aa78e4f8c80 (diff)
downloadports-d1887c1b96b5a2e32984aa5696fa97c77c289afd.tar.gz
ports-d1887c1b96b5a2e32984aa5696fa97c77c289afd.zip
mail/rubygem-actionmailbox71: Add rubygem-actionmailbox71 7.1.1
Action Mailbox routes incoming emails to controller-like mailboxes for processing in Rails. It ships with ingresses for Mailgun, Mandrill, Postmark, and SendGrid. You can also handle inbound mails directly via the built-in Exim, Postfix, and Qmail ingresses. The inbound emails are turned into InboundEmail records using Active Record and feature lifecycle tracking, storage of the original email on cloud storage via Active Storage, and responsible data handling with on-by-default incineration. These inbound emails are routed asynchronously using Active Job to one or several dedicated mailboxes, which are capable of interacting directly with the rest of your domain model.
-rw-r--r--mail/Makefile1
-rw-r--r--mail/rubygem-actionmailbox71/Makefile31
-rw-r--r--mail/rubygem-actionmailbox71/distinfo3
-rw-r--r--mail/rubygem-actionmailbox71/pkg-descr12
4 files changed, 47 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 99aead784f59..7dc4b7581784 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -587,6 +587,7 @@
SUBDIR += rubygem-actionmailbox60
SUBDIR += rubygem-actionmailbox61
SUBDIR += rubygem-actionmailbox70
+ SUBDIR += rubygem-actionmailbox71
SUBDIR += rubygem-actionmailer4
SUBDIR += rubygem-actionmailer5
SUBDIR += rubygem-actionmailer50
diff --git a/mail/rubygem-actionmailbox71/Makefile b/mail/rubygem-actionmailbox71/Makefile
new file mode 100644
index 000000000000..3012a1ac8a71
--- /dev/null
+++ b/mail/rubygem-actionmailbox71/Makefile
@@ -0,0 +1,31 @@
+PORTNAME= actionmailbox
+PORTVERSION= 7.1.1
+CATEGORIES= mail rubygems
+MASTER_SITES= RG
+PKGNAMESUFFIX= 71
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Receive and process incoming emails in Rails applications
+WWW= https://github.com/rails/rails/tree/main/actionmailbox \
+ https://rubyonrails.org/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
+
+RUN_DEPENDS= rubygem-actionpack71>=${PORTVERSION}<${PORTVERSION}_99:www/rubygem-actionpack71 \
+ rubygem-activejob71>=${PORTVERSION}<${PORTVERSION}_99:devel/rubygem-activejob71 \
+ rubygem-activerecord71>=${PORTVERSION}<${PORTVERSION}_99:databases/rubygem-activerecord71 \
+ rubygem-activestorage71>=${PORTVERSION}<${PORTVERSION}_99:net/rubygem-activestorage71 \
+ rubygem-activesupport71>=${PORTVERSION}<${PORTVERSION}_99:devel/rubygem-activesupport71 \
+ rubygem-mail>=2.7.1,2:mail/rubygem-mail \
+ rubygem-net-imap>=0:mail/rubygem-net-imap \
+ rubygem-net-pop>=0:mail/rubygem-net-pop \
+ rubygem-net-smtp>=0:mail/rubygem-net-smtp
+
+USES= gem
+
+NO_ARCH= yes
+
+PORTSCOUT= limit:^7\.1\.
+
+.include <bsd.port.mk>
diff --git a/mail/rubygem-actionmailbox71/distinfo b/mail/rubygem-actionmailbox71/distinfo
new file mode 100644
index 000000000000..641e7d172c23
--- /dev/null
+++ b/mail/rubygem-actionmailbox71/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1697330178
+SHA256 (rubygem/actionmailbox-7.1.1.gem) = e1e9e9d9072953edad32bddbfab855c4ddfab7f34140bdb5b8c26375d109c78e
+SIZE (rubygem/actionmailbox-7.1.1.gem) = 22528
diff --git a/mail/rubygem-actionmailbox71/pkg-descr b/mail/rubygem-actionmailbox71/pkg-descr
new file mode 100644
index 000000000000..ffc1daea8253
--- /dev/null
+++ b/mail/rubygem-actionmailbox71/pkg-descr
@@ -0,0 +1,12 @@
+Action Mailbox routes incoming emails to controller-like mailboxes for
+processing in Rails. It ships with ingresses for Mailgun, Mandrill, Postmark,
+and SendGrid. You can also handle inbound mails directly via the built-in Exim,
+Postfix, and Qmail ingresses.
+
+The inbound emails are turned into InboundEmail records using Active Record and
+feature lifecycle tracking, storage of the original email on cloud storage via
+Active Storage, and responsible data handling with on-by-default incineration.
+
+These inbound emails are routed asynchronously using Active Job to one or
+several dedicated mailboxes, which are capable of interacting directly with the
+rest of your domain model.