aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-02-07 23:48:09 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2023-02-07 23:49:06 +0000
commitd1b04483c52a818a56054ddb3bbe8b706e3f3cd7 (patch)
tree239a4acc41c535cfcf86be6aefcc7f2662c1b5a4
parente7111d77c0a7e67cc0277d62f02dab636e1b709c (diff)
downloadports-d1b04483c52a818a56054ddb3bbe8b706e3f3cd7.tar.gz
ports-d1b04483c52a818a56054ddb3bbe8b706e3f3cd7.zip
*/*: update NGINX JavaScript 0.7.9 -> 0.7.10
Bump PORTREVISION for www/nginx-devel. <ChangeLog> nginx modules: *) Feature: added Request, Response and Headers ctors in Fetch API. *) Bugfix: fixed nginx logger callback for calls in master process. Core: *) Feature: added signal support in CLI. *) Feature: added "xml" module for working with XML documents. *) Feature: extended support for symmetric and asymmetric keys in WebCrypto. Most notably JWK format for importKey() was added. *) Feature: extended support for symmetric and asymmetric keys in WebCrypto. Most notably JWK format for importKey() was added. generateKey() and exportKey() were also implemented. *) Feature: added String.prototype.replaceAll(). *) Bugfix: fixed for(expr1; conditional syntax error handling. *) Bugfix: fixed Object.values() and Object.entries() with external objects. *) Bugfix: fixed RegExp.prototype[@@replace](). </ChangeLog>
-rw-r--r--devel/libnjs/Makefile2
-rw-r--r--devel/libnjs/distinfo6
-rw-r--r--www/nginx-devel/Makefile8
-rw-r--r--www/nginx-devel/Makefile.extmod5
-rw-r--r--www/nginx-devel/Makefile.options.desc3
-rw-r--r--www/nginx-devel/distinfo6
6 files changed, 19 insertions, 11 deletions
diff --git a/devel/libnjs/Makefile b/devel/libnjs/Makefile
index 269f68a519d5..55226ef510e4 100644
--- a/devel/libnjs/Makefile
+++ b/devel/libnjs/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libnjs
-DISTVERSION= 0.7.9
+DISTVERSION= 0.7.10
CATEGORIES= devel www
MAINTAINER= osa@FreeBSD.org
diff --git a/devel/libnjs/distinfo b/devel/libnjs/distinfo
index 161f62d3fa41..36c42be7d98d 100644
--- a/devel/libnjs/distinfo
+++ b/devel/libnjs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1668698435
-SHA256 (nginx-njs-0.7.9_GH0.tar.gz) = 92cc425d0b0952bb7e2e7a396cba58feb4a90fb3cb63441c201ab4d3e0cd6403
-SIZE (nginx-njs-0.7.9_GH0.tar.gz) = 617115
+TIMESTAMP = 1675792206
+SHA256 (nginx-njs-0.7.10_GH0.tar.gz) = fa69ce6819f172c34338dc23ba5126ac986caf4652c7c01ea02bcef93d558cc4
+SIZE (nginx-njs-0.7.10_GH0.tar.gz) = 652296
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 0a0ee6b1bf6e..19ea035ff50c 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -1,6 +1,6 @@
PORTNAME?= nginx
PORTVERSION= 1.23.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
LOCAL/osa
@@ -79,7 +79,7 @@ OPTIONS_GROUP_MAILGRP= MAIL MAIL_IMAP MAIL_POP3 MAIL_SMTP MAIL_SSL
OPTIONS_GROUP_STREAMGRP= STREAM STREAM_REALIP STREAM_SSL \
STREAM_SSL_PREREAD
-OPTIONS_DEFINE= DEBUG DEBUGLOG DSO FILE_AIO IPV6 NJS THREADS WWW
+OPTIONS_DEFINE= DEBUG DEBUGLOG DSO FILE_AIO IPV6 NJS NJS_XML THREADS WWW
OPTIONS_DEFAULT?= DSO FILE_AIO HTTP HTTP_ADDITION HTTP_AUTH_REQ HTTP_CACHE \
HTTP_DAV HTTP_FLV HTTP_GUNZIP_FILTER HTTP_GZIP_STATIC HTTP_MP4 \
HTTP_RANDOM_INDEX HTTP_REALIP HTTP_SECURE_LINK HTTP_SLICE HTTP_SSL \
@@ -252,6 +252,10 @@ IGNORE= required HTTPV3_BORING or HTTPV3_LSSL or HTTPV3_QTLS \
NJS_CONFIGURE_ARGS= --no-pcre2
.endif
+.if empty(PORT_OPTIONS:MNJS_XML)
+NJS_CONFIGURE_ARGS= --no-libxml2
+.endif
+
pre-everything::
@${ECHO_MSG}
.if ${PORT_OPTIONS:MHTTP_UPSTREAM_FAIR}
diff --git a/www/nginx-devel/Makefile.extmod b/www/nginx-devel/Makefile.extmod
index a3932ff06b34..224cb918cd18 100644
--- a/www/nginx-devel/Makefile.extmod
+++ b/www/nginx-devel/Makefile.extmod
@@ -247,10 +247,13 @@ NAXSI_GH_TUPLE= nbs-system:naxsi:${NAXSI_NGINX_VER}:naxsi
NAXSI_VARS= DSO_EXTMODS+=naxsi NAXSI_SUBDIR=/naxsi_src
NAXSI_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-naxsi_runtime.c
-NJS_GH_TUPLE= nginx:njs:0.7.9:njs
+NJS_GH_TUPLE= nginx:njs:0.7.10:njs
NJS_VARS= DSO_EXTMODS+=njs NJS_SUBDIR=/nginx
NJS_USES= libedit
+NJS_XML_IMPLIES= NJS
+NJS_XML_LIB_DEPENDS= libxml2.so:textproc/libxml2
+
OPENTRACING_GH_TUPLE= opentracing-contrib:nginx-opentracing:v0.24.0:opentracing
OPENTRACING_LIB_DEPENDS= libopentracing.so:devel/libopentracing
OPENTRACING_VARS= DSO_EXTMODS+=opentracing OPENTRACING_SUBDIR=/opentracing
diff --git a/www/nginx-devel/Makefile.options.desc b/www/nginx-devel/Makefile.options.desc
index 9f2a6a589e41..bfe005c66f25 100644
--- a/www/nginx-devel/Makefile.options.desc
+++ b/www/nginx-devel/Makefile.options.desc
@@ -90,7 +90,8 @@ MAIL_SSL_DESC= Enable mail_ssl module
MEMC_DESC= 3rd party memc (memcached) module
MODSECURITY3_DESC= 3rd party modsecurity3 module
NAXSI_DESC= 3rd party naxsi module
-NJS_DESC= Enable javascript module
+NJS_DESC= Enable javascript (NJS) module
+NJS_XML_DESC= Enable XML functionality in NJS module
OPENTRACING_DESC= 3rd party opentracing module
PASSENGER_DESC= 3rd party passenger module
PCRE_ONE_DESC= Enable PCRE1 support
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 522a802ee0df..867ebcc14b4d 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1674147529
+TIMESTAMP = 1675811845
SHA256 (nginx-1.23.3.tar.gz) = 75cb5787dbb9fae18b14810f91cc4343f64ce4c24e27302136fb52498042ba54
SIZE (nginx-1.23.3.tar.gz) = 1108958
SHA256 (nginx_mogilefs_module-1.0.4.tar.gz) = 7ac230d30907f013dff8d435a118619ea6168aa3714dba62c6962d350c6295ae
@@ -107,8 +107,8 @@ SHA256 (SpiderLabs-ModSecurity-nginx-v1.0.3_GH0.tar.gz) = 32a42256616cc674dca24c
SIZE (SpiderLabs-ModSecurity-nginx-v1.0.3_GH0.tar.gz) = 34063
SHA256 (nbs-system-naxsi-29793dc_GH0.tar.gz) = 579df0e50ff32464f7bb152df9d93ea18c05c4aa3966ec4d8c603b5dd629be08
SIZE (nbs-system-naxsi-29793dc_GH0.tar.gz) = 236932
-SHA256 (nginx-njs-0.7.9_GH0.tar.gz) = 92cc425d0b0952bb7e2e7a396cba58feb4a90fb3cb63441c201ab4d3e0cd6403
-SIZE (nginx-njs-0.7.9_GH0.tar.gz) = 617115
+SHA256 (nginx-njs-0.7.10_GH0.tar.gz) = fa69ce6819f172c34338dc23ba5126ac986caf4652c7c01ea02bcef93d558cc4
+SIZE (nginx-njs-0.7.10_GH0.tar.gz) = 652296
SHA256 (opentracing-contrib-nginx-opentracing-v0.24.0_GH0.tar.gz) = 5328c5f37e0615b5252aed51b9cd40f3d14989d995ad54134076aeda4ab9b280
SIZE (opentracing-contrib-nginx-opentracing-v0.24.0_GH0.tar.gz) = 679417
SHA256 (konstruxi-ngx_postgres-8aa7359_GH0.tar.gz) = c69ad4495de7c7883ebc23e1e6c4cc83a4ac6a7fddd4d5c12e49d33b65f7c50b