aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-06-14 17:35:07 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-07 22:37:20 +0000
commitd1bc019710a876b7cdfc2eb3f56d912d50337263 (patch)
tree2c41ce79b21704d9be6803e8cf18d04fcf3cb38b
parentdad575bcf10a730b1f13b92a6c86b1d71fe91591 (diff)
downloadports-d1bc019710a876b7cdfc2eb3f56d912d50337263.tar.gz
ports-d1bc019710a876b7cdfc2eb3f56d912d50337263.zip
x11-wm/kwinft: update to 5.25.0 after d06d26f8c45e
-rw-r--r--x11-wm/kwinft/Makefile13
-rw-r--r--x11-wm/kwinft/distinfo6
-rw-r--r--x11-wm/kwinft/files/patch-render_effect_internal__win__properties.h23
-rw-r--r--x11-wm/kwinft/files/patch-xwl_xwayland.cpp34
-rw-r--r--x11-wm/kwinft/pkg-plist70
5 files changed, 115 insertions, 31 deletions
diff --git a/x11-wm/kwinft/Makefile b/x11-wm/kwinft/Makefile
index 7f9cbec20178..769b90c6cc39 100644
--- a/x11-wm/kwinft/Makefile
+++ b/x11-wm/kwinft/Makefile
@@ -1,7 +1,6 @@
PORTNAME= kwinft
DISTVERSIONPREFIX= ${PORTNAME}@
-DISTVERSION= 5.24.1
-PORTREVISION= 1
+DISTVERSION= 5.25.0
CATEGORIES= x11-wm wayland
MAINTAINER= jbeich@FreeBSD.org
@@ -11,8 +10,6 @@ WWW= https://gitlab.com/kwinft/kwinft
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= requires https://gitlab.com/kwinft/kwinft/-/commit/facc1040ff1e
-
BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libwayland-server.so:graphics/wayland \
@@ -33,17 +30,17 @@ CONFLICTS_INSTALL= plasma5-kwin # bin/kwin_wayland
USES= cmake:testing gl kde:5 pkgconfig python:run qt:5 shebangfix xorg
USE_GITLAB= yes
USE_GL= egl
-USE_KDE= ecm:build auth completion config configwidgets \
+USE_KDE= ecm:build auth config configwidgets \
coreaddons crash dbusaddons decoration globalaccel i18n \
idletime kcmutils kdeclarative kio kscreenlocker newstuff \
- notifications package plasma-framework service textwidgets \
+ notifications package plasma-framework service \
widgetsaddons windowsystem xmlgui
USE_LDCONFIG= yes
USE_QT= qmake:build buildtools:build core dbus declarative gui \
multimedia:run quickcontrols2:run widgets x11extras
USE_XORG= pixman x11 xcb xi
-SHEBANG_FILES= kconf_update/*.py kconf_update/*.pl
-GL_COMMIT= 022f157ce4bd14fbe069ab6fe41647b70d20f004
+SHEBANG_FILES= effect/effects/*.py kconf_update/*.py kconf_update/*.pl
+GL_COMMIT= a70cd81ac8f81189782831e52b6fec01aeeefdfd
PLIST_SUB= VERSION=${PORTVERSION}
LDFLAGS+= -Wl,--as-needed # GL, ICE/SM/Xext, glib, intl, Qt5*, KF5*
diff --git a/x11-wm/kwinft/distinfo b/x11-wm/kwinft/distinfo
index 1d97723ae144..8f606fa3adf7 100644
--- a/x11-wm/kwinft/distinfo
+++ b/x11-wm/kwinft/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1650728835
-SHA256 (kwinft-kwinft-022f157ce4bd14fbe069ab6fe41647b70d20f004_GL0.tar.gz) = 56d29241573c4cc055b0024064c1a12fa2a6cfc57d7cfa0e9a2c08dd8605f324
-SIZE (kwinft-kwinft-022f157ce4bd14fbe069ab6fe41647b70d20f004_GL0.tar.gz) = 4941113
+TIMESTAMP = 1655228107
+SHA256 (kwinft-kwinft-a70cd81ac8f81189782831e52b6fec01aeeefdfd_GL0.tar.gz) = 68c5df0b9d0dba56391c8e4ec788a7d1a64c2195d6312b360d79c3afe76c5389
+SIZE (kwinft-kwinft-a70cd81ac8f81189782831e52b6fec01aeeefdfd_GL0.tar.gz) = 4988371
diff --git a/x11-wm/kwinft/files/patch-render_effect_internal__win__properties.h b/x11-wm/kwinft/files/patch-render_effect_internal__win__properties.h
new file mode 100644
index 000000000000..27d3e6d921a5
--- /dev/null
+++ b/x11-wm/kwinft/files/patch-render_effect_internal__win__properties.h
@@ -0,0 +1,23 @@
+In file included from ../.build/kwin_x11_lib_autogen/mocs_compilation.cpp:10:
+In file included from ../.build/kwin_x11_lib_autogen/TRO3DFMZQE/moc_effects.cpp:10:
+In file included from render/x11/effects.h:9:
+In file included from render/x11/effect/blur_integration.h:8:
+In file included from render/x11/effect/blur_update.h:8:
+In file included from render/effect/internal_win_update.h:9:
+render/effect/internal_win_properties.h:46:62: error: implicit instantiation of undefined template 'std::array<std::variant<KWin::render::internal_effect_property<QRegion>>, 1>'
+inline std::array<std::variant<internal_region_property>, 1> get_internal_blur_properties()
+ ^
+/usr/include/c++/v1/__tuple:219:64: note: template is declared here
+template <class _Tp, size_t _Size> struct _LIBCPP_TEMPLATE_VIS array;
+ ^
+
+--- render/effect/internal_win_properties.h.orig 2022-06-14 17:35:07 UTC
++++ render/effect/internal_win_properties.h
+@@ -7,6 +7,7 @@
+
+ #include <KWindowEffects>
+ #include <QVariant>
++#include <array>
+ #include <string_view>
+ #include <variant>
+
diff --git a/x11-wm/kwinft/files/patch-xwl_xwayland.cpp b/x11-wm/kwinft/files/patch-xwl_xwayland.cpp
new file mode 100644
index 000000000000..38481a7c9916
--- /dev/null
+++ b/x11-wm/kwinft/files/patch-xwl_xwayland.cpp
@@ -0,0 +1,34 @@
+Revert https://gitlab.com/kwinft/kwinft/-/commit/e22b49694e87
+
+xwl/xwayland.cpp:64:5: error: use of undeclared identifier 'close'
+ close(pipe);
+ ^
+xwl/xwayland.cpp:79:9: error: use of undeclared identifier 'pipe'
+ if (pipe(pipeFds) != 0) {
+ ^
+xwl/xwayland.cpp:88:14: error: use of undeclared identifier 'dup'
+ int fd = dup(sx[1]);
+ ^
+xwl/xwayland.cpp:96:9: error: use of undeclared identifier 'close'
+ close(fd);
+ ^
+xwl/xwayland.cpp:99:23: error: use of undeclared identifier 'dup'
+ auto const wlfd = dup(waylandSocket);
+ ^
+xwl/xwayland.cpp:101:9: error: use of undeclared identifier 'close'
+ close(fd);
+ ^
+xwl/xwayland.cpp:153:5: error: use of undeclared identifier 'close'
+ close(pipeFds[1]);
+ ^
+
+--- xwl/xwayland.cpp.orig 2022-06-14 17:35:07 UTC
++++ xwl/xwayland.cpp
+@@ -44,6 +44,7 @@ along with this program. If not, see <http://www.gnu.
+ #include <compositor.h>
+ #include <iostream>
+ #include <sys/socket.h>
++#include <unistd.h>
+
+ static void readDisplay(int pipe)
+ {
diff --git a/x11-wm/kwinft/pkg-plist b/x11-wm/kwinft/pkg-plist
index 7cc8b411edf2..c12d73794517 100644
--- a/x11-wm/kwinft/pkg-plist
+++ b/x11-wm/kwinft/pkg-plist
@@ -7,13 +7,37 @@ include/kwinconfig.h
include/kwindeformeffect.h
include/kwineffectquickview.h
include/kwineffects.h
+include/kwineffects/animation_effect.h
+include/kwineffects/deform_effect.h
+include/kwineffects/effect.h
+include/kwineffects/effect_frame.h
+include/kwineffects/effect_integration.h
+include/kwineffects/effect_plugin_factory.h
+include/kwineffects/effect_quick_view.h
+include/kwineffects/effect_screen.h
+include/kwineffects/effect_window.h
+include/kwineffects/effects_handler.h
+include/kwineffects/export.h
+include/kwineffects/motions.h
+include/kwineffects/paint_clipper.h
+include/kwineffects/paint_data.h
+include/kwineffects/time_line.h
+include/kwineffects/types.h
+include/kwineffects/window_quad.h
include/kwineffects_export.h
+include/kwingl/export.h
+include/kwingl/platform.h
+include/kwingl/texture.h
+include/kwingl/utils.h
+include/kwingl/utils_funcs.h
include/kwinglobals.h
include/kwinglplatform.h
include/kwingltexture.h
include/kwinglutils.h
include/kwinglutils_export.h
include/kwinglutils_funcs.h
+include/kwinxrender/export.h
+include/kwinxrender/utils.h
include/kwinxrenderutils.h
include/kwinxrenderutils_export.h
lib/cmake/KWinDBusInterface/KWinDBusInterfaceConfig.cmake
@@ -40,15 +64,6 @@ lib/libkwinglutils.so.%%VERSION%%
lib/libkwinxrenderutils.so
lib/libkwinxrenderutils.so.13
lib/libkwinxrenderutils.so.%%VERSION%%
-%%QT_PLUGINDIR%%/kcm_kwin_scripts.so
-%%QT_PLUGINDIR%%/kcm_kwinoptions.so
-%%QT_PLUGINDIR%%/kcm_kwinscreenedges.so
-%%QT_PLUGINDIR%%/kcm_kwintabbox.so
-%%QT_PLUGINDIR%%/kcm_kwintouchscreen.so
-%%QT_PLUGINDIR%%/kcms/kcm_kwin_effects.so
-%%QT_PLUGINDIR%%/kcms/kcm_kwin_virtualdesktops.so
-%%QT_PLUGINDIR%%/kcms/kcm_kwindecoration.so
-%%QT_PLUGINDIR%%/kcms/kcm_kwinrules.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_aurorae.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_decoration.so
%%QT_PLUGINDIR%%/kpackage/packagestructure/kwin_effect.so
@@ -78,8 +93,17 @@ lib/libkwinxrenderutils.so.%%VERSION%%
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_trackmouse_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_wobblywindows_config.so
%%QT_PLUGINDIR%%/kwin/effects/configs/kwin_zoom_config.so
-%%QT_PLUGINDIR%%/kwincompositing.so
%%QT_PLUGINDIR%%/org.kde.kdecoration2/kwin5_aurorae.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_kwin_effects.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_kwin_scripts.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_kwin_virtualdesktops.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_kwindecoration.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings/kcm_kwinrules.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kcm_kwinoptions.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kcm_kwinscreenedges.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kcm_kwintabbox.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kcm_kwintouchscreen.so
+%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kwincompositing.so
%%QT_QMLDIR%%/org/kde/kwin/decoration/AppMenuButton.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/ButtonGroup.qml
%%QT_QMLDIR%%/org/kde/kwin/decoration/Decoration.qml
@@ -93,6 +117,15 @@ lib/libkwinxrenderutils.so.%%VERSION%%
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/qmldir
lib/systemd/user/plasma-kwin_wayland.service
lib/systemd/user/plasma-kwin_x11.service
+share/applications/kcm_kwin_effects.desktop
+share/applications/kcm_kwin_scripts.desktop
+share/applications/kcm_kwin_virtualdesktops.desktop
+share/applications/kcm_kwindecoration.desktop
+share/applications/kcm_kwinoptions.desktop
+share/applications/kcm_kwinrules.desktop
+share/applications/kcm_kwinscreenedges.desktop
+share/applications/kcm_kwintouchscreen.desktop
+share/applications/kwincompositing.desktop
share/applications/org.kde.kwin_rules_dialog.desktop
share/config.kcfg/kwin.kcfg
share/config.kcfg/kwin_colorcorrect.kcfg
@@ -103,6 +136,7 @@ share/dbus-1/interfaces/org.kde.KWin.xml
share/dbus-1/interfaces/org.kde.kwin.ColorCorrect.xml
share/dbus-1/interfaces/org.kde.kwin.Compositing.xml
share/dbus-1/interfaces/org.kde.kwin.Effects.xml
+share/dbus-1/interfaces/org.kde.kwin.InputDevice.xml
share/dbus-1/interfaces/org.kde.kwin.VirtualKeyboard.xml
%%PORTDOCS%%share/doc/HTML/en/kcontrol/desktop/index.cache.bz2
%%PORTDOCS%%share/doc/HTML/en/kcontrol/desktop/index.docbook
@@ -186,6 +220,7 @@ share/kpackage/kcms/kcm_kwin_effects/contents/ui/Video.qml
share/kpackage/kcms/kcm_kwin_effects/contents/ui/main.qml
share/kpackage/kcms/kcm_kwin_effects/metadata.desktop
share/kpackage/kcms/kcm_kwin_effects/metadata.json
+share/kpackage/kcms/kcm_kwin_scripts/contents/ui/main.qml
share/kpackage/kcms/kcm_kwin_virtualdesktops/contents/ui/main.qml
share/kpackage/kcms/kcm_kwin_virtualdesktops/metadata.desktop
share/kpackage/kcms/kcm_kwin_virtualdesktops/metadata.json
@@ -203,17 +238,8 @@ share/kpackage/kcms/kcm_kwinrules/contents/ui/RulesList.qml
share/kpackage/kcms/kcm_kwinrules/contents/ui/ValueEditor.qml
share/kpackage/kcms/kcm_kwinrules/metadata.desktop
share/kpackage/kcms/kcm_kwinrules/metadata.json
-share/kservices5/kcm_kwin_effects.desktop
-share/kservices5/kcm_kwin_virtualdesktops.desktop
-share/kservices5/kcm_kwinrules.desktop
+share/kservices5/kcm_kwintabbox.desktop
share/kservices5/kwin/kwin4_decoration_qml_plastik.desktop
-share/kservices5/kwincompositing.desktop
-share/kservices5/kwindecoration.desktop
-share/kservices5/kwinoptions.desktop
-share/kservices5/kwinscreenedges.desktop
-share/kservices5/kwinscripts.desktop
-share/kservices5/kwintabbox.desktop
-share/kservices5/kwintouchscreen.desktop
share/kservicetypes5/kwindecoration.desktop
share/kservicetypes5/kwindesktopswitcher.desktop
share/kservicetypes5/kwineffect.desktop
@@ -227,6 +253,7 @@ share/kwin/aurorae/Decoration.qml
share/kwin/aurorae/DecorationButton.qml
share/kwin/aurorae/MenuButton.qml
share/kwin/aurorae/aurorae.qml
+share/kwin/builtin-effects/kwin4_effect_blend/metadata.json
share/kwin/builtin-effects/kwin4_effect_blur/metadata.json
share/kwin/builtin-effects/kwin4_effect_colorpicker/metadata.json
share/kwin/builtin-effects/kwin4_effect_contrast/metadata.json
@@ -329,6 +356,9 @@ share/kwin/effects/kwin4_effect_windowaperture/contents/code/main.js
share/kwin/effects/kwin4_effect_windowaperture/metadata.desktop
share/kwin/effects/kwin4_effect_windowaperture/metadata.json
share/kwin/effects/presentwindows/main.qml
+share/kwin/frames/plasma/frame_none.qml
+share/kwin/frames/plasma/frame_styled.qml
+share/kwin/frames/plasma/frame_unstyled.qml
share/kwin/kcm_kwintabbox/desktop.png
share/kwin/kcm_kwintabbox/dolphin.png
share/kwin/kcm_kwintabbox/kmail.png