aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-07-21 17:18:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-07-21 17:18:03 +0000
commitd1ebca215e497a57a9e276209b9779dc588e6da6 (patch)
tree784325b598433b38f6595dfdfcbbcb6be6956728
parentdca36587efae6670580d4b1299b8dcd099663c89 (diff)
downloadports-d1ebca215e497a57a9e276209b9779dc588e6da6.tar.gz
ports-d1ebca215e497a57a9e276209b9779dc588e6da6.zip
textproc/vacuum: New port: OpenAPI/Swagger linter and quality analysis tool
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/vacuum/Makefile23
-rw-r--r--textproc/vacuum/distinfo5
-rw-r--r--textproc/vacuum/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index d63df9d37664..50431d94ed5a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -2038,6 +2038,7 @@
SUBDIR += urlview
SUBDIR += utf8proc
SUBDIR += uz-aspell
+ SUBDIR += vacuum
SUBDIR += vale
SUBDIR += vbindiff
SUBDIR += ve-hunspell
diff --git a/textproc/vacuum/Makefile b/textproc/vacuum/Makefile
new file mode 100644
index 000000000000..1b39c8242d9d
--- /dev/null
+++ b/textproc/vacuum/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= vacuum
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.6
+CATEGORIES= textproc
+PKGNAMESUFFIX= -lint-tool
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= OpenAPI/Swagger linter and quality analysis tool
+WWW= https://quobix.com/vacuum/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+GO_MODULE= github.com/daveshanley/vacuum
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-test:
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME} lint ${WRKSRC}/model/test_files/petstorev3.json
+
+.include <bsd.port.mk>
diff --git a/textproc/vacuum/distinfo b/textproc/vacuum/distinfo
new file mode 100644
index 000000000000..a7e69bf90f52
--- /dev/null
+++ b/textproc/vacuum/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1689958714
+SHA256 (go/textproc_vacuum/vacuum-v0.2.6/v0.2.6.mod) = f118d3683451a5a80dca6cc1d2e0ce5a3d54d957bfd694a0a6234f062fc75a5c
+SIZE (go/textproc_vacuum/vacuum-v0.2.6/v0.2.6.mod) = 1983
+SHA256 (go/textproc_vacuum/vacuum-v0.2.6/v0.2.6.zip) = 49f9f0a5002a74042fd9c16ec1d8e50994970f1a7d308b0f335ea40338e8ec83
+SIZE (go/textproc_vacuum/vacuum-v0.2.6/v0.2.6.zip) = 1903566
diff --git a/textproc/vacuum/pkg-descr b/textproc/vacuum/pkg-descr
new file mode 100644
index 000000000000..1dcfd88d6e0d
--- /dev/null
+++ b/textproc/vacuum/pkg-descr
@@ -0,0 +1,5 @@
+Vacuum is an OpenAPI & Swagger linter.
+
+vacuum will tell you what is wrong with your spec, why, where and how to fix it.
+It will work at scale and is designed as a CLI (with a UI) and a library to be
+consumed in other applications.