aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-10-01 15:06:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-10-01 15:09:13 +0000
commitd25d388b58d3335a9ef91335aca0a12225999741 (patch)
tree89d61f9ab72202dac2bcb47b0c3600cb12ca2f6c
parentce284868c83ccadde1723ca613af2fcad2671116 (diff)
downloadports-d25d388b58d3335a9ef91335aca0a12225999741.tar.gz
ports-d25d388b58d3335a9ef91335aca0a12225999741.zip
biology/hhsuite: fix build on armv7
PR: 266736 (cherry picked from commit 75d814716539317715472ded1bb11b3c6ccb72bc)
-rw-r--r--biology/hhsuite/Makefile2
-rw-r--r--biology/hhsuite/files/patch-lib_simde_simde_x86_sse2.h11
2 files changed, 11 insertions, 2 deletions
diff --git a/biology/hhsuite/Makefile b/biology/hhsuite/Makefile
index 7686f86e7278..60e0fcb6ad66 100644
--- a/biology/hhsuite/Makefile
+++ b/biology/hhsuite/Makefile
@@ -11,8 +11,6 @@ WWW= https://github.com/soedinglab/hh-suite
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_armv7= compilation fails: no member named 'neon_f64' in 'simde__m128d_private', see https://github.com/soedinglab/hh-suite/issues/322
-
LIB_DEPENDS= libmpi.so:net/openmpi
USES= compiler:c++11-lang cmake perl5 python shebangfix
diff --git a/biology/hhsuite/files/patch-lib_simde_simde_x86_sse2.h b/biology/hhsuite/files/patch-lib_simde_simde_x86_sse2.h
new file mode 100644
index 000000000000..898d98065043
--- /dev/null
+++ b/biology/hhsuite/files/patch-lib_simde_simde_x86_sse2.h
@@ -0,0 +1,11 @@
+--- lib/simde/simde/x86/sse2.h.orig 2022-10-01 09:24:35 UTC
++++ lib/simde/simde/x86/sse2.h
+@@ -6591,7 +6591,7 @@ simde_x_mm_negate_pd(simde__m128d a) {
+
+ #if defined(SIMDE_POWER_ALTIVEC_P9_NATIVE)
+ r_.altivec_f64 = vec_neg(a_.altivec_f64);
+- #elif defined(SIMDE_ARM_NEON_A32V7_NATIVE)
++ #elif defined(SIMDE_ARM_NEON_A64V8_NATIVE)
+ r_.neon_f64 = vnegq_f64(a_.neon_f64);
+ #elif defined(SIMDE_WASM_SIMD128d_NATIVE)
+ r_.wasm_v128d = wasm_f64x2_neg(a_.wasm_v128d);