aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-08-31 14:35:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-08-31 14:38:09 +0000
commitd278243809bfa2de43adb6d398113e5e8c8c4cd1 (patch)
tree3c20a8f92e668d21fdd583f02758ead819e0f536
parent12fb56ac24aeeb8c255dc652b7b7bd10e827a551 (diff)
downloadports-d278243809bfa2de43adb6d398113e5e8c8c4cd1.tar.gz
ports-d278243809bfa2de43adb6d398113e5e8c8c4cd1.zip
shells/zsh: remove the MEM option
Remove the option allowing to use zsh memory allocator, it is only useful for zsh developers who won't use the port anyway. PR: 259997
-rw-r--r--shells/zsh/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/shells/zsh/Makefile b/shells/zsh/Makefile
index e38568d9cbda..a20769d651f7 100644
--- a/shells/zsh/Makefile
+++ b/shells/zsh/Makefile
@@ -1,5 +1,6 @@
PORTNAME= zsh
DISTVERSION= 5.9
+PORTREVISION= 1
CATEGORIES= shells
MASTER_SITES= https://www.zsh.org/pub/ \
SF \
@@ -44,13 +45,12 @@ CPPFLAGS+= -DBOOL_DEFINED
LDFLAGS+= -Wl,--as-needed
TEST_TARGET= test
-OPTIONS_DEFINE= DEBUG ETCDIR GDBM MEM PCRE STATIC \
+OPTIONS_DEFINE= DEBUG ETCDIR GDBM PCRE STATIC \
DOCS EXAMPLES
OPTIONS_SUB= yes
ETCDIR_DESC= System-wide defaults in /etc (instead of $${PREFIX}/etc)
GDBM_DESC= Enable GDBM support (GPL)
-MEM_DESC= Enable zsh-mem options
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
@@ -58,7 +58,6 @@ PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
DEBUG_CONFIGURE_ENABLE= zsh-debug
ETCDIR_CONFIGURE_OFF= --enable-etcdir=${PREFIX}/etc
GDBM_CONFIGURE_ENABLE= gdbm
-MEM_CONFIGURE_ENABLE= zsh-mem
PCRE_CONFIGURE_ENABLE= pcre
## Some modules can only be built as a shared library.