aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-03-28 11:56:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-03-28 11:56:32 +0000
commitd2922f372dba77e182b9b4ee7a8fb48b0849349c (patch)
tree21e6e5fe1529a1466cfde2f635f7d25419b46c4a
parent4cc765aeead24fa70eefef117dad722d415cf7dd (diff)
downloadports-d2922f372dba77e182b9b4ee7a8fb48b0849349c.tar.gz
ports-d2922f372dba77e182b9b4ee7a8fb48b0849349c.zip
- Fix after objformat removal
Reported by: pointyhat
Notes
Notes: svn path=/head/; revision=188660
-rw-r--r--audio/gtkgep/Makefile3
-rw-r--r--audio/gtkgep/pkg-plist1
-rw-r--r--graphics/enfle/Makefile1
-rw-r--r--math/lapack++/Makefile4
-rw-r--r--math/lapack++/pkg-plist1
-rw-r--r--textproc/libtranslate/Makefile5
-rw-r--r--www/flashplugin-mozilla/Makefile1
-rw-r--r--x11-themes/buffy/Makefile1
-rw-r--r--x11-themes/clean-theme-gtk/Makefile1
-rw-r--r--x11-themes/engradient/Makefile1
-rw-r--r--x11-themes/gtk-Mac2-theme/Makefile1
-rw-r--r--x11-themes/gtk-flat-theme/Makefile1
-rw-r--r--x11-themes/gtk-qn-x11-theme/Makefile3
-rw-r--r--x11-themes/gtk-zenith-theme/Makefile3
-rw-r--r--x11-themes/gtkbe/Makefile1
-rw-r--r--x11-themes/gtkstep-pastel/Makefile1
-rw-r--r--x11-themes/gtkstep/Makefile1
-rw-r--r--x11-themes/icegradient/Makefile1
18 files changed, 27 insertions, 4 deletions
diff --git a/audio/gtkgep/Makefile b/audio/gtkgep/Makefile
index 6930fc03e4f1..9c5ff3e8810c 100644
--- a/audio/gtkgep/Makefile
+++ b/audio/gtkgep/Makefile
@@ -20,4 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -fPIC" LDFLAGS="${PTHREAD_LIBS}"
PLIST_SUB= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/audio/gtkgep/pkg-plist b/audio/gtkgep/pkg-plist
index 7cc7c6bd0a8b..fe58dd3c851a 100644
--- a/audio/gtkgep/pkg-plist
+++ b/audio/gtkgep/pkg-plist
@@ -30,7 +30,6 @@ lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/lowpass4.so
lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/ngexp.la
lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/ngexp.so
lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/noisegate.la
-lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/noisegate.la
lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/noisegate.so
lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/overdrive.la
lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/overdrive.so
diff --git a/graphics/enfle/Makefile b/graphics/enfle/Makefile
index 2fad31191c08..c21dd21c248a 100644
--- a/graphics/enfle/Makefile
+++ b/graphics/enfle/Makefile
@@ -36,6 +36,7 @@ MAN1= enfle.1
post-patch:
${PERL} -pi -e 's/^(.*_la_LDFLAGS = -module)$$/\1 -avoid-version/' \
${WRKSRC}/plugins/*/*/Makefile.in
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
post-install:
${INSTALL_MAN} ${WRKSRC}/enfle.1 ${PREFIX}/man/man1
diff --git a/math/lapack++/Makefile b/math/lapack++/Makefile
index f65d4e0d0a06..1db81413b2cf 100644
--- a/math/lapack++/Makefile
+++ b/math/lapack++/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lapack++
PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://math.nist.gov/lapack++/:doc
@@ -40,7 +40,7 @@ BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
FC= gfortran42
F77= gfortran42
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
.if defined(WITH_ATLAS)
BLAS_LIB= -L${LOCALBASE}/lib -lf77blas -latlas
diff --git a/math/lapack++/pkg-plist b/math/lapack++/pkg-plist
index a923534efddc..8e0bdc2581de 100644
--- a/math/lapack++/pkg-plist
+++ b/math/lapack++/pkg-plist
@@ -59,6 +59,7 @@ include/lapackpp/vd.h
include/lapackpp/vf.h
include/lapackpp/vi.h
include/lapackpp/vli.h
+lib/liblapackpp.a
lib/liblapackpp.la
lib/liblapackpp.so
lib/liblapackpp.so.15
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
index 22c54068f0f5..5cfec483ebef 100644
--- a/textproc/libtranslate/Makefile
+++ b/textproc/libtranslate/Makefile
@@ -19,7 +19,7 @@ USE_GETOPT_LONG= yes
USE_GNOME= glib20 gnomehack intlhack
GNU_CONFIGURE= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
@@ -50,4 +50,7 @@ PLIST_SUB+= TALKFILTERS=""
LIB_DEPENDS+= talkfilters:${PORTSDIR}/misc/talkfilters
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/www/flashplugin-mozilla/Makefile b/www/flashplugin-mozilla/Makefile
index 9ea29fed3286..f7de2a01120c 100644
--- a/www/flashplugin-mozilla/Makefile
+++ b/www/flashplugin-mozilla/Makefile
@@ -34,5 +34,6 @@ post-patch:
-e "s/libnpflash.so.0.0.0/libnpflash.so.0/" \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' ${WRKSRC}/npapi.h
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${CONFIGURE_WRKSRC}/configure ${CONFIGURE_WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/buffy/Makefile b/x11-themes/buffy/Makefile
index b242c298d6c2..f4c095feab5b 100644
--- a/x11-themes/buffy/Makefile
+++ b/x11-themes/buffy/Makefile
@@ -25,5 +25,6 @@ GNU_CONFIGURE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/clean-theme-gtk/Makefile b/x11-themes/clean-theme-gtk/Makefile
index d4c2c4aabb0e..c484be97c62e 100644
--- a/x11-themes/clean-theme-gtk/Makefile
+++ b/x11-themes/clean-theme-gtk/Makefile
@@ -25,5 +25,6 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/engradient/Makefile b/x11-themes/engradient/Makefile
index dd10e598c24c..872f84c52531 100644
--- a/x11-themes/engradient/Makefile
+++ b/x11-themes/engradient/Makefile
@@ -25,5 +25,6 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-Mac2-theme/Makefile b/x11-themes/gtk-Mac2-theme/Makefile
index 0f2ea4a30068..b482559f6b33 100644
--- a/x11-themes/gtk-Mac2-theme/Makefile
+++ b/x11-themes/gtk-Mac2-theme/Makefile
@@ -25,5 +25,6 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-flat-theme/Makefile b/x11-themes/gtk-flat-theme/Makefile
index 0930fa1679af..6bee43108c90 100644
--- a/x11-themes/gtk-flat-theme/Makefile
+++ b/x11-themes/gtk-flat-theme/Makefile
@@ -25,5 +25,6 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-qn-x11-theme/Makefile b/x11-themes/gtk-qn-x11-theme/Makefile
index 1781b685fe85..9174178b8398 100644
--- a/x11-themes/gtk-qn-x11-theme/Makefile
+++ b/x11-themes/gtk-qn-x11-theme/Makefile
@@ -22,4 +22,7 @@ USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_GMAKE= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-zenith-theme/Makefile b/x11-themes/gtk-zenith-theme/Makefile
index dc9e23887828..d05a9a6313ab 100644
--- a/x11-themes/gtk-zenith-theme/Makefile
+++ b/x11-themes/gtk-zenith-theme/Makefile
@@ -22,4 +22,7 @@ USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_GMAKE= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.mk>
diff --git a/x11-themes/gtkbe/Makefile b/x11-themes/gtkbe/Makefile
index 0fd4cff21b81..cd53928995e9 100644
--- a/x11-themes/gtkbe/Makefile
+++ b/x11-themes/gtkbe/Makefile
@@ -25,5 +25,6 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/gtkstep-pastel/Makefile b/x11-themes/gtkstep-pastel/Makefile
index b654c729737a..c2d2f2a26915 100644
--- a/x11-themes/gtkstep-pastel/Makefile
+++ b/x11-themes/gtkstep-pastel/Makefile
@@ -24,5 +24,6 @@ GNU_CONFIGURE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/gtkstep/Makefile b/x11-themes/gtkstep/Makefile
index 1ecdabee66bf..9134f615862b 100644
--- a/x11-themes/gtkstep/Makefile
+++ b/x11-themes/gtkstep/Makefile
@@ -24,5 +24,6 @@ GNU_CONFIGURE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>
diff --git a/x11-themes/icegradient/Makefile b/x11-themes/icegradient/Makefile
index 017adaa57c9f..263319a993c9 100644
--- a/x11-themes/icegradient/Makefile
+++ b/x11-themes/icegradient/Makefile
@@ -26,5 +26,6 @@ USE_GMAKE= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
.include <bsd.port.mk>