aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-11-13 15:51:32 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-11-13 15:51:32 +0000
commitd2a04c48871a07d4e335f293fa6bf1e2122bd6c2 (patch)
treeb8c7a3c8b54724d0d1c574be959323e0da8c6030
parent8d7c6ae83f008303bb62bb62b3d10386cee9036d (diff)
downloadports-d2a04c48871a07d4e335f293fa6bf1e2122bd6c2.tar.gz
ports-d2a04c48871a07d4e335f293fa6bf1e2122bd6c2.zip
Support the GKRELLM_SERVER_ONLY option to allow server-only installation.
Bump PORTREVISION due to changed file locations. PR: ports/82200, see also ports/82197 Submitted by: Jonathan Noack <noackjr@alumni.rice.edu> Approved by: david@pinko.net (maintainer, timeout 4 months)
Notes
Notes: svn path=/head/; revision=148115
-rw-r--r--sysutils/gkrelltop/Makefile27
-rw-r--r--sysutils/gkrelltop/files/patch-Makefile8
-rw-r--r--sysutils/gkrelltop/pkg-plist3
3 files changed, 26 insertions, 12 deletions
diff --git a/sysutils/gkrelltop/Makefile b/sysutils/gkrelltop/Makefile
index e551e4870962..f67bac3d8677 100644
--- a/sysutils/gkrelltop/Makefile
+++ b/sysutils/gkrelltop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gkrelltop
PORTVERSION= 2.2.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= sysutils
MASTER_SITES= http://psychology.rutgers.edu/~zaimi/html/gkrelltop/
DISTNAME= ${PORTNAME}_2.2-6
@@ -15,17 +15,28 @@ DISTNAME= ${PORTNAME}_2.2-6
MAINTAINER= david@pinko.net
COMMENT= Plugin for gkrellm 2.x shows top three processes, requires procfs
-RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-BUILD_DEPENDS= ${X11BASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
+RUN_DEPENDS= gkrellmd:${PORTSDIR}/sysutils/gkrellm2
+BUILD_DEPENDS= ${RUN_DEPENDS}
+USE_REINPLACE= yes
USE_GMAKE= yes
-MAKE_ARGS= INSTALLDIR=${PREFIX}/libexec/gkrellm2/plugins \
- INSTALLDIRD=${PREFIX}/libexec/gkrellm2/plugins
-USE_X_PREFIX= yes
+MAKE_ARGS= INSTALLDIR=${X11BASE}/libexec/gkrellm2/plugins \
+ INSTALLDIRD=${PREFIX}/libexec/gkrellm2/plugins-gkrellmd
+
+.if defined(GKRELLM_SERVER_ONLY)
+ALL_TARGET= server
+INSTALL_TARGET= install-server
+PLIST_SUB+= CLIENT="@comment "
+.else
+PLIST_SUB+= CLIENT=""
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PLIST_FILES= libexec/gkrellm2/plugins/gkrelltop.so \
- libexec/gkrellm2/plugins/gkrelltopd.so
+post-patch:
+.if defined(GKRELLM_SERVER_ONLY)
+ ${REINPLACE_CMD} 's/^\(PKG.*\)gkrellm/\1gkrellmd/' ${WRKSRC}/configure
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/sysutils/gkrelltop/files/patch-Makefile b/sysutils/gkrelltop/files/patch-Makefile
index 1347c3498fb1..9fdb4987f4bd 100644
--- a/sysutils/gkrelltop/files/patch-Makefile
+++ b/sysutils/gkrelltop/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Dec 11 12:50:39 2004
-+++ Makefile Sat Dec 25 23:35:53 2004
+--- Makefile.orig Fri Dec 10 19:50:39 2004
++++ Makefile Mon Jun 13 08:29:12 2005
@@ -28,9 +28,9 @@
OSFLAG = `uname | tr '[:lower:]' '[:upper:]'`
SHELL=/bin/sh
@@ -17,12 +17,12 @@
ifeq ($(WANT_GLIB12),yes)
-CFLAGSD = -I/usr/X11R6/include -D$(OSFLAG) -fPIC -Wall `glib-config --cflags`
-+CFLAGSD = -I${X11BASE}/include -D$(OSFLAG) -fPIC -Wall `glib-config --cflags`
++CFLAGSD = -I${PREFIX}/include -D$(OSFLAG) -fPIC -Wall `glib-config --cflags`
LIBSD = `glib-config --libs`
CONFIGURE_ARGS += --with-glib12
else
-CFLAGSD = -D$(OSFLAG) -fPIC -Wall `pkg-config glib-2.0 --cflags`
-+CFLAGSD = -D$(OSFLAG) -I${X11BASE}/include -fPIC -Wall `pkg-config glib-2.0 --cflags`
++CFLAGSD = -D$(OSFLAG) -I${PREFIX}/include -fPIC -Wall `pkg-config glib-2.0 --cflags`
LIBSD = `pkg-config glib-2.0 --libs`
endif
INSTALLDIRD=$(HOME)/.gkrellm2/plugins-gkrellmd
diff --git a/sysutils/gkrelltop/pkg-plist b/sysutils/gkrelltop/pkg-plist
new file mode 100644
index 000000000000..29b15244dabf
--- /dev/null
+++ b/sysutils/gkrelltop/pkg-plist
@@ -0,0 +1,3 @@
+libexec/gkrellm2/plugins-gkrellmd/gkrelltopd.so
+%%CLIENT%%@cwd %%X11BASE%%
+%%CLIENT%%libexec/gkrellm2/plugins/gkrelltop.so