aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-12-01 15:33:37 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-12-01 18:42:20 +0000
commitd2b903d861f299813cdc9cc44933f4f710ee8d8d (patch)
treec96638a1ba4703206978f0c9c3b096373f5722a2
parent5990b1a2eb44425a59d6b1a5e54f91aa618a3ccf (diff)
downloadports-d2b903d861f299813cdc9cc44933f4f710ee8d8d.tar.gz
ports-d2b903d861f299813cdc9cc44933f4f710ee8d8d.zip
security/openfhe: Add options HEXL and NTL
-rw-r--r--security/openfhe/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/security/openfhe/Makefile b/security/openfhe/Makefile
index 37705157fb7a..f478a54f7a7b 100644
--- a/security/openfhe/Makefile
+++ b/security/openfhe/Makefile
@@ -1,6 +1,7 @@
PORTNAME= openfhe
DISTVERSIONPREFIX= v
DISTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= security math
MAINTAINER= yuri@FreeBSD.org
@@ -29,4 +30,16 @@ CMAKE_TESTING_TARGET= testall
BINARY_ALIAS= git=false
+OPTIONS_DEFINE= HEXL NTL
+OPTIONS_DEFAULT= NTL
+
+HEXL_DESC= Buld with Intel hexl
+HEXL_CMAKE_BOOL= WITH_INTEL_HEXL
+HEXL_BROKEN= Fails to find hexl package and no hexl submodule
+
+NTL_DESC= Build with libntl
+NTL_CMAKE_BOOL= WITH_NTL
+NTL_LIB_DEPENDS= libgmp.so:math/gmp \
+ libntl.so:math/ntl
+
.include <bsd.port.mk>