aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-15 21:09:31 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-10-15 21:12:59 +0000
commitd2d578c63e18f76ed99f6636a67dee23a5e013a3 (patch)
tree9114a98c3da23e42b86927863783df89295c1dc5
parent0a2daccb24b2a6bc46fdb1691c65fc2d66f4b256 (diff)
downloadports-d2d578c63e18f76ed99f6636a67dee23a5e013a3.tar.gz
ports-d2d578c63e18f76ed99f6636a67dee23a5e013a3.zip
security/vault: Add missing Web UI
PR: 272617 Reported by: bd@dbconn.net
-rw-r--r--security/vault/Makefile27
-rw-r--r--security/vault/distinfo4
2 files changed, 27 insertions, 4 deletions
diff --git a/security/vault/Makefile b/security/vault/Makefile
index ef3f68f07078..fd1932e6f8c2 100644
--- a/security/vault/Makefile
+++ b/security/vault/Makefile
@@ -1,15 +1,17 @@
PORTNAME= vault
PORTVERSION= 1.14.0
-PORTREVISION= 3
+PORTREVISION= 4
DISTVERSIONPREFIX= v
CATEGORIES= security
-MASTER_SITES= https://raw.githubusercontent.com/hashicorp/vault/${DISTVERSIONFULL}/
+MASTER_SITES= https://raw.githubusercontent.com/hashicorp/vault/${DISTVERSIONFULL}/ \
+ LOCAL/bofh/security/${PORTNAME}/:web_ui
DISTFILES= go.mod \
api/go.mod \
api/auth/approle/go.mod \
api/auth/kubernetes/go.mod \
api/auth/userpass/go.mod \
- sdk/go.mod
+ sdk/go.mod \
+ ${PORTNAME}-web_ui-${DISTVERSION}${EXTRACT_SUFX}:web_ui
MAINTAINER= bofh@FreeBSD.org
COMMENT= Tool for securely accessing secrets
@@ -18,6 +20,11 @@ WWW= https://vaultproject.io/
LICENSE= MPL20
LICENSE_FILE= ${WRKSRC}/LICENSE
+.if defined(MAINTAINER_MODE)
+EXTRACT_DEPENDS=npm-node18>0:www/npm-node18 \
+ yarn-node18>0:www/yarn-node18
+.endif
+
USES= cpe go:modules
CPE_VENDOR= hashicorp
USE_GITHUB= yes
@@ -46,4 +53,18 @@ SOURCE_DATE_EPOCH_CMD= date -ur \
$$(${GREP} -m1 TIMESTAMP ${DISTINFO_FILE} | ${SED} -e 's/[^0-9]//g') \
'+%Y-%m-%dT%H:%M:%SZ'
+post-patch:
+ ${CP} -Rf ${WRKDIR}/web_ui ${WRKSRC}/http/
+
+.if defined(MAINTAINER_MODE)
+_make-web_ui: extract
+ cd ${WRKSRC}/ui && ${SETENV} ${MAKE_ENV} yarn
+ cd ${WRKSRC}/ui && ${SETENV} ${MAKE_ENV} npm rebuild node-sass
+ cd ${WRKSRC}/ui && ${SETENV} ${MAKE_ENV} yarn run build
+ cd ${WRKDIR} && ${TAR} -czf \
+ ${PORTNAME}-web_ui-${DISTVERSION}${EXTRACT_SUFX} -C ${WRKSRC}/http web_ui
+ scp ${WRKDIR}/${PORTNAME}-web_ui-${DISTVERSION}${EXTRACT_SUFX} \
+ bofh@freefall.freebsd.org:public_distfiles/security/${PORTNAME}/
+.endif
+
.include <bsd.port.post.mk>
diff --git a/security/vault/distinfo b/security/vault/distinfo
index 803ae8802ca2..1701842d6bc0 100644
--- a/security/vault/distinfo
+++ b/security/vault/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1688100641
+TIMESTAMP = 1697381170
SHA256 (go/security_vault/hashicorp-vault-v1.14.0_GH0/go.mod) = 95341cf91029519fbefe7ffd6deca16e4e8b66c5161dcb2702857d5e8bb86c62
SIZE (go/security_vault/hashicorp-vault-v1.14.0_GH0/go.mod) = 26115
SHA256 (go/security_vault/hashicorp-vault-v1.14.0_GH0/api/go.mod) = ed6f55c24bcb000178b01e54a80e175bc4d7266f3c6c4933a852f9f629c91e76
@@ -11,5 +11,7 @@ SHA256 (go/security_vault/hashicorp-vault-v1.14.0_GH0/api/auth/userpass/go.mod)
SIZE (go/security_vault/hashicorp-vault-v1.14.0_GH0/api/auth/userpass/go.mod) = 108
SHA256 (go/security_vault/hashicorp-vault-v1.14.0_GH0/sdk/go.mod) = f712cb4478cf99ce40d2edb3c2c30ac05179373b7cf8e6b6a917c65506d9db27
SIZE (go/security_vault/hashicorp-vault-v1.14.0_GH0/sdk/go.mod) = 4153
+SHA256 (go/security_vault/hashicorp-vault-v1.14.0_GH0/vault-web_ui-1.14.0.tar.gz) = edfe47e08484831a685058570207d183eaf5aa6aa043fb414a1fddc6bf08e395
+SIZE (go/security_vault/hashicorp-vault-v1.14.0_GH0/vault-web_ui-1.14.0.tar.gz) = 2118920
SHA256 (go/security_vault/hashicorp-vault-v1.14.0_GH0/hashicorp-vault-v1.14.0_GH0.tar.gz) = 0fad3903be0573312447e7250adc192e920cead1fb5d4dc4cca6c79c385907eb
SIZE (go/security_vault/hashicorp-vault-v1.14.0_GH0/hashicorp-vault-v1.14.0_GH0.tar.gz) = 30824651