aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-10 11:41:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-02-10 11:41:30 +0000
commitd36a4f46118fc600d7d989d0b5db2aae2a06f65c (patch)
tree30d38aaa05133efc51f510e508f955f8be5d8b6a
parent523bb16432aa57536536ba0ac54687718e011e02 (diff)
downloadports-d36a4f46118fc600d7d989d0b5db2aae2a06f65c.tar.gz
ports-d36a4f46118fc600d7d989d0b5db2aae2a06f65c.zip
devel/edi: EFL-based/focused IDE (new port had been added)
Requested by: someone on t.me/freebsd_ru
-rw-r--r--devel/Makefile1
-rw-r--r--devel/edi/Makefile33
-rw-r--r--devel/edi/distinfo3
-rw-r--r--devel/edi/files/patch-meson.build31
-rw-r--r--devel/edi/pkg-descr4
-rw-r--r--devel/edi/pkg-plist58
6 files changed, 130 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c5a6fedc8921..e8c3880b4e18 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -577,6 +577,7 @@
SUBDIR += easyloggingpp
SUBDIR += ebnf2yacc
SUBDIR += ecgi
+ SUBDIR += edi
SUBDIR += editline
SUBDIR += efivar
SUBDIR += efl
diff --git a/devel/edi/Makefile b/devel/edi/Makefile
new file mode 100644
index 000000000000..53b2f1e4c004
--- /dev/null
+++ b/devel/edi/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= edi
+PORTVERSION= 0.8.0
+CATEGORIES= devel enlightenment
+MASTER_SITES= https://github.com/Enlightenment/edi/releases/download/v${PORTVERSION}/ # http://download.enlightenment.org/rel/apps/${PORTNAME}/
+DIST_SUBDIR= enlightenment
+
+MAINTAINER= enlightenment@FreeBSD.org
+COMMENT= EFL-based/focused IDE
+WWW= https://phab.enlightenment.org/w/projects/edi/
+
+LIB_DEPENDS= libelementary.so:devel/efl
+
+USES= desktop-file-utils gettext meson pkgconfig tar:xz
+MESON_ARGS= -Dlibclang=false
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS NEWS TODO
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e '/input : join_paths/d' \
+ ${WRKSRC}/data/extra/templates/meson.build
+# XXX: should probably use get_option('mandir') below
+ @${REINPLACE_CMD} -e '/install_dir/s,doc/edi,man/man1,' \
+ ${WRKSRC}/doc/meson.build
+ @${REINPLACE_CMD} -e '/tests/d' ${WRKSRC}/src/meson.build
+ @${ECHO_CMD} "option('docsdir', type : 'string'," \
+ "value : '${DOCSDIR_REL}')" >> ${WRKSRC}/meson_options.txt
+ @${ECHO_CMD} "option('localbase', type : 'string'," \
+ "value : '${LOCALBASE}')" >> ${WRKSRC}/meson_options.txt
+
+.include <bsd.port.mk>
diff --git a/devel/edi/distinfo b/devel/edi/distinfo
new file mode 100644
index 000000000000..11207ec7a100
--- /dev/null
+++ b/devel/edi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1638861412
+SHA256 (enlightenment/edi-0.8.0.tar.xz) = 6a34c6f5afa45589c1836f796880d64b37686a1975cd369ebf467191d17d6806
+SIZE (enlightenment/edi-0.8.0.tar.xz) = 797996
diff --git a/devel/edi/files/patch-meson.build b/devel/edi/files/patch-meson.build
new file mode 100644
index 000000000000..c31465fe4f60
--- /dev/null
+++ b/devel/edi/files/patch-meson.build
@@ -0,0 +1,31 @@
+--- meson.build.orig 2020-04-29 13:40:58 UTC
++++ meson.build
+@@ -19,7 +19,7 @@ config_h.set_quoted('PACKAGE_BUILD_DIR', meson.build_r
+ config_h.set_quoted('PACKAGE_BIN_DIR', join_paths(get_option('prefix'), get_option('bindir')))
+ config_h.set_quoted('PACKAGE_LIB_DIR', join_paths(get_option('prefix'), get_option('libdir')))
+ config_h.set_quoted('PACKAGE_DATA_DIR', join_paths(get_option('prefix'), get_option('datadir'), 'edi'))
+-config_h.set_quoted('PACKAGE_DOC_DIR', join_paths(get_option('prefix'), get_option('infodir'), 'edi'))
++config_h.set_quoted('PACKAGE_DOC_DIR', join_paths(get_option('prefix'), get_option('docsdir')))
+
+ config_h.set_quoted('EFL_BETA_API_SUPPORT' , '1')
+
+@@ -37,7 +37,7 @@ cc = meson.get_compiler('c')
+
+ config_h.set_quoted('EFL_CFLAGS', run_command(find_program('pkg-config'), '--libs', '--cflags', 'elementary').stdout().strip())
+
+-intl = cc.find_library('intl', required : false)
++intl = cc.find_library('intl', required : false, dirs : join_paths(get_option('localbase'), 'lib'))
+
+ bear = find_program('bear', required : false)
+ if get_option('bear') == true and bear.found()
+@@ -94,8 +94,8 @@ subdir('src')
+ subdir('doc')
+ subdir('data')
+
+-install_data(['AUTHORS'],
+- install_dir : join_paths(get_option('prefix'), get_option('infodir'), 'edi')
++install_data(['AUTHORS', 'NEWS', 'TODO'],
++ install_dir : join_paths(get_option('prefix'), get_option('docsdir'))
+ )
+
+ configure_file(
diff --git a/devel/edi/pkg-descr b/devel/edi/pkg-descr
new file mode 100644
index 000000000000..8abe5b4f9fae
--- /dev/null
+++ b/devel/edi/pkg-descr
@@ -0,0 +1,4 @@
+This is a project to create a complete IDE using the EFL (Enlightenment
+Foundation Libraries). It aims to lower the barrier to getting involved
+in Enlightenment development and in creating applications based on the
+EFL suite, but can also be used as an advanced, standalone text editor.
diff --git a/devel/edi/pkg-plist b/devel/edi/pkg-plist
new file mode 100644
index 000000000000..c94b57ac331b
--- /dev/null
+++ b/devel/edi/pkg-plist
@@ -0,0 +1,58 @@
+bin/edi
+bin/edi_build
+bin/edi_scm
+lib/libedi.so
+lib/libedi.so.0
+lib/libedi.so.0.8.0
+share/applications/edi.desktop
+%%DATADIR%%/examples/examples.edj
+%%DATADIR%%/icons/application-exit.png
+%%DATADIR%%/icons/applications-electronics.png
+%%DATADIR%%/icons/dialog-error.png
+%%DATADIR%%/icons/dialog-information.png
+%%DATADIR%%/icons/dialog-question.png
+%%DATADIR%%/icons/document-new.png
+%%DATADIR%%/icons/document-save-as.png
+%%DATADIR%%/icons/document-save.png
+%%DATADIR%%/icons/edit-clear.png
+%%DATADIR%%/icons/edit-copy.png
+%%DATADIR%%/icons/edit-cut.png
+%%DATADIR%%/icons/edit-delete.png
+%%DATADIR%%/icons/edit-find-replace.png
+%%DATADIR%%/icons/edit-find.png
+%%DATADIR%%/icons/edit-paste.png
+%%DATADIR%%/icons/edit-redo.png
+%%DATADIR%%/icons/edit-undo.png
+%%DATADIR%%/icons/empty.png
+%%DATADIR%%/icons/folder-new.png
+%%DATADIR%%/icons/folder.png
+%%DATADIR%%/icons/go-down.png
+%%DATADIR%%/icons/go-home.png
+%%DATADIR%%/icons/go-jump.png
+%%DATADIR%%/icons/go-up.png
+%%DATADIR%%/icons/help-about.png
+%%DATADIR%%/icons/image-x-generic.png
+%%DATADIR%%/icons/mail-send.png
+%%DATADIR%%/icons/media-playback-start.png
+%%DATADIR%%/icons/media-playback-stop.png
+%%DATADIR%%/icons/media-record.png
+%%DATADIR%%/icons/network-server.png
+%%DATADIR%%/icons/object-flip-horizontal.png
+%%DATADIR%%/icons/object-flip-vertical.png
+%%DATADIR%%/icons/preferences-desktop.png
+%%DATADIR%%/icons/system-run.png
+%%DATADIR%%/icons/text-x-csrc.png
+%%DATADIR%%/icons/text-x-generic.png
+%%DATADIR%%/icons/utilities-terminal.png
+%%DATADIR%%/icons/window-close.png
+%%DATADIR%%/icons/window-new.png
+%%DATADIR%%/images/about.png
+%%DATADIR%%/images/welcome.png
+%%DATADIR%%/templates/eflproject.tar.gz
+%%DATADIR%%/templates/eflproject_python.tar.gz
+%%DATADIR%%/templates/templates.edj
+%%DATADIR%%/themes/solarized.edj
+%%DATADIR%%/themes/solarized_dark.edj
+%%DATADIR%%/themes/white.edj
+share/icons/hicolor/256x256/apps/edi.png
+share/man/man1/edi.1.gz