aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-27 15:28:01 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-27 15:28:01 +0000
commitd37916f24e922667cec9a18cf135042b77007253 (patch)
tree205210085bfa9b62ff32d8055d34610365d915eb
parent4f924cb3b42d3df97f9603ab735e63826f287811 (diff)
downloadports-d37916f24e922667cec9a18cf135042b77007253.tar.gz
ports-d37916f24e922667cec9a18cf135042b77007253.zip
graphics/py-python-barcode: Add py-python-barcode 0.14.0
python-barcode provides a simple way to create barcodes in Python. There are no external dependencies when generating SVG files. Pillow is required for generating images (e.g.: PNGs).
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-python-barcode/Makefile27
-rw-r--r--graphics/py-python-barcode/distinfo3
-rw-r--r--graphics/py-python-barcode/pkg-descr4
4 files changed, 35 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 326a4c184b92..553cd3f80113 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -934,6 +934,7 @@
SUBDIR += py-pyqtgraph
SUBDIR += py-pyrsgis
SUBDIR += py-pytesseract
+ SUBDIR += py-python-barcode
SUBDIR += py-python-poppler-qt5
SUBDIR += py-pyvips
SUBDIR += py-pyvista
diff --git a/graphics/py-python-barcode/Makefile b/graphics/py-python-barcode/Makefile
new file mode 100644
index 000000000000..238dd795b250
--- /dev/null
+++ b/graphics/py-python-barcode/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= python-barcode
+PORTVERSION= 0.14.0
+CATEGORIES= graphics python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Create standard barcodes with Python
+WWW= https://github.com/WhyNotHugo/python-barcode
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= IMAGES
+OPTIONS_DEFAULT=IMAGES
+IMAGES_DESC= Generate images
+
+IMAGES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/graphics/py-python-barcode/distinfo b/graphics/py-python-barcode/distinfo
new file mode 100644
index 000000000000..56edb36e21c8
--- /dev/null
+++ b/graphics/py-python-barcode/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1682354450
+SHA256 (python-barcode-0.14.0.tar.gz) = 241b34aa5c5cb6a9889882f9409b0182903a2c5d19b4218be3609cdbbd5ffdf9
+SIZE (python-barcode-0.14.0.tar.gz) = 228128
diff --git a/graphics/py-python-barcode/pkg-descr b/graphics/py-python-barcode/pkg-descr
new file mode 100644
index 000000000000..cc8b12391c9f
--- /dev/null
+++ b/graphics/py-python-barcode/pkg-descr
@@ -0,0 +1,4 @@
+python-barcode provides a simple way to create barcodes in Python.
+
+There are no external dependencies when generating SVG files. Pillow is required
+for generating images (e.g.: PNGs).