aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-30 19:24:37 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-04-30 22:38:43 +0000
commitd3a34476994f4b5c0cf24408e8963aa901e477c6 (patch)
tree83db03eaf2f61b4843db461beaf531b7902a3873
parentdae915d003e3ee6f12a58f0131825e3c4673ec40 (diff)
downloadports-d3a34476994f4b5c0cf24408e8963aa901e477c6.tar.gz
ports-d3a34476994f4b5c0cf24408e8963aa901e477c6.zip
devel/ptlib: Mark BROKEN_SSL
- Requires OpenSSL deprecated BIO_s_file_internal - Upstream has more recent versions from SF/opalvoip which might support more recent versions of OpenSSL - Fix pre-configure from my previous commit Approved by: portmgr (blanket)
-rw-r--r--devel/ptlib/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/ptlib/Makefile b/devel/ptlib/Makefile
index e79dd4a71cfb..4c77352c6a9a 100644
--- a/devel/ptlib/Makefile
+++ b/devel/ptlib/Makefile
@@ -14,6 +14,8 @@ LIB_DEPENDS= libexpat.so:textproc/expat2
USES= autoreconf:build bison:wrapper compiler:c11 gmake localbase:ldflags \
pathfix pkgconfig ssl tar:xz
+BROKEN_SSL= openssl30 openssl31
+BROKEN_SSL_REASON= Uses OpenSSL 3.0.0 deprecated BIO_s_file_internal
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -118,8 +120,8 @@ CONFIGURE_ARGS+= --disable-dc
post-patch:
@${REINPLACE_CMD} -e 's/RTF_WASCLONED/0x20000/' ${WRKSRC}/src/ptlib/unix/socket.cxx
-#pre-configure:
-# (cd ${WRKSRC}/plugins/ && ${AUTORECONF} -fi)
+pre-configure:
+ (cd ${WRKSRC}/plugins/ && ${AUTORECONF} -fi)
post-install:
${LN} -sf libpt.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/libpt.so.${PVERSION_MAJOR}